remove inactive svn keyword
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
56 - expose mtail.py as simply mtail
57
58 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
59 - plc-kml.py now has support for nodegroups
60
61 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
62 - use nodeimage package instead of deprecated bootstrapfs
63 - has systemd-friendly startup script
64 - plc_reload moved to functions/ - no more service plc reload
65 - no svn keywords anymore
66
67 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
68 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
69
70 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
71 - new settings for myslice (comon&tophat) and monitor (db)
72 - removed mentions of chroot in description
73 - can redo myplc-docs on broken f12-latex
74 - set short_open_tag in php.ini
75 - fixes in gen-sites-xml (is that still used ?)
76 - partial-repo.sh has moved to 'build' where it more belongs
77 - tweaks in convenience tool 'mtail'
78
79 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
80 - fixed changelog, no change from 5.0-16
81
82 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
83 - requires ed for the plc.d/packages step
84 - sirius initscript to handle stop and restart
85
86 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
87 - ignore steps in db-config.d if they have a '.' or '~' in their name
88
89 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
90 - can redo myplc-docs without the doc for monitor
91
92 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
93 - no semantic change - just fixed specfile for git URL
94
95 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
96 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
97
98 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
99 - add missing files to rpm package
100
101 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
102 - mtail.py -s for SFA
103 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
104
105 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
106 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
107
108 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
109 - plc-config-tty now has a validator on booleans
110 - e.g. entering 'True' now is rejected rather than silently recording 'false'
111
112 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
113 - disable mod_wsgi
114
115 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
116 - module name changes
117 - start wsgi support
118
119 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
120 - new setting PLC_RESERVATION_GRANULARITY
121
122 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
123 - * partial-repo.sh script
124 - * preserve key along with certificates
125
126 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
127 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
128
129 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
130 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
131 - new OMF category in the config
132 - create the drl system slice
133
134 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
135 - first working version of 5.0:
136 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
137 - nodefamily is 3-fold with pldistro-fcdistro-arch
138 - new PLC_FLAVOUR config category
139 - reviewed module layout
140 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
141
142 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
143 - support for fedora 12
144 - new package myplc-config for use by sfa
145 - drupal user registration turned off
146
147 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
148 - - fix to make sure when API, BOOT, MONITOR are on the same
149 - machine as WWW that the SSL key,cert for WWW takes precedence.
150 - - Do proper setup for SSL CA certficate to be used as the server
151 - chain.
152
153 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
154 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
155
156 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
157 - depend on pcucontrol
158
159 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
160 - * validate input according to type in plc_config
161 - * added the _genicw system slice
162 - * add tag types for sites and persons
163 - * add new tags for nodes and slices for exemption from myops
164
165 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
166 - turn off drupal on a box that acts as BOOT server but not as WWW server
167 - cleanup some obsolete code for old chroot-jail packaging in the process
168 - new bootcd-kernel script for keeping bootcd variants up2date
169
170 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
171 - Make the /etc/hosts manipulation optional.
172
173 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
174 - Fix SetRole.
175
176 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
177 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
178 - into the DB.
179 - - Added the root ssh key handling support back into plc.d/ssh and the
180 - default xml file.  This should be identical to the way it was in
181 - rc12.
182 - - Added support in the db-config.d/01-init script to register the root
183 - ssh public key with the default administrator.  In this way the root
184 - ssh key will make it into the root account on the nodes by means of
185 - NodeManager's specialaccounts plugin.
186
187 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
188 - db-config ignores sliver tags
189 - sirius's db-config script renamed (was sirious)
190
191 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
192 - fix for silverauth - missing tag types now created at plc startup time
193
194 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
195 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
196
197 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
198 - companion to NM's specialaccounts plugin
199 - do not generate /etc/planetlab/root_ssh_key* anymore
200 - remove related config. variables and conf_files
201
202 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
203 - clarified description text to refer only to plcrt and not other optional
204 - packages.
205
206 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
207 - fixed a bug setting slice multiple attributes with the same tag name
208
209 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
210 - SSL setup for monitor box, and related new config variables
211 - new conf_file for /etc/planetlab/extensions
212 - various tweaks in db-config internals, about initscripts among others
213 - also more messages defined in the db
214
215 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
216 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
217
218 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
219 - bugfix in db-config, tag 4.3-19 would not fly
220
221 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
222 - Refactored db-config into snippets in db-config.d/.
223
224 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
225 - oops, tag 4.3-17 was broken and would not work
226
227 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
228 - bugfix - escape sequences inserted in xml configs
229
230 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
231 - Handle db-config.d files properly.
232
233 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
234 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
235 - than the log file
236 - - Fix db-config to be a bit more cautious when
237 - /etc/planetlab/db-config.d doesn't exist
238 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
239 - .orig files.
240 - - Refactor generic plc-config-tty code into plc_config.py.
241 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
242 - and the list of validated variables and the corresponding
243 - validator() function. This refactoring lets one reuse plc_config.py
244 - as a generic cmdline configuration tool for highly customer MyPLC
245 - like software.
246
247 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
248 - update PCU Type descriptions.
249 - updates to init scripts
250
251 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
252 - requires monitor-pcucontrol so register-wizard can work
253
254 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
255 - cleaned up plc-config-tty, no more need to configure plc-devel
256
257 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
258 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
259
260 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
261 - tighter right permissions on site_admin's authorized keys for more robustness
262
263 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
264 - fix issue in db-config that prevented correct operation
265
266 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
267 - remove support for chroot-based packaging - no crond nor syslog step anymore
268 - plc init script now named plc.init instead of former guest.init
269
270 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
271 - add Monitor to docs build
272
273 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
274 - plc_config.py and plc-config-tty: generalized to work for more diverse
275 - MyPLC configurations.
276 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
277 - deployments and increase the memory limits in php.ini
278 - plc.d/crond: add --full option to vacuumdb
279
280 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
281 - avoid generating ssl certificates for disabled services among www api boot
282
283 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
284 - cleaned up old entries in db-config
285 - mtail more robust
286
287 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
288 - php include path tweaked for plekit includes
289 - reviewed myplc (fka native) packaging dependencies
290 - renumbered 4.3
291
292 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
293 - rename myplc into myplc-chroot and myplc-native into myplc
294 - new settings (shortname & hrn_root) for local peer
295
296
297 %define module_current_branch 4.3