Setting tag myplc-5.2-2
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.2
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
56 - fix typo in check-hrns - used to print 'host' while dealing with persons
57
58 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
59 - supports httpd config for either mod_python (preferred) or mod_wsgi
60 - requires mod_wsgi on f18 only, otherwise mod_python
61 - supports httpd config for apache 2.4 (f18)
62 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
63
64 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
65 - bugfix in check-vsys-defaults.py
66
67 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
68 - define open_basedir in php.ini to stop confidentiality leak
69 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
70 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
71 - new utilities check-hrns.py and check-vsys-defaults.py
72
73 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
74 - set TimeoutSec to 300 in plc.service
75 - remove ref to deprecated svn $URL$ in db-config usage
76
77 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
78 - expose mtail.py as simply mtail
79
80 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
81 - plc-kml.py now has support for nodegroups
82
83 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
84 - use nodeimage package instead of deprecated bootstrapfs
85 - has systemd-friendly startup script
86 - plc_reload moved to functions/ - no more service plc reload
87 - no svn keywords anymore
88
89 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
90 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
91
92 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
93 - new settings for myslice (comon&tophat) and monitor (db)
94 - removed mentions of chroot in description
95 - can redo myplc-docs on broken f12-latex
96 - set short_open_tag in php.ini
97 - fixes in gen-sites-xml (is that still used ?)
98 - partial-repo.sh has moved to 'build' where it more belongs
99 - tweaks in convenience tool 'mtail'
100
101 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
102 - fixed changelog, no change from 5.0-16
103
104 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
105 - requires ed for the plc.d/packages step
106 - sirius initscript to handle stop and restart
107
108 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
109 - ignore steps in db-config.d if they have a '.' or '~' in their name
110
111 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
112 - can redo myplc-docs without the doc for monitor
113
114 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
115 - no semantic change - just fixed specfile for git URL
116
117 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
118 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
119
120 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
121 - add missing files to rpm package
122
123 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
124 - mtail.py -s for SFA
125 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
126
127 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
128 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
129
130 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
131 - plc-config-tty now has a validator on booleans
132 - e.g. entering 'True' now is rejected rather than silently recording 'false'
133
134 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
135 - disable mod_wsgi
136
137 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
138 - module name changes
139 - start wsgi support
140
141 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
142 - new setting PLC_RESERVATION_GRANULARITY
143
144 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
145 - * partial-repo.sh script
146 - * preserve key along with certificates
147
148 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
149 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
150
151 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
152 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
153 - new OMF category in the config
154 - create the drl system slice
155
156 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
157 - first working version of 5.0:
158 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
159 - nodefamily is 3-fold with pldistro-fcdistro-arch
160 - new PLC_FLAVOUR config category
161 - reviewed module layout
162 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
163
164 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
165 - support for fedora 12
166 - new package myplc-config for use by sfa
167 - drupal user registration turned off
168
169 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
170 - - fix to make sure when API, BOOT, MONITOR are on the same
171 - machine as WWW that the SSL key,cert for WWW takes precedence.
172 - - Do proper setup for SSL CA certficate to be used as the server
173 - chain.
174
175 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
176 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
177
178 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
179 - depend on pcucontrol
180
181 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
182 - * validate input according to type in plc_config
183 - * added the _genicw system slice
184 - * add tag types for sites and persons
185 - * add new tags for nodes and slices for exemption from myops
186
187 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
188 - turn off drupal on a box that acts as BOOT server but not as WWW server
189 - cleanup some obsolete code for old chroot-jail packaging in the process
190 - new bootcd-kernel script for keeping bootcd variants up2date
191
192 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
193 - Make the /etc/hosts manipulation optional.
194
195 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
196 - Fix SetRole.
197
198 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
199 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
200 - into the DB.
201 - - Added the root ssh key handling support back into plc.d/ssh and the
202 - default xml file.  This should be identical to the way it was in
203 - rc12.
204 - - Added support in the db-config.d/01-init script to register the root
205 - ssh public key with the default administrator.  In this way the root
206 - ssh key will make it into the root account on the nodes by means of
207 - NodeManager's specialaccounts plugin.
208
209 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
210 - db-config ignores sliver tags
211 - sirius's db-config script renamed (was sirious)
212
213 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
214 - fix for silverauth - missing tag types now created at plc startup time
215
216 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
217 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
218
219 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
220 - companion to NM's specialaccounts plugin
221 - do not generate /etc/planetlab/root_ssh_key* anymore
222 - remove related config. variables and conf_files
223
224 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
225 - clarified description text to refer only to plcrt and not other optional
226 - packages.
227
228 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
229 - fixed a bug setting slice multiple attributes with the same tag name
230
231 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
232 - SSL setup for monitor box, and related new config variables
233 - new conf_file for /etc/planetlab/extensions
234 - various tweaks in db-config internals, about initscripts among others
235 - also more messages defined in the db
236
237 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
238 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
239
240 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
241 - bugfix in db-config, tag 4.3-19 would not fly
242
243 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
244 - Refactored db-config into snippets in db-config.d/.
245
246 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
247 - oops, tag 4.3-17 was broken and would not work
248
249 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
250 - bugfix - escape sequences inserted in xml configs
251
252 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
253 - Handle db-config.d files properly.
254
255 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
256 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
257 - than the log file
258 - - Fix db-config to be a bit more cautious when
259 - /etc/planetlab/db-config.d doesn't exist
260 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
261 - .orig files.
262 - - Refactor generic plc-config-tty code into plc_config.py.
263 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
264 - and the list of validated variables and the corresponding
265 - validator() function. This refactoring lets one reuse plc_config.py
266 - as a generic cmdline configuration tool for highly customer MyPLC
267 - like software.
268
269 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
270 - update PCU Type descriptions.
271 - updates to init scripts
272
273 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
274 - requires monitor-pcucontrol so register-wizard can work
275
276 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
277 - cleaned up plc-config-tty, no more need to configure plc-devel
278
279 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
280 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
281
282 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
283 - tighter right permissions on site_admin's authorized keys for more robustness
284
285 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
286 - fix issue in db-config that prevented correct operation
287
288 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
289 - remove support for chroot-based packaging - no crond nor syslog step anymore
290 - plc init script now named plc.init instead of former guest.init
291
292 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
293 - add Monitor to docs build
294
295 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
296 - plc_config.py and plc-config-tty: generalized to work for more diverse
297 - MyPLC configurations.
298 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
299 - deployments and increase the memory limits in php.ini
300 - plc.d/crond: add --full option to vacuumdb
301
302 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
303 - avoid generating ssl certificates for disabled services among www api boot
304
305 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
306 - cleaned up old entries in db-config
307 - mtail more robust
308
309 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
310 - php include path tweaked for plekit includes
311 - reviewed myplc (fka native) packaging dependencies
312 - renumbered 4.3
313
314 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
315 - rename myplc into myplc-chroot and myplc-native into myplc
316 - new settings (shortname & hrn_root) for local peer
317
318
319 %define module_current_branch 4.3