bump major to 5.2
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.1
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
56 - bugfix in check-vsys-defaults.py
57
58 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
59 - define open_basedir in php.ini to stop confidentiality leak
60 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
61 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
62 - new utilities check-hrns.py and check-vsys-defaults.py
63
64 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
65 - set TimeoutSec to 300 in plc.service
66 - remove ref to deprecated svn $URL$ in db-config usage
67
68 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
69 - expose mtail.py as simply mtail
70
71 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
72 - plc-kml.py now has support for nodegroups
73
74 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
75 - use nodeimage package instead of deprecated bootstrapfs
76 - has systemd-friendly startup script
77 - plc_reload moved to functions/ - no more service plc reload
78 - no svn keywords anymore
79
80 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
81 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
82
83 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
84 - new settings for myslice (comon&tophat) and monitor (db)
85 - removed mentions of chroot in description
86 - can redo myplc-docs on broken f12-latex
87 - set short_open_tag in php.ini
88 - fixes in gen-sites-xml (is that still used ?)
89 - partial-repo.sh has moved to 'build' where it more belongs
90 - tweaks in convenience tool 'mtail'
91
92 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
93 - fixed changelog, no change from 5.0-16
94
95 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
96 - requires ed for the plc.d/packages step
97 - sirius initscript to handle stop and restart
98
99 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
100 - ignore steps in db-config.d if they have a '.' or '~' in their name
101
102 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
103 - can redo myplc-docs without the doc for monitor
104
105 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
106 - no semantic change - just fixed specfile for git URL
107
108 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
109 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
110
111 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
112 - add missing files to rpm package
113
114 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
115 - mtail.py -s for SFA
116 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
117
118 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
119 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
120
121 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
122 - plc-config-tty now has a validator on booleans
123 - e.g. entering 'True' now is rejected rather than silently recording 'false'
124
125 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
126 - disable mod_wsgi
127
128 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
129 - module name changes
130 - start wsgi support
131
132 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
133 - new setting PLC_RESERVATION_GRANULARITY
134
135 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
136 - * partial-repo.sh script
137 - * preserve key along with certificates
138
139 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
140 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
141
142 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
143 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
144 - new OMF category in the config
145 - create the drl system slice
146
147 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
148 - first working version of 5.0:
149 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
150 - nodefamily is 3-fold with pldistro-fcdistro-arch
151 - new PLC_FLAVOUR config category
152 - reviewed module layout
153 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
154
155 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
156 - support for fedora 12
157 - new package myplc-config for use by sfa
158 - drupal user registration turned off
159
160 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
161 - - fix to make sure when API, BOOT, MONITOR are on the same
162 - machine as WWW that the SSL key,cert for WWW takes precedence.
163 - - Do proper setup for SSL CA certficate to be used as the server
164 - chain.
165
166 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
167 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
168
169 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
170 - depend on pcucontrol
171
172 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
173 - * validate input according to type in plc_config
174 - * added the _genicw system slice
175 - * add tag types for sites and persons
176 - * add new tags for nodes and slices for exemption from myops
177
178 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
179 - turn off drupal on a box that acts as BOOT server but not as WWW server
180 - cleanup some obsolete code for old chroot-jail packaging in the process
181 - new bootcd-kernel script for keeping bootcd variants up2date
182
183 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
184 - Make the /etc/hosts manipulation optional.
185
186 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
187 - Fix SetRole.
188
189 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
190 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
191 - into the DB.
192 - - Added the root ssh key handling support back into plc.d/ssh and the
193 - default xml file.  This should be identical to the way it was in
194 - rc12.
195 - - Added support in the db-config.d/01-init script to register the root
196 - ssh public key with the default administrator.  In this way the root
197 - ssh key will make it into the root account on the nodes by means of
198 - NodeManager's specialaccounts plugin.
199
200 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
201 - db-config ignores sliver tags
202 - sirius's db-config script renamed (was sirious)
203
204 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
205 - fix for silverauth - missing tag types now created at plc startup time
206
207 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
208 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
209
210 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
211 - companion to NM's specialaccounts plugin
212 - do not generate /etc/planetlab/root_ssh_key* anymore
213 - remove related config. variables and conf_files
214
215 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
216 - clarified description text to refer only to plcrt and not other optional
217 - packages.
218
219 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
220 - fixed a bug setting slice multiple attributes with the same tag name
221
222 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
223 - SSL setup for monitor box, and related new config variables
224 - new conf_file for /etc/planetlab/extensions
225 - various tweaks in db-config internals, about initscripts among others
226 - also more messages defined in the db
227
228 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
229 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
230
231 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
232 - bugfix in db-config, tag 4.3-19 would not fly
233
234 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
235 - Refactored db-config into snippets in db-config.d/.
236
237 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
238 - oops, tag 4.3-17 was broken and would not work
239
240 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
241 - bugfix - escape sequences inserted in xml configs
242
243 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
244 - Handle db-config.d files properly.
245
246 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
247 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
248 - than the log file
249 - - Fix db-config to be a bit more cautious when
250 - /etc/planetlab/db-config.d doesn't exist
251 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
252 - .orig files.
253 - - Refactor generic plc-config-tty code into plc_config.py.
254 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
255 - and the list of validated variables and the corresponding
256 - validator() function. This refactoring lets one reuse plc_config.py
257 - as a generic cmdline configuration tool for highly customer MyPLC
258 - like software.
259
260 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
261 - update PCU Type descriptions.
262 - updates to init scripts
263
264 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
265 - requires monitor-pcucontrol so register-wizard can work
266
267 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
268 - cleaned up plc-config-tty, no more need to configure plc-devel
269
270 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
271 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
272
273 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
274 - tighter right permissions on site_admin's authorized keys for more robustness
275
276 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
277 - fix issue in db-config that prevented correct operation
278
279 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
280 - remove support for chroot-based packaging - no crond nor syslog step anymore
281 - plc init script now named plc.init instead of former guest.init
282
283 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
284 - add Monitor to docs build
285
286 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
287 - plc_config.py and plc-config-tty: generalized to work for more diverse
288 - MyPLC configurations.
289 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
290 - deployments and increase the memory limits in php.ini
291 - plc.d/crond: add --full option to vacuumdb
292
293 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
294 - avoid generating ssl certificates for disabled services among www api boot
295
296 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
297 - cleaned up old entries in db-config
298 - mtail more robust
299
300 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
301 - php include path tweaked for plekit includes
302 - reviewed myplc (fka native) packaging dependencies
303 - renumbered 4.3
304
305 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
306 - rename myplc into myplc-chroot and myplc-native into myplc
307 - new settings (shortname & hrn_root) for local peer
308
309
310 %define module_current_branch 4.3