Setting tag myplc-4.3-51
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 51
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
61 - generate plc_config.rb via plc-config
62
63 * Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
64 - Do not preserve /etc/planetlab on upgrade operations
65
66 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
67 - Remove Monitor references from spec file
68
69 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
70 - Introduce staticroute tagtype
71
72 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
73 - attempt to fix small glitches
74
75 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
76 - enable short_open_tag for backward compatibility
77
78 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
79 - Cherry-pick PHP5 timezone fix form master
80
81 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
82 - pick the greatest version as a kernel
83
84 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
85 - handle directory name changes for myplc-docs package as well
86
87 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
88 - handle directory name changes
89
90 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
91 - Use correct resolv.conf file.
92
93 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
94 - Make dnsmasq usable.
95
96 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
97 - Allow dnsmasq configuration to be extended.
98
99 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
100 - Add DRL slice.
101 - Generalize bootcd-kernel.
102
103 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
104 - support for fedora 12
105 - new package myplc-config for use by sfa
106 - drupal user registration turned off
107
108 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
109 - - fix to make sure when API, BOOT, MONITOR are on the same
110 - machine as WWW that the SSL key,cert for WWW takes precedence.
111 - - Do proper setup for SSL CA certficate to be used as the server
112 - chain.
113
114 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
115 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
116
117 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
118 - depend on pcucontrol
119
120 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
121 - * validate input according to type in plc_config
122 - * added the _genicw system slice
123 - * add tag types for sites and persons
124 - * add new tags for nodes and slices for exemption from myops
125
126 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
127 - turn off drupal on a box that acts as BOOT server but not as WWW server
128 - cleanup some obsolete code for old chroot-jail packaging in the process
129 - new bootcd-kernel script for keeping bootcd variants up2date
130
131 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
132 - Make the /etc/hosts manipulation optional.
133
134 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
135 - Fix SetRole.
136
137 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
138 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
139 - into the DB.
140 - - Added the root ssh key handling support back into plc.d/ssh and the
141 - default xml file.  This should be identical to the way it was in
142 - rc12.
143 - - Added support in the db-config.d/01-init script to register the root
144 - ssh public key with the default administrator.  In this way the root
145 - ssh key will make it into the root account on the nodes by means of
146 - NodeManager's specialaccounts plugin.
147
148 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
149 - db-config ignores sliver tags
150 - sirius's db-config script renamed (was sirious)
151
152 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
153 - fix for silverauth - missing tag types now created at plc startup time
154
155 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
156 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
157
158 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
159 - companion to NM's specialaccounts plugin
160 - do not generate /etc/planetlab/root_ssh_key* anymore
161 - remove related config. variables and conf_files
162
163 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
164 - clarified description text to refer only to plcrt and not other optional
165 - packages.
166
167 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
168 - fixed a bug setting slice multiple attributes with the same tag name
169
170 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
171 - SSL setup for monitor box, and related new config variables
172 - new conf_file for /etc/planetlab/extensions
173 - various tweaks in db-config internals, about initscripts among others
174 - also more messages defined in the db
175
176 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
177 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
178
179 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
180 - bugfix in db-config, tag 4.3-19 would not fly
181
182 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
183 - Refactored db-config into snippets in db-config.d/.
184
185 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
186 - oops, tag 4.3-17 was broken and would not work
187
188 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
189 - bugfix - escape sequences inserted in xml configs
190
191 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
192 - Handle db-config.d files properly.
193
194 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
195 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
196 - than the log file
197 - - Fix db-config to be a bit more cautious when
198 - /etc/planetlab/db-config.d doesn't exist
199 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
200 - .orig files.
201 - - Refactor generic plc-config-tty code into plc_config.py.
202 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
203 - and the list of validated variables and the corresponding
204 - validator() function. This refactoring lets one reuse plc_config.py
205 - as a generic cmdline configuration tool for highly customer MyPLC
206 - like software.
207
208 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
209 - update PCU Type descriptions.
210 - updates to init scripts
211
212 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
213 - requires monitor-pcucontrol so register-wizard can work
214
215 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
216 - cleaned up plc-config-tty, no more need to configure plc-devel
217
218 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
219 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
220
221 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
222 - tighter right permissions on site_admin's authorized keys for more robustness
223
224 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
225 - fix issue in db-config that prevented correct operation
226
227 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
228 - remove support for chroot-based packaging - no crond nor syslog step anymore
229 - plc init script now named plc.init instead of former guest.init
230
231 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
232 - add Monitor to docs build
233
234 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
235 - plc_config.py and plc-config-tty: generalized to work for more diverse
236 - MyPLC configurations.
237 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
238 - deployments and increase the memory limits in php.ini
239 - plc.d/crond: add --full option to vacuumdb
240
241 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
242 - avoid generating ssl certificates for disabled services among www api boot
243
244 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
245 - cleaned up old entries in db-config
246 - mtail more robust
247
248 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
249 - php include path tweaked for plekit includes
250 - reviewed myplc (fka native) packaging dependencies
251 - renumbered 4.3
252
253 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
254 - rename myplc into myplc-chroot and myplc-native into myplc
255 - new settings (shortname & hrn_root) for local peer
256