Setting tag myplc-5.3-1
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.3
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
56 - review check-hrns for plcapi-5.3
57 - add PLC_HRN_ROOT in usual plc-config-tty's settings
58
59 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
60 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
61 - add an rpm-sign dependency on feedora>=16
62
63 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
64 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
65
66 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
67 - plc.d/gpg now does not rm /dev/random but preserves it
68 - this is because libvirt won't let us run mknod
69
70 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
71 - fix typo in check-hrns - used to print 'host' while dealing with persons
72
73 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
74 - supports httpd config for either mod_python (preferred) or mod_wsgi
75 - requires mod_wsgi on f18 only, otherwise mod_python
76 - supports httpd config for apache 2.4 (f18)
77 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
78
79 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
80 - bugfix in check-vsys-defaults.py
81
82 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
83 - define open_basedir in php.ini to stop confidentiality leak
84 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
85 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
86 - new utilities check-hrns.py and check-vsys-defaults.py
87
88 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
89 - set TimeoutSec to 300 in plc.service
90 - remove ref to deprecated svn $URL$ in db-config usage
91
92 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
93 - expose mtail.py as simply mtail
94
95 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
96 - plc-kml.py now has support for nodegroups
97
98 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
99 - use nodeimage package instead of deprecated bootstrapfs
100 - has systemd-friendly startup script
101 - plc_reload moved to functions/ - no more service plc reload
102 - no svn keywords anymore
103
104 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
105 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
106
107 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
108 - new settings for myslice (comon&tophat) and monitor (db)
109 - removed mentions of chroot in description
110 - can redo myplc-docs on broken f12-latex
111 - set short_open_tag in php.ini
112 - fixes in gen-sites-xml (is that still used ?)
113 - partial-repo.sh has moved to 'build' where it more belongs
114 - tweaks in convenience tool 'mtail'
115
116 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
117 - fixed changelog, no change from 5.0-16
118
119 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
120 - requires ed for the plc.d/packages step
121 - sirius initscript to handle stop and restart
122
123 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
124 - ignore steps in db-config.d if they have a '.' or '~' in their name
125
126 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
127 - can redo myplc-docs without the doc for monitor
128
129 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
130 - no semantic change - just fixed specfile for git URL
131
132 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
133 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
134
135 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
136 - add missing files to rpm package
137
138 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
139 - mtail.py -s for SFA
140 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
141
142 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
143 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
144
145 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
146 - plc-config-tty now has a validator on booleans
147 - e.g. entering 'True' now is rejected rather than silently recording 'false'
148
149 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
150 - disable mod_wsgi
151
152 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
153 - module name changes
154 - start wsgi support
155
156 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
157 - new setting PLC_RESERVATION_GRANULARITY
158
159 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
160 - * partial-repo.sh script
161 - * preserve key along with certificates
162
163 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
164 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
165
166 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
167 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
168 - new OMF category in the config
169 - create the drl system slice
170
171 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
172 - first working version of 5.0:
173 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
174 - nodefamily is 3-fold with pldistro-fcdistro-arch
175 - new PLC_FLAVOUR config category
176 - reviewed module layout
177 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
178
179 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
180 - support for fedora 12
181 - new package myplc-config for use by sfa
182 - drupal user registration turned off
183
184 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
185 - - fix to make sure when API, BOOT, MONITOR are on the same
186 - machine as WWW that the SSL key,cert for WWW takes precedence.
187 - - Do proper setup for SSL CA certficate to be used as the server
188 - chain.
189
190 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
191 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
192
193 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
194 - depend on pcucontrol
195
196 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
197 - * validate input according to type in plc_config
198 - * added the _genicw system slice
199 - * add tag types for sites and persons
200 - * add new tags for nodes and slices for exemption from myops
201
202 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
203 - turn off drupal on a box that acts as BOOT server but not as WWW server
204 - cleanup some obsolete code for old chroot-jail packaging in the process
205 - new bootcd-kernel script for keeping bootcd variants up2date
206
207 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
208 - Make the /etc/hosts manipulation optional.
209
210 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
211 - Fix SetRole.
212
213 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
214 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
215 - into the DB.
216 - - Added the root ssh key handling support back into plc.d/ssh and the
217 - default xml file.  This should be identical to the way it was in
218 - rc12.
219 - - Added support in the db-config.d/01-init script to register the root
220 - ssh public key with the default administrator.  In this way the root
221 - ssh key will make it into the root account on the nodes by means of
222 - NodeManager's specialaccounts plugin.
223
224 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
225 - db-config ignores sliver tags
226 - sirius's db-config script renamed (was sirious)
227
228 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
229 - fix for silverauth - missing tag types now created at plc startup time
230
231 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
232 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
233
234 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
235 - companion to NM's specialaccounts plugin
236 - do not generate /etc/planetlab/root_ssh_key* anymore
237 - remove related config. variables and conf_files
238
239 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
240 - clarified description text to refer only to plcrt and not other optional
241 - packages.
242
243 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
244 - fixed a bug setting slice multiple attributes with the same tag name
245
246 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
247 - SSL setup for monitor box, and related new config variables
248 - new conf_file for /etc/planetlab/extensions
249 - various tweaks in db-config internals, about initscripts among others
250 - also more messages defined in the db
251
252 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
253 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
254
255 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
256 - bugfix in db-config, tag 4.3-19 would not fly
257
258 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
259 - Refactored db-config into snippets in db-config.d/.
260
261 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
262 - oops, tag 4.3-17 was broken and would not work
263
264 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
265 - bugfix - escape sequences inserted in xml configs
266
267 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
268 - Handle db-config.d files properly.
269
270 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
271 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
272 - than the log file
273 - - Fix db-config to be a bit more cautious when
274 - /etc/planetlab/db-config.d doesn't exist
275 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
276 - .orig files.
277 - - Refactor generic plc-config-tty code into plc_config.py.
278 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
279 - and the list of validated variables and the corresponding
280 - validator() function. This refactoring lets one reuse plc_config.py
281 - as a generic cmdline configuration tool for highly customer MyPLC
282 - like software.
283
284 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
285 - update PCU Type descriptions.
286 - updates to init scripts
287
288 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
289 - requires monitor-pcucontrol so register-wizard can work
290
291 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
292 - cleaned up plc-config-tty, no more need to configure plc-devel
293
294 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
295 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
296
297 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
298 - tighter right permissions on site_admin's authorized keys for more robustness
299
300 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
301 - fix issue in db-config that prevented correct operation
302
303 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
304 - remove support for chroot-based packaging - no crond nor syslog step anymore
305 - plc init script now named plc.init instead of former guest.init
306
307 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
308 - add Monitor to docs build
309
310 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
311 - plc_config.py and plc-config-tty: generalized to work for more diverse
312 - MyPLC configurations.
313 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
314 - deployments and increase the memory limits in php.ini
315 - plc.d/crond: add --full option to vacuumdb
316
317 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
318 - avoid generating ssl certificates for disabled services among www api boot
319
320 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
321 - cleaned up old entries in db-config
322 - mtail more robust
323
324 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
325 - php include path tweaked for plekit includes
326 - reviewed myplc (fka native) packaging dependencies
327 - renumbered 4.3
328
329 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
330 - rename myplc into myplc-chroot and myplc-native into myplc
331 - new settings (shortname & hrn_root) for local peer
332
333
334 %define module_current_branch 4.3