Setting tag myplc-5.1-2
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.1
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
56 - plc-kml.py now has support for nodegroups
57
58 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
59 - use nodeimage package instead of deprecated bootstrapfs
60 - has systemd-friendly startup script
61 - plc_reload moved to functions/ - no more service plc reload
62 - no svn keywords anymore
63
64 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
65 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
66
67 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
68 - new settings for myslice (comon&tophat) and monitor (db)
69 - removed mentions of chroot in description
70 - can redo myplc-docs on broken f12-latex
71 - set short_open_tag in php.ini
72 - fixes in gen-sites-xml (is that still used ?)
73 - partial-repo.sh has moved to 'build' where it more belongs
74 - tweaks in convenience tool 'mtail'
75
76 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
77 - fixed changelog, no change from 5.0-16
78
79 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
80 - requires ed for the plc.d/packages step
81 - sirius initscript to handle stop and restart
82
83 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
84 - ignore steps in db-config.d if they have a '.' or '~' in their name
85
86 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
87 - can redo myplc-docs without the doc for monitor
88
89 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
90 - no semantic change - just fixed specfile for git URL
91
92 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
93 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
94
95 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
96 - add missing files to rpm package
97
98 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
99 - mtail.py -s for SFA
100 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
101
102 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
103 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
104
105 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
106 - plc-config-tty now has a validator on booleans
107 - e.g. entering 'True' now is rejected rather than silently recording 'false'
108
109 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
110 - disable mod_wsgi
111
112 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
113 - module name changes
114 - start wsgi support
115
116 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
117 - new setting PLC_RESERVATION_GRANULARITY
118
119 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
120 - * partial-repo.sh script
121 - * preserve key along with certificates
122
123 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
124 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
125
126 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
127 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
128 - new OMF category in the config
129 - create the drl system slice
130
131 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
132 - first working version of 5.0:
133 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
134 - nodefamily is 3-fold with pldistro-fcdistro-arch
135 - new PLC_FLAVOUR config category
136 - reviewed module layout
137 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
138
139 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
140 - support for fedora 12
141 - new package myplc-config for use by sfa
142 - drupal user registration turned off
143
144 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
145 - - fix to make sure when API, BOOT, MONITOR are on the same
146 - machine as WWW that the SSL key,cert for WWW takes precedence.
147 - - Do proper setup for SSL CA certficate to be used as the server
148 - chain.
149
150 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
151 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
152
153 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
154 - depend on pcucontrol
155
156 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
157 - * validate input according to type in plc_config
158 - * added the _genicw system slice
159 - * add tag types for sites and persons
160 - * add new tags for nodes and slices for exemption from myops
161
162 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
163 - turn off drupal on a box that acts as BOOT server but not as WWW server
164 - cleanup some obsolete code for old chroot-jail packaging in the process
165 - new bootcd-kernel script for keeping bootcd variants up2date
166
167 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
168 - Make the /etc/hosts manipulation optional.
169
170 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
171 - Fix SetRole.
172
173 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
174 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
175 - into the DB.
176 - - Added the root ssh key handling support back into plc.d/ssh and the
177 - default xml file.  This should be identical to the way it was in
178 - rc12.
179 - - Added support in the db-config.d/01-init script to register the root
180 - ssh public key with the default administrator.  In this way the root
181 - ssh key will make it into the root account on the nodes by means of
182 - NodeManager's specialaccounts plugin.
183
184 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
185 - db-config ignores sliver tags
186 - sirius's db-config script renamed (was sirious)
187
188 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
189 - fix for silverauth - missing tag types now created at plc startup time
190
191 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
192 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
193
194 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
195 - companion to NM's specialaccounts plugin
196 - do not generate /etc/planetlab/root_ssh_key* anymore
197 - remove related config. variables and conf_files
198
199 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
200 - clarified description text to refer only to plcrt and not other optional
201 - packages.
202
203 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
204 - fixed a bug setting slice multiple attributes with the same tag name
205
206 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
207 - SSL setup for monitor box, and related new config variables
208 - new conf_file for /etc/planetlab/extensions
209 - various tweaks in db-config internals, about initscripts among others
210 - also more messages defined in the db
211
212 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
213 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
214
215 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
216 - bugfix in db-config, tag 4.3-19 would not fly
217
218 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
219 - Refactored db-config into snippets in db-config.d/.
220
221 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
222 - oops, tag 4.3-17 was broken and would not work
223
224 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
225 - bugfix - escape sequences inserted in xml configs
226
227 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
228 - Handle db-config.d files properly.
229
230 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
231 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
232 - than the log file
233 - - Fix db-config to be a bit more cautious when
234 - /etc/planetlab/db-config.d doesn't exist
235 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
236 - .orig files.
237 - - Refactor generic plc-config-tty code into plc_config.py.
238 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
239 - and the list of validated variables and the corresponding
240 - validator() function. This refactoring lets one reuse plc_config.py
241 - as a generic cmdline configuration tool for highly customer MyPLC
242 - like software.
243
244 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
245 - update PCU Type descriptions.
246 - updates to init scripts
247
248 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
249 - requires monitor-pcucontrol so register-wizard can work
250
251 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
252 - cleaned up plc-config-tty, no more need to configure plc-devel
253
254 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
255 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
256
257 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
258 - tighter right permissions on site_admin's authorized keys for more robustness
259
260 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
261 - fix issue in db-config that prevented correct operation
262
263 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
264 - remove support for chroot-based packaging - no crond nor syslog step anymore
265 - plc init script now named plc.init instead of former guest.init
266
267 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
268 - add Monitor to docs build
269
270 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
271 - plc_config.py and plc-config-tty: generalized to work for more diverse
272 - MyPLC configurations.
273 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
274 - deployments and increase the memory limits in php.ini
275 - plc.d/crond: add --full option to vacuumdb
276
277 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
278 - avoid generating ssl certificates for disabled services among www api boot
279
280 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
281 - cleaned up old entries in db-config
282 - mtail more robust
283
284 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
285 - php include path tweaked for plekit includes
286 - reviewed myplc (fka native) packaging dependencies
287 - renumbered 4.3
288
289 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
290 - rename myplc into myplc-chroot and myplc-native into myplc
291 - new settings (shortname & hrn_root) for local peer
292
293
294 %define module_current_branch 4.3