Setting tag myplc-7.0-0
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 7.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
56 - suitable for python3 on both f27 and f29
57
58 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
59 - takes care of creating plcapi log file
60
61 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
62 - tweaked renew_reminder for federation
63
64 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
65 - tweaks in check-hrns.py
66 - do not require PyXML any more
67
68 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
69 - review check-hrns for plcapi-5.3
70 - add PLC_HRN_ROOT in usual plc-config-tty's settings
71
72 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
73 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
74 - add an rpm-sign dependency on feedora>=16
75
76 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
77 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
78
79 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
80 - plc.d/gpg now does not rm /dev/random but preserves it
81 - this is because libvirt won't let us run mknod
82
83 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
84 - fix typo in check-hrns - used to print 'host' while dealing with persons
85
86 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
87 - supports httpd config for either mod_python (preferred) or mod_wsgi
88 - requires mod_wsgi on f18 only, otherwise mod_python
89 - supports httpd config for apache 2.4 (f18)
90 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
91
92 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
93 - bugfix in check-vsys-defaults.py
94
95 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
96 - define open_basedir in php.ini to stop confidentiality leak
97 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
98 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
99 - new utilities check-hrns.py and check-vsys-defaults.py
100
101 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
102 - set TimeoutSec to 300 in plc.service
103 - remove ref to deprecated svn $URL$ in db-config usage
104
105 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
106 - expose mtail.py as simply mtail
107
108 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
109 - plc-kml.py now has support for nodegroups
110
111 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
112 - use nodeimage package instead of deprecated bootstrapfs
113 - has systemd-friendly startup script
114 - plc_reload moved to functions/ - no more service plc reload
115 - no svn keywords anymore
116
117 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
118 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
119
120 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
121 - new settings for myslice (comon&tophat) and monitor (db)
122 - removed mentions of chroot in description
123 - can redo myplc-docs on broken f12-latex
124 - set short_open_tag in php.ini
125 - fixes in gen-sites-xml (is that still used ?)
126 - partial-repo.sh has moved to 'build' where it more belongs
127 - tweaks in convenience tool 'mtail'
128
129 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
130 - fixed changelog, no change from 5.0-16
131
132 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
133 - requires ed for the plc.d/packages step
134 - sirius initscript to handle stop and restart
135
136 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
137 - ignore steps in db-config.d if they have a '.' or '~' in their name
138
139 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
140 - can redo myplc-docs without the doc for monitor
141
142 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
143 - no semantic change - just fixed specfile for git URL
144
145 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
146 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
147
148 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
149 - add missing files to rpm package
150
151 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
152 - mtail.py -s for SFA
153 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
154
155 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
156 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
157
158 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
159 - plc-config-tty now has a validator on booleans
160 - e.g. entering 'True' now is rejected rather than silently recording 'false'
161
162 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
163 - disable mod_wsgi
164
165 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
166 - module name changes
167 - start wsgi support
168
169 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
170 - new setting PLC_RESERVATION_GRANULARITY
171
172 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
173 - * partial-repo.sh script
174 - * preserve key along with certificates
175
176 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
177 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
178
179 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
180 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
181 - new OMF category in the config
182 - create the drl system slice
183
184 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
185 - first working version of 5.0:
186 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
187 - nodefamily is 3-fold with pldistro-fcdistro-arch
188 - new PLC_FLAVOUR config category
189 - reviewed module layout
190 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
191
192 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
193 - support for fedora 12
194 - new package myplc-config for use by sfa
195 - drupal user registration turned off
196
197 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
198 - - fix to make sure when API, BOOT, MONITOR are on the same
199 - machine as WWW that the SSL key,cert for WWW takes precedence.
200 - - Do proper setup for SSL CA certficate to be used as the server
201 - chain.
202
203 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
204 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
205
206 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
207 - depend on pcucontrol
208
209 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
210 - * validate input according to type in plc_config
211 - * added the _genicw system slice
212 - * add tag types for sites and persons
213 - * add new tags for nodes and slices for exemption from myops
214
215 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
216 - turn off drupal on a box that acts as BOOT server but not as WWW server
217 - cleanup some obsolete code for old chroot-jail packaging in the process
218 - new bootcd-kernel script for keeping bootcd variants up2date
219
220 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
221 - Make the /etc/hosts manipulation optional.
222
223 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
224 - Fix SetRole.
225
226 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
227 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
228 - into the DB.
229 - - Added the root ssh key handling support back into plc.d/ssh and the
230 - default xml file.  This should be identical to the way it was in
231 - rc12.
232 - - Added support in the db-config.d/01-init script to register the root
233 - ssh public key with the default administrator.  In this way the root
234 - ssh key will make it into the root account on the nodes by means of
235 - NodeManager's specialaccounts plugin.
236
237 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
238 - db-config ignores sliver tags
239 - sirius's db-config script renamed (was sirious)
240
241 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
242 - fix for silverauth - missing tag types now created at plc startup time
243
244 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
245 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
246
247 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
248 - companion to NM's specialaccounts plugin
249 - do not generate /etc/planetlab/root_ssh_key* anymore
250 - remove related config. variables and conf_files
251
252 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
253 - clarified description text to refer only to plcrt and not other optional
254 - packages.
255
256 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
257 - fixed a bug setting slice multiple attributes with the same tag name
258
259 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
260 - SSL setup for monitor box, and related new config variables
261 - new conf_file for /etc/planetlab/extensions
262 - various tweaks in db-config internals, about initscripts among others
263 - also more messages defined in the db
264
265 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
266 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
267
268 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
269 - bugfix in db-config, tag 4.3-19 would not fly
270
271 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
272 - Refactored db-config into snippets in db-config.d/.
273
274 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
275 - oops, tag 4.3-17 was broken and would not work
276
277 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
278 - bugfix - escape sequences inserted in xml configs
279
280 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
281 - Handle db-config.d files properly.
282
283 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
284 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
285 - than the log file
286 - - Fix db-config to be a bit more cautious when
287 - /etc/planetlab/db-config.d doesn't exist
288 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
289 - .orig files.
290 - - Refactor generic plc-config-tty code into plc_config.py.
291 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
292 - and the list of validated variables and the corresponding
293 - validator() function. This refactoring lets one reuse plc_config.py
294 - as a generic cmdline configuration tool for highly customer MyPLC
295 - like software.
296
297 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
298 - update PCU Type descriptions.
299 - updates to init scripts
300
301 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
302 - requires monitor-pcucontrol so register-wizard can work
303
304 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
305 - cleaned up plc-config-tty, no more need to configure plc-devel
306
307 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
308 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
309
310 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
311 - tighter right permissions on site_admin's authorized keys for more robustness
312
313 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
314 - fix issue in db-config that prevented correct operation
315
316 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
317 - remove support for chroot-based packaging - no crond nor syslog step anymore
318 - plc init script now named plc.init instead of former guest.init
319
320 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
321 - add Monitor to docs build
322
323 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
324 - plc_config.py and plc-config-tty: generalized to work for more diverse
325 - MyPLC configurations.
326 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
327 - deployments and increase the memory limits in php.ini
328 - plc.d/crond: add --full option to vacuumdb
329
330 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
331 - avoid generating ssl certificates for disabled services among www api boot
332
333 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
334 - cleaned up old entries in db-config
335 - mtail more robust
336
337 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
338 - php include path tweaked for plekit includes
339 - reviewed myplc (fka native) packaging dependencies
340 - renumbered 4.3
341
342 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
343 - rename myplc into myplc-chroot and myplc-native into myplc
344 - new settings (shortname & hrn_root) for local peer
345
346
347 %define module_current_branch 4.3