fixes to the service file; + former stub /etc/init.d/plc becomes /usr/bin/plc-ctl
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.3
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
56 - takes care of creating plcapi log file
57
58 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
59 - tweaked renew_reminder for federation
60
61 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
62 - tweaks in check-hrns.py
63 - do not require PyXML any more
64
65 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
66 - review check-hrns for plcapi-5.3
67 - add PLC_HRN_ROOT in usual plc-config-tty's settings
68
69 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
70 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
71 - add an rpm-sign dependency on feedora>=16
72
73 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
74 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
75
76 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
77 - plc.d/gpg now does not rm /dev/random but preserves it
78 - this is because libvirt won't let us run mknod
79
80 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
81 - fix typo in check-hrns - used to print 'host' while dealing with persons
82
83 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
84 - supports httpd config for either mod_python (preferred) or mod_wsgi
85 - requires mod_wsgi on f18 only, otherwise mod_python
86 - supports httpd config for apache 2.4 (f18)
87 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
88
89 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
90 - bugfix in check-vsys-defaults.py
91
92 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
93 - define open_basedir in php.ini to stop confidentiality leak
94 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
95 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
96 - new utilities check-hrns.py and check-vsys-defaults.py
97
98 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
99 - set TimeoutSec to 300 in plc.service
100 - remove ref to deprecated svn $URL$ in db-config usage
101
102 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
103 - expose mtail.py as simply mtail
104
105 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
106 - plc-kml.py now has support for nodegroups
107
108 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
109 - use nodeimage package instead of deprecated bootstrapfs
110 - has systemd-friendly startup script
111 - plc_reload moved to functions/ - no more service plc reload
112 - no svn keywords anymore
113
114 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
115 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
116
117 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
118 - new settings for myslice (comon&tophat) and monitor (db)
119 - removed mentions of chroot in description
120 - can redo myplc-docs on broken f12-latex
121 - set short_open_tag in php.ini
122 - fixes in gen-sites-xml (is that still used ?)
123 - partial-repo.sh has moved to 'build' where it more belongs
124 - tweaks in convenience tool 'mtail'
125
126 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
127 - fixed changelog, no change from 5.0-16
128
129 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
130 - requires ed for the plc.d/packages step
131 - sirius initscript to handle stop and restart
132
133 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
134 - ignore steps in db-config.d if they have a '.' or '~' in their name
135
136 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
137 - can redo myplc-docs without the doc for monitor
138
139 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
140 - no semantic change - just fixed specfile for git URL
141
142 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
143 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
144
145 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
146 - add missing files to rpm package
147
148 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
149 - mtail.py -s for SFA
150 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
151
152 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
153 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
154
155 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
156 - plc-config-tty now has a validator on booleans
157 - e.g. entering 'True' now is rejected rather than silently recording 'false'
158
159 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
160 - disable mod_wsgi
161
162 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
163 - module name changes
164 - start wsgi support
165
166 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
167 - new setting PLC_RESERVATION_GRANULARITY
168
169 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
170 - * partial-repo.sh script
171 - * preserve key along with certificates
172
173 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
174 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
175
176 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
177 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
178 - new OMF category in the config
179 - create the drl system slice
180
181 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
182 - first working version of 5.0:
183 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
184 - nodefamily is 3-fold with pldistro-fcdistro-arch
185 - new PLC_FLAVOUR config category
186 - reviewed module layout
187 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
188
189 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
190 - support for fedora 12
191 - new package myplc-config for use by sfa
192 - drupal user registration turned off
193
194 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
195 - - fix to make sure when API, BOOT, MONITOR are on the same
196 - machine as WWW that the SSL key,cert for WWW takes precedence.
197 - - Do proper setup for SSL CA certficate to be used as the server
198 - chain.
199
200 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
201 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
202
203 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
204 - depend on pcucontrol
205
206 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
207 - * validate input according to type in plc_config
208 - * added the _genicw system slice
209 - * add tag types for sites and persons
210 - * add new tags for nodes and slices for exemption from myops
211
212 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
213 - turn off drupal on a box that acts as BOOT server but not as WWW server
214 - cleanup some obsolete code for old chroot-jail packaging in the process
215 - new bootcd-kernel script for keeping bootcd variants up2date
216
217 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
218 - Make the /etc/hosts manipulation optional.
219
220 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
221 - Fix SetRole.
222
223 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
224 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
225 - into the DB.
226 - - Added the root ssh key handling support back into plc.d/ssh and the
227 - default xml file.  This should be identical to the way it was in
228 - rc12.
229 - - Added support in the db-config.d/01-init script to register the root
230 - ssh public key with the default administrator.  In this way the root
231 - ssh key will make it into the root account on the nodes by means of
232 - NodeManager's specialaccounts plugin.
233
234 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
235 - db-config ignores sliver tags
236 - sirius's db-config script renamed (was sirious)
237
238 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
239 - fix for silverauth - missing tag types now created at plc startup time
240
241 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
242 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
243
244 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
245 - companion to NM's specialaccounts plugin
246 - do not generate /etc/planetlab/root_ssh_key* anymore
247 - remove related config. variables and conf_files
248
249 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
250 - clarified description text to refer only to plcrt and not other optional
251 - packages.
252
253 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
254 - fixed a bug setting slice multiple attributes with the same tag name
255
256 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
257 - SSL setup for monitor box, and related new config variables
258 - new conf_file for /etc/planetlab/extensions
259 - various tweaks in db-config internals, about initscripts among others
260 - also more messages defined in the db
261
262 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
263 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
264
265 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
266 - bugfix in db-config, tag 4.3-19 would not fly
267
268 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
269 - Refactored db-config into snippets in db-config.d/.
270
271 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
272 - oops, tag 4.3-17 was broken and would not work
273
274 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
275 - bugfix - escape sequences inserted in xml configs
276
277 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
278 - Handle db-config.d files properly.
279
280 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
281 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
282 - than the log file
283 - - Fix db-config to be a bit more cautious when
284 - /etc/planetlab/db-config.d doesn't exist
285 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
286 - .orig files.
287 - - Refactor generic plc-config-tty code into plc_config.py.
288 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
289 - and the list of validated variables and the corresponding
290 - validator() function. This refactoring lets one reuse plc_config.py
291 - as a generic cmdline configuration tool for highly customer MyPLC
292 - like software.
293
294 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
295 - update PCU Type descriptions.
296 - updates to init scripts
297
298 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
299 - requires monitor-pcucontrol so register-wizard can work
300
301 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
302 - cleaned up plc-config-tty, no more need to configure plc-devel
303
304 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
305 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
306
307 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
308 - tighter right permissions on site_admin's authorized keys for more robustness
309
310 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
311 - fix issue in db-config that prevented correct operation
312
313 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
314 - remove support for chroot-based packaging - no crond nor syslog step anymore
315 - plc init script now named plc.init instead of former guest.init
316
317 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
318 - add Monitor to docs build
319
320 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
321 - plc_config.py and plc-config-tty: generalized to work for more diverse
322 - MyPLC configurations.
323 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
324 - deployments and increase the memory limits in php.ini
325 - plc.d/crond: add --full option to vacuumdb
326
327 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
328 - avoid generating ssl certificates for disabled services among www api boot
329
330 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
331 - cleaned up old entries in db-config
332 - mtail more robust
333
334 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
335 - php include path tweaked for plekit includes
336 - reviewed myplc (fka native) packaging dependencies
337 - renumbered 4.3
338
339 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
340 - rename myplc into myplc-chroot and myplc-native into myplc
341 - new settings (shortname & hrn_root) for local peer
342
343
344 %define module_current_branch 4.3