use lower case names to workaround stupid puppet bug (http://projects.puppetlabs...
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 50
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
61 - Do not preserve /etc/planetlab on upgrade operations
62
63 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
64 - Remove Monitor references from spec file
65
66 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
67 - Introduce staticroute tagtype
68
69 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
70 - attempt to fix small glitches
71
72 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
73 - enable short_open_tag for backward compatibility
74
75 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
76 - Cherry-pick PHP5 timezone fix form master
77
78 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
79 - pick the greatest version as a kernel
80
81 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
82 - handle directory name changes for myplc-docs package as well
83
84 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
85 - handle directory name changes
86
87 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
88 - Use correct resolv.conf file.
89
90 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
91 - Make dnsmasq usable.
92
93 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
94 - Allow dnsmasq configuration to be extended.
95
96 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
97 - Add DRL slice.
98 - Generalize bootcd-kernel.
99
100 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
101 - support for fedora 12
102 - new package myplc-config for use by sfa
103 - drupal user registration turned off
104
105 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
106 - - fix to make sure when API, BOOT, MONITOR are on the same
107 - machine as WWW that the SSL key,cert for WWW takes precedence.
108 - - Do proper setup for SSL CA certficate to be used as the server
109 - chain.
110
111 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
112 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
113
114 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
115 - depend on pcucontrol
116
117 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
118 - * validate input according to type in plc_config
119 - * added the _genicw system slice
120 - * add tag types for sites and persons
121 - * add new tags for nodes and slices for exemption from myops
122
123 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
124 - turn off drupal on a box that acts as BOOT server but not as WWW server
125 - cleanup some obsolete code for old chroot-jail packaging in the process
126 - new bootcd-kernel script for keeping bootcd variants up2date
127
128 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
129 - Make the /etc/hosts manipulation optional.
130
131 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
132 - Fix SetRole.
133
134 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
135 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
136 - into the DB.
137 - - Added the root ssh key handling support back into plc.d/ssh and the
138 - default xml file.  This should be identical to the way it was in
139 - rc12.
140 - - Added support in the db-config.d/01-init script to register the root
141 - ssh public key with the default administrator.  In this way the root
142 - ssh key will make it into the root account on the nodes by means of
143 - NodeManager's specialaccounts plugin.
144
145 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
146 - db-config ignores sliver tags
147 - sirius's db-config script renamed (was sirious)
148
149 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
150 - fix for silverauth - missing tag types now created at plc startup time
151
152 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
153 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
154
155 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
156 - companion to NM's specialaccounts plugin
157 - do not generate /etc/planetlab/root_ssh_key* anymore
158 - remove related config. variables and conf_files
159
160 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
161 - clarified description text to refer only to plcrt and not other optional
162 - packages.
163
164 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
165 - fixed a bug setting slice multiple attributes with the same tag name
166
167 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
168 - SSL setup for monitor box, and related new config variables
169 - new conf_file for /etc/planetlab/extensions
170 - various tweaks in db-config internals, about initscripts among others
171 - also more messages defined in the db
172
173 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
174 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
175
176 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
177 - bugfix in db-config, tag 4.3-19 would not fly
178
179 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
180 - Refactored db-config into snippets in db-config.d/.
181
182 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
183 - oops, tag 4.3-17 was broken and would not work
184
185 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
186 - bugfix - escape sequences inserted in xml configs
187
188 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
189 - Handle db-config.d files properly.
190
191 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
192 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
193 - than the log file
194 - - Fix db-config to be a bit more cautious when
195 - /etc/planetlab/db-config.d doesn't exist
196 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
197 - .orig files.
198 - - Refactor generic plc-config-tty code into plc_config.py.
199 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
200 - and the list of validated variables and the corresponding
201 - validator() function. This refactoring lets one reuse plc_config.py
202 - as a generic cmdline configuration tool for highly customer MyPLC
203 - like software.
204
205 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
206 - update PCU Type descriptions.
207 - updates to init scripts
208
209 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
210 - requires monitor-pcucontrol so register-wizard can work
211
212 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
213 - cleaned up plc-config-tty, no more need to configure plc-devel
214
215 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
216 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
217
218 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
219 - tighter right permissions on site_admin's authorized keys for more robustness
220
221 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
222 - fix issue in db-config that prevented correct operation
223
224 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
225 - remove support for chroot-based packaging - no crond nor syslog step anymore
226 - plc init script now named plc.init instead of former guest.init
227
228 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
229 - add Monitor to docs build
230
231 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
232 - plc_config.py and plc-config-tty: generalized to work for more diverse
233 - MyPLC configurations.
234 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
235 - deployments and increase the memory limits in php.ini
236 - plc.d/crond: add --full option to vacuumdb
237
238 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
239 - avoid generating ssl certificates for disabled services among www api boot
240
241 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
242 - cleaned up old entries in db-config
243 - mtail more robust
244
245 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
246 - php include path tweaked for plekit includes
247 - reviewed myplc (fka native) packaging dependencies
248 - renumbered 4.3
249
250 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
251 - rename myplc into myplc-chroot and myplc-native into myplc
252 - new settings (shortname & hrn_root) for local peer
253