pick the greatest version as a kernel
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 43
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
61 - handle directory name changes for myplc-docs package as well
62
63 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
64 - handle directory name changes
65
66 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
67 - Use correct resolv.conf file.
68
69 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
70 - Make dnsmasq usable.
71
72 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
73 - Allow dnsmasq configuration to be extended.
74
75 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
76 - Add DRL slice.
77 - Generalize bootcd-kernel.
78
79 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
80 - support for fedora 12
81 - new package myplc-config for use by sfa
82 - drupal user registration turned off
83
84 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
85 - - fix to make sure when API, BOOT, MONITOR are on the same
86 - machine as WWW that the SSL key,cert for WWW takes precedence.
87 - - Do proper setup for SSL CA certficate to be used as the server
88 - chain.
89
90 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
91 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
92
93 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
94 - depend on pcucontrol
95
96 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
97 - * validate input according to type in plc_config
98 - * added the _genicw system slice
99 - * add tag types for sites and persons
100 - * add new tags for nodes and slices for exemption from myops
101
102 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
103 - turn off drupal on a box that acts as BOOT server but not as WWW server
104 - cleanup some obsolete code for old chroot-jail packaging in the process
105 - new bootcd-kernel script for keeping bootcd variants up2date
106
107 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
108 - Make the /etc/hosts manipulation optional.
109
110 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
111 - Fix SetRole.
112
113 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
114 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
115 - into the DB.
116 - - Added the root ssh key handling support back into plc.d/ssh and the
117 - default xml file.  This should be identical to the way it was in
118 - rc12.
119 - - Added support in the db-config.d/01-init script to register the root
120 - ssh public key with the default administrator.  In this way the root
121 - ssh key will make it into the root account on the nodes by means of
122 - NodeManager's specialaccounts plugin.
123
124 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
125 - db-config ignores sliver tags
126 - sirius's db-config script renamed (was sirious)
127
128 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
129 - fix for silverauth - missing tag types now created at plc startup time
130
131 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
132 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
133
134 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
135 - companion to NM's specialaccounts plugin
136 - do not generate /etc/planetlab/root_ssh_key* anymore
137 - remove related config. variables and conf_files
138
139 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
140 - clarified description text to refer only to plcrt and not other optional
141 - packages.
142
143 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
144 - fixed a bug setting slice multiple attributes with the same tag name
145
146 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
147 - SSL setup for monitor box, and related new config variables
148 - new conf_file for /etc/planetlab/extensions
149 - various tweaks in db-config internals, about initscripts among others
150 - also more messages defined in the db
151
152 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
153 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
154
155 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
156 - bugfix in db-config, tag 4.3-19 would not fly
157
158 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
159 - Refactored db-config into snippets in db-config.d/.
160
161 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
162 - oops, tag 4.3-17 was broken and would not work
163
164 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
165 - bugfix - escape sequences inserted in xml configs
166
167 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
168 - Handle db-config.d files properly.
169
170 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
171 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
172 - than the log file
173 - - Fix db-config to be a bit more cautious when
174 - /etc/planetlab/db-config.d doesn't exist
175 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
176 - .orig files.
177 - - Refactor generic plc-config-tty code into plc_config.py.
178 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
179 - and the list of validated variables and the corresponding
180 - validator() function. This refactoring lets one reuse plc_config.py
181 - as a generic cmdline configuration tool for highly customer MyPLC
182 - like software.
183
184 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
185 - update PCU Type descriptions.
186 - updates to init scripts
187
188 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
189 - requires monitor-pcucontrol so register-wizard can work
190
191 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
192 - cleaned up plc-config-tty, no more need to configure plc-devel
193
194 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
195 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
196
197 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
198 - tighter right permissions on site_admin's authorized keys for more robustness
199
200 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
201 - fix issue in db-config that prevented correct operation
202
203 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
204 - remove support for chroot-based packaging - no crond nor syslog step anymore
205 - plc init script now named plc.init instead of former guest.init
206
207 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
208 - add Monitor to docs build
209
210 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
211 - plc_config.py and plc-config-tty: generalized to work for more diverse
212 - MyPLC configurations.
213 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
214 - deployments and increase the memory limits in php.ini
215 - plc.d/crond: add --full option to vacuumdb
216
217 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
218 - avoid generating ssl certificates for disabled services among www api boot
219
220 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
221 - cleaned up old entries in db-config
222 - mtail more robust
223
224 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
225 - php include path tweaked for plekit includes
226 - reviewed myplc (fka native) packaging dependencies
227 - renumbered 4.3
228
229 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
230 - rename myplc into myplc-chroot and myplc-native into myplc
231 - new settings (shortname & hrn_root) for local peer
232