Setting tag myplc-5.1-5
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
56 - define open_basedir in php.ini to stop confidentiality leak
57 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
58 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
59 - new utilities check-hrns.py and check-vsys-defaults.py
60
61 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
62 - set TimeoutSec to 300 in plc.service
63 - remove ref to deprecated svn $URL$ in db-config usage
64
65 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
66 - expose mtail.py as simply mtail
67
68 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
69 - plc-kml.py now has support for nodegroups
70
71 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
72 - use nodeimage package instead of deprecated bootstrapfs
73 - has systemd-friendly startup script
74 - plc_reload moved to functions/ - no more service plc reload
75 - no svn keywords anymore
76
77 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
78 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
79
80 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
81 - new settings for myslice (comon&tophat) and monitor (db)
82 - removed mentions of chroot in description
83 - can redo myplc-docs on broken f12-latex
84 - set short_open_tag in php.ini
85 - fixes in gen-sites-xml (is that still used ?)
86 - partial-repo.sh has moved to 'build' where it more belongs
87 - tweaks in convenience tool 'mtail'
88
89 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
90 - fixed changelog, no change from 5.0-16
91
92 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
93 - requires ed for the plc.d/packages step
94 - sirius initscript to handle stop and restart
95
96 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
97 - ignore steps in db-config.d if they have a '.' or '~' in their name
98
99 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
100 - can redo myplc-docs without the doc for monitor
101
102 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
103 - no semantic change - just fixed specfile for git URL
104
105 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
106 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
107
108 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
109 - add missing files to rpm package
110
111 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
112 - mtail.py -s for SFA
113 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
114
115 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
116 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
117
118 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
119 - plc-config-tty now has a validator on booleans
120 - e.g. entering 'True' now is rejected rather than silently recording 'false'
121
122 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
123 - disable mod_wsgi
124
125 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
126 - module name changes
127 - start wsgi support
128
129 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
130 - new setting PLC_RESERVATION_GRANULARITY
131
132 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
133 - * partial-repo.sh script
134 - * preserve key along with certificates
135
136 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
137 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
138
139 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
140 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
141 - new OMF category in the config
142 - create the drl system slice
143
144 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
145 - first working version of 5.0:
146 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
147 - nodefamily is 3-fold with pldistro-fcdistro-arch
148 - new PLC_FLAVOUR config category
149 - reviewed module layout
150 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
151
152 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
153 - support for fedora 12
154 - new package myplc-config for use by sfa
155 - drupal user registration turned off
156
157 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
158 - - fix to make sure when API, BOOT, MONITOR are on the same
159 - machine as WWW that the SSL key,cert for WWW takes precedence.
160 - - Do proper setup for SSL CA certficate to be used as the server
161 - chain.
162
163 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
164 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
165
166 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
167 - depend on pcucontrol
168
169 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
170 - * validate input according to type in plc_config
171 - * added the _genicw system slice
172 - * add tag types for sites and persons
173 - * add new tags for nodes and slices for exemption from myops
174
175 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
176 - turn off drupal on a box that acts as BOOT server but not as WWW server
177 - cleanup some obsolete code for old chroot-jail packaging in the process
178 - new bootcd-kernel script for keeping bootcd variants up2date
179
180 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
181 - Make the /etc/hosts manipulation optional.
182
183 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
184 - Fix SetRole.
185
186 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
187 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
188 - into the DB.
189 - - Added the root ssh key handling support back into plc.d/ssh and the
190 - default xml file.  This should be identical to the way it was in
191 - rc12.
192 - - Added support in the db-config.d/01-init script to register the root
193 - ssh public key with the default administrator.  In this way the root
194 - ssh key will make it into the root account on the nodes by means of
195 - NodeManager's specialaccounts plugin.
196
197 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
198 - db-config ignores sliver tags
199 - sirius's db-config script renamed (was sirious)
200
201 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
202 - fix for silverauth - missing tag types now created at plc startup time
203
204 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
205 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
206
207 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
208 - companion to NM's specialaccounts plugin
209 - do not generate /etc/planetlab/root_ssh_key* anymore
210 - remove related config. variables and conf_files
211
212 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
213 - clarified description text to refer only to plcrt and not other optional
214 - packages.
215
216 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
217 - fixed a bug setting slice multiple attributes with the same tag name
218
219 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
220 - SSL setup for monitor box, and related new config variables
221 - new conf_file for /etc/planetlab/extensions
222 - various tweaks in db-config internals, about initscripts among others
223 - also more messages defined in the db
224
225 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
226 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
227
228 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
229 - bugfix in db-config, tag 4.3-19 would not fly
230
231 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
232 - Refactored db-config into snippets in db-config.d/.
233
234 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
235 - oops, tag 4.3-17 was broken and would not work
236
237 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
238 - bugfix - escape sequences inserted in xml configs
239
240 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
241 - Handle db-config.d files properly.
242
243 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
244 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
245 - than the log file
246 - - Fix db-config to be a bit more cautious when
247 - /etc/planetlab/db-config.d doesn't exist
248 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
249 - .orig files.
250 - - Refactor generic plc-config-tty code into plc_config.py.
251 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
252 - and the list of validated variables and the corresponding
253 - validator() function. This refactoring lets one reuse plc_config.py
254 - as a generic cmdline configuration tool for highly customer MyPLC
255 - like software.
256
257 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
258 - update PCU Type descriptions.
259 - updates to init scripts
260
261 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
262 - requires monitor-pcucontrol so register-wizard can work
263
264 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
265 - cleaned up plc-config-tty, no more need to configure plc-devel
266
267 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
268 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
269
270 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
271 - tighter right permissions on site_admin's authorized keys for more robustness
272
273 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
274 - fix issue in db-config that prevented correct operation
275
276 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
277 - remove support for chroot-based packaging - no crond nor syslog step anymore
278 - plc init script now named plc.init instead of former guest.init
279
280 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
281 - add Monitor to docs build
282
283 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
284 - plc_config.py and plc-config-tty: generalized to work for more diverse
285 - MyPLC configurations.
286 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
287 - deployments and increase the memory limits in php.ini
288 - plc.d/crond: add --full option to vacuumdb
289
290 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
291 - avoid generating ssl certificates for disabled services among www api boot
292
293 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
294 - cleaned up old entries in db-config
295 - mtail more robust
296
297 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
298 - php include path tweaked for plekit includes
299 - reviewed myplc (fka native) packaging dependencies
300 - renumbered 4.3
301
302 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
303 - rename myplc into myplc-chroot and myplc-native into myplc
304 - new settings (shortname & hrn_root) for local peer
305
306
307 %define module_current_branch 4.3