convenience script for coupling with the OMF Experiment Controller
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.1
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
56 - set TimeoutSec to 300 in plc.service
57 - remove ref to deprecated svn $URL$ in db-config usage
58
59 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
60 - expose mtail.py as simply mtail
61
62 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
63 - plc-kml.py now has support for nodegroups
64
65 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
66 - use nodeimage package instead of deprecated bootstrapfs
67 - has systemd-friendly startup script
68 - plc_reload moved to functions/ - no more service plc reload
69 - no svn keywords anymore
70
71 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
72 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
73
74 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
75 - new settings for myslice (comon&tophat) and monitor (db)
76 - removed mentions of chroot in description
77 - can redo myplc-docs on broken f12-latex
78 - set short_open_tag in php.ini
79 - fixes in gen-sites-xml (is that still used ?)
80 - partial-repo.sh has moved to 'build' where it more belongs
81 - tweaks in convenience tool 'mtail'
82
83 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
84 - fixed changelog, no change from 5.0-16
85
86 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
87 - requires ed for the plc.d/packages step
88 - sirius initscript to handle stop and restart
89
90 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
91 - ignore steps in db-config.d if they have a '.' or '~' in their name
92
93 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
94 - can redo myplc-docs without the doc for monitor
95
96 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
97 - no semantic change - just fixed specfile for git URL
98
99 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
100 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
101
102 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
103 - add missing files to rpm package
104
105 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
106 - mtail.py -s for SFA
107 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
108
109 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
110 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
111
112 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
113 - plc-config-tty now has a validator on booleans
114 - e.g. entering 'True' now is rejected rather than silently recording 'false'
115
116 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
117 - disable mod_wsgi
118
119 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
120 - module name changes
121 - start wsgi support
122
123 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
124 - new setting PLC_RESERVATION_GRANULARITY
125
126 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
127 - * partial-repo.sh script
128 - * preserve key along with certificates
129
130 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
131 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
132
133 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
134 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
135 - new OMF category in the config
136 - create the drl system slice
137
138 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
139 - first working version of 5.0:
140 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
141 - nodefamily is 3-fold with pldistro-fcdistro-arch
142 - new PLC_FLAVOUR config category
143 - reviewed module layout
144 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
145
146 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
147 - support for fedora 12
148 - new package myplc-config for use by sfa
149 - drupal user registration turned off
150
151 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
152 - - fix to make sure when API, BOOT, MONITOR are on the same
153 - machine as WWW that the SSL key,cert for WWW takes precedence.
154 - - Do proper setup for SSL CA certficate to be used as the server
155 - chain.
156
157 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
158 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
159
160 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
161 - depend on pcucontrol
162
163 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
164 - * validate input according to type in plc_config
165 - * added the _genicw system slice
166 - * add tag types for sites and persons
167 - * add new tags for nodes and slices for exemption from myops
168
169 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
170 - turn off drupal on a box that acts as BOOT server but not as WWW server
171 - cleanup some obsolete code for old chroot-jail packaging in the process
172 - new bootcd-kernel script for keeping bootcd variants up2date
173
174 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
175 - Make the /etc/hosts manipulation optional.
176
177 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
178 - Fix SetRole.
179
180 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
181 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
182 - into the DB.
183 - - Added the root ssh key handling support back into plc.d/ssh and the
184 - default xml file.  This should be identical to the way it was in
185 - rc12.
186 - - Added support in the db-config.d/01-init script to register the root
187 - ssh public key with the default administrator.  In this way the root
188 - ssh key will make it into the root account on the nodes by means of
189 - NodeManager's specialaccounts plugin.
190
191 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
192 - db-config ignores sliver tags
193 - sirius's db-config script renamed (was sirious)
194
195 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
196 - fix for silverauth - missing tag types now created at plc startup time
197
198 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
199 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
200
201 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
202 - companion to NM's specialaccounts plugin
203 - do not generate /etc/planetlab/root_ssh_key* anymore
204 - remove related config. variables and conf_files
205
206 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
207 - clarified description text to refer only to plcrt and not other optional
208 - packages.
209
210 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
211 - fixed a bug setting slice multiple attributes with the same tag name
212
213 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
214 - SSL setup for monitor box, and related new config variables
215 - new conf_file for /etc/planetlab/extensions
216 - various tweaks in db-config internals, about initscripts among others
217 - also more messages defined in the db
218
219 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
220 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
221
222 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
223 - bugfix in db-config, tag 4.3-19 would not fly
224
225 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
226 - Refactored db-config into snippets in db-config.d/.
227
228 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
229 - oops, tag 4.3-17 was broken and would not work
230
231 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
232 - bugfix - escape sequences inserted in xml configs
233
234 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
235 - Handle db-config.d files properly.
236
237 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
238 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
239 - than the log file
240 - - Fix db-config to be a bit more cautious when
241 - /etc/planetlab/db-config.d doesn't exist
242 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
243 - .orig files.
244 - - Refactor generic plc-config-tty code into plc_config.py.
245 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
246 - and the list of validated variables and the corresponding
247 - validator() function. This refactoring lets one reuse plc_config.py
248 - as a generic cmdline configuration tool for highly customer MyPLC
249 - like software.
250
251 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
252 - update PCU Type descriptions.
253 - updates to init scripts
254
255 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
256 - requires monitor-pcucontrol so register-wizard can work
257
258 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
259 - cleaned up plc-config-tty, no more need to configure plc-devel
260
261 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
262 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
263
264 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
265 - tighter right permissions on site_admin's authorized keys for more robustness
266
267 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
268 - fix issue in db-config that prevented correct operation
269
270 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
271 - remove support for chroot-based packaging - no crond nor syslog step anymore
272 - plc init script now named plc.init instead of former guest.init
273
274 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
275 - add Monitor to docs build
276
277 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
278 - plc_config.py and plc-config-tty: generalized to work for more diverse
279 - MyPLC configurations.
280 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
281 - deployments and increase the memory limits in php.ini
282 - plc.d/crond: add --full option to vacuumdb
283
284 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
285 - avoid generating ssl certificates for disabled services among www api boot
286
287 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
288 - cleaned up old entries in db-config
289 - mtail more robust
290
291 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
292 - php include path tweaked for plekit includes
293 - reviewed myplc (fka native) packaging dependencies
294 - renumbered 4.3
295
296 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
297 - rename myplc into myplc-chroot and myplc-native into myplc
298 - new settings (shortname & hrn_root) for local peer
299
300
301 %define module_current_branch 4.3