fix resolv.conf issue on plc
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 53
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed May 04 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-53
61 - VCDN-333: Node Statistics selected incorrect interface and accordingly COMON gets no stats from node. : Now node name can only be used for primary interface
62 - fix gpg update.
63 - this issue raises in gpg2 (hangs in SL6), but it's considered as a bug in gpg1
64 - https://bugs.g10code.com/gnupg/issue1122
65
66 * Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-52
67 - use lower case variable names to workaround http://projects.puppetlabs.com/issues/3939
68
69 * Tue May 03 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-51
70 - generate plc_config.rb via plc-config
71
72 * Fri Apr 08 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-50
73 - Do not preserve /etc/planetlab on upgrade operations
74
75 * Thu Apr 07 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-49
76 - Remove Monitor references from spec file
77
78 * Wed Apr 06 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-48
79 - Introduce staticroute tagtype
80
81 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
82 - attempt to fix small glitches
83
84 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
85 - enable short_open_tag for backward compatibility
86
87 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
88 - Cherry-pick PHP5 timezone fix form master
89
90 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
91 - pick the greatest version as a kernel
92
93 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
94 - handle directory name changes for myplc-docs package as well
95
96 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
97 - handle directory name changes
98
99 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
100 - Use correct resolv.conf file.
101
102 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
103 - Make dnsmasq usable.
104
105 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
106 - Allow dnsmasq configuration to be extended.
107
108 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
109 - Add DRL slice.
110 - Generalize bootcd-kernel.
111
112 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
113 - support for fedora 12
114 - new package myplc-config for use by sfa
115 - drupal user registration turned off
116
117 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
118 - - fix to make sure when API, BOOT, MONITOR are on the same
119 - machine as WWW that the SSL key,cert for WWW takes precedence.
120 - - Do proper setup for SSL CA certficate to be used as the server
121 - chain.
122
123 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
124 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
125
126 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
127 - depend on pcucontrol
128
129 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
130 - * validate input according to type in plc_config
131 - * added the _genicw system slice
132 - * add tag types for sites and persons
133 - * add new tags for nodes and slices for exemption from myops
134
135 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
136 - turn off drupal on a box that acts as BOOT server but not as WWW server
137 - cleanup some obsolete code for old chroot-jail packaging in the process
138 - new bootcd-kernel script for keeping bootcd variants up2date
139
140 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
141 - Make the /etc/hosts manipulation optional.
142
143 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
144 - Fix SetRole.
145
146 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
147 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
148 - into the DB.
149 - - Added the root ssh key handling support back into plc.d/ssh and the
150 - default xml file.  This should be identical to the way it was in
151 - rc12.
152 - - Added support in the db-config.d/01-init script to register the root
153 - ssh public key with the default administrator.  In this way the root
154 - ssh key will make it into the root account on the nodes by means of
155 - NodeManager's specialaccounts plugin.
156
157 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
158 - db-config ignores sliver tags
159 - sirius's db-config script renamed (was sirious)
160
161 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
162 - fix for silverauth - missing tag types now created at plc startup time
163
164 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
165 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
166
167 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
168 - companion to NM's specialaccounts plugin
169 - do not generate /etc/planetlab/root_ssh_key* anymore
170 - remove related config. variables and conf_files
171
172 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
173 - clarified description text to refer only to plcrt and not other optional
174 - packages.
175
176 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
177 - fixed a bug setting slice multiple attributes with the same tag name
178
179 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
180 - SSL setup for monitor box, and related new config variables
181 - new conf_file for /etc/planetlab/extensions
182 - various tweaks in db-config internals, about initscripts among others
183 - also more messages defined in the db
184
185 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
186 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
187
188 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
189 - bugfix in db-config, tag 4.3-19 would not fly
190
191 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
192 - Refactored db-config into snippets in db-config.d/.
193
194 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
195 - oops, tag 4.3-17 was broken and would not work
196
197 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
198 - bugfix - escape sequences inserted in xml configs
199
200 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
201 - Handle db-config.d files properly.
202
203 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
204 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
205 - than the log file
206 - - Fix db-config to be a bit more cautious when
207 - /etc/planetlab/db-config.d doesn't exist
208 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
209 - .orig files.
210 - - Refactor generic plc-config-tty code into plc_config.py.
211 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
212 - and the list of validated variables and the corresponding
213 - validator() function. This refactoring lets one reuse plc_config.py
214 - as a generic cmdline configuration tool for highly customer MyPLC
215 - like software.
216
217 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
218 - update PCU Type descriptions.
219 - updates to init scripts
220
221 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
222 - requires monitor-pcucontrol so register-wizard can work
223
224 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
225 - cleaned up plc-config-tty, no more need to configure plc-devel
226
227 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
228 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
229
230 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
231 - tighter right permissions on site_admin's authorized keys for more robustness
232
233 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
234 - fix issue in db-config that prevented correct operation
235
236 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
237 - remove support for chroot-based packaging - no crond nor syslog step anymore
238 - plc init script now named plc.init instead of former guest.init
239
240 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
241 - add Monitor to docs build
242
243 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
244 - plc_config.py and plc-config-tty: generalized to work for more diverse
245 - MyPLC configurations.
246 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
247 - deployments and increase the memory limits in php.ini
248 - plc.d/crond: add --full option to vacuumdb
249
250 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
251 - avoid generating ssl certificates for disabled services among www api boot
252
253 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
254 - cleaned up old entries in db-config
255 - mtail more robust
256
257 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
258 - php include path tweaked for plekit includes
259 - reviewed myplc (fka native) packaging dependencies
260 - renumbered 4.3
261
262 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
263 - rename myplc into myplc-chroot and myplc-native into myplc
264 - new settings (shortname & hrn_root) for local peer
265