egrep is obsolete
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 7.1
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.1-0
56 - ready on f35
57
58 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
59 - suitable for python3 on both f27 and f29
60
61 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
62 - takes care of creating plcapi log file
63
64 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
65 - tweaked renew_reminder for federation
66
67 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
68 - tweaks in check-hrns.py
69 - do not require PyXML any more
70
71 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
72 - review check-hrns for plcapi-5.3
73 - add PLC_HRN_ROOT in usual plc-config-tty's settings
74
75 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
76 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
77 - add an rpm-sign dependency on feedora>=16
78
79 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
80 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
81
82 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
83 - plc.d/gpg now does not rm /dev/random but preserves it
84 - this is because libvirt won't let us run mknod
85
86 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
87 - fix typo in check-hrns - used to print 'host' while dealing with persons
88
89 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
90 - supports httpd config for either mod_python (preferred) or mod_wsgi
91 - requires mod_wsgi on f18 only, otherwise mod_python
92 - supports httpd config for apache 2.4 (f18)
93 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
94
95 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
96 - bugfix in check-vsys-defaults.py
97
98 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
99 - define open_basedir in php.ini to stop confidentiality leak
100 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
101 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
102 - new utilities check-hrns.py and check-vsys-defaults.py
103
104 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
105 - set TimeoutSec to 300 in plc.service
106 - remove ref to deprecated svn $URL$ in db-config usage
107
108 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
109 - expose mtail.py as simply mtail
110
111 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
112 - plc-kml.py now has support for nodegroups
113
114 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
115 - use nodeimage package instead of deprecated bootstrapfs
116 - has systemd-friendly startup script
117 - plc_reload moved to functions/ - no more service plc reload
118 - no svn keywords anymore
119
120 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
121 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
122
123 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
124 - new settings for myslice (comon&tophat) and monitor (db)
125 - removed mentions of chroot in description
126 - can redo myplc-docs on broken f12-latex
127 - set short_open_tag in php.ini
128 - fixes in gen-sites-xml (is that still used ?)
129 - partial-repo.sh has moved to 'build' where it more belongs
130 - tweaks in convenience tool 'mtail'
131
132 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
133 - fixed changelog, no change from 5.0-16
134
135 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
136 - requires ed for the plc.d/packages step
137 - sirius initscript to handle stop and restart
138
139 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
140 - ignore steps in db-config.d if they have a '.' or '~' in their name
141
142 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
143 - can redo myplc-docs without the doc for monitor
144
145 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
146 - no semantic change - just fixed specfile for git URL
147
148 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
149 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
150
151 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
152 - add missing files to rpm package
153
154 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
155 - mtail.py -s for SFA
156 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
157
158 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
159 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
160
161 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
162 - plc-config-tty now has a validator on booleans
163 - e.g. entering 'True' now is rejected rather than silently recording 'false'
164
165 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
166 - disable mod_wsgi
167
168 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
169 - module name changes
170 - start wsgi support
171
172 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
173 - new setting PLC_RESERVATION_GRANULARITY
174
175 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
176 - * partial-repo.sh script
177 - * preserve key along with certificates
178
179 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
180 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
181
182 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
183 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
184 - new OMF category in the config
185 - create the drl system slice
186
187 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
188 - first working version of 5.0:
189 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
190 - nodefamily is 3-fold with pldistro-fcdistro-arch
191 - new PLC_FLAVOUR config category
192 - reviewed module layout
193 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
194
195 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
196 - support for fedora 12
197 - new package myplc-config for use by sfa
198 - drupal user registration turned off
199
200 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
201 - - fix to make sure when API, BOOT, MONITOR are on the same
202 - machine as WWW that the SSL key,cert for WWW takes precedence.
203 - - Do proper setup for SSL CA certficate to be used as the server
204 - chain.
205
206 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
207 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
208
209 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
210 - depend on pcucontrol
211
212 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
213 - * validate input according to type in plc_config
214 - * added the _genicw system slice
215 - * add tag types for sites and persons
216 - * add new tags for nodes and slices for exemption from myops
217
218 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
219 - turn off drupal on a box that acts as BOOT server but not as WWW server
220 - cleanup some obsolete code for old chroot-jail packaging in the process
221 - new bootcd-kernel script for keeping bootcd variants up2date
222
223 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
224 - Make the /etc/hosts manipulation optional.
225
226 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
227 - Fix SetRole.
228
229 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
230 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
231 - into the DB.
232 - - Added the root ssh key handling support back into plc.d/ssh and the
233 - default xml file.  This should be identical to the way it was in
234 - rc12.
235 - - Added support in the db-config.d/01-init script to register the root
236 - ssh public key with the default administrator.  In this way the root
237 - ssh key will make it into the root account on the nodes by means of
238 - NodeManager's specialaccounts plugin.
239
240 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
241 - db-config ignores sliver tags
242 - sirius's db-config script renamed (was sirious)
243
244 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
245 - fix for silverauth - missing tag types now created at plc startup time
246
247 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
248 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
249
250 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
251 - companion to NM's specialaccounts plugin
252 - do not generate /etc/planetlab/root_ssh_key* anymore
253 - remove related config. variables and conf_files
254
255 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
256 - clarified description text to refer only to plcrt and not other optional
257 - packages.
258
259 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
260 - fixed a bug setting slice multiple attributes with the same tag name
261
262 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
263 - SSL setup for monitor box, and related new config variables
264 - new conf_file for /etc/planetlab/extensions
265 - various tweaks in db-config internals, about initscripts among others
266 - also more messages defined in the db
267
268 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
269 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
270
271 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
272 - bugfix in db-config, tag 4.3-19 would not fly
273
274 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
275 - Refactored db-config into snippets in db-config.d/.
276
277 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
278 - oops, tag 4.3-17 was broken and would not work
279
280 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
281 - bugfix - escape sequences inserted in xml configs
282
283 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
284 - Handle db-config.d files properly.
285
286 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
287 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
288 - than the log file
289 - - Fix db-config to be a bit more cautious when
290 - /etc/planetlab/db-config.d doesn't exist
291 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
292 - .orig files.
293 - - Refactor generic plc-config-tty code into plc_config.py.
294 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
295 - and the list of validated variables and the corresponding
296 - validator() function. This refactoring lets one reuse plc_config.py
297 - as a generic cmdline configuration tool for highly customer MyPLC
298 - like software.
299
300 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
301 - update PCU Type descriptions.
302 - updates to init scripts
303
304 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
305 - requires monitor-pcucontrol so register-wizard can work
306
307 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
308 - cleaned up plc-config-tty, no more need to configure plc-devel
309
310 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
311 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
312
313 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
314 - tighter right permissions on site_admin's authorized keys for more robustness
315
316 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
317 - fix issue in db-config that prevented correct operation
318
319 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
320 - remove support for chroot-based packaging - no crond nor syslog step anymore
321 - plc init script now named plc.init instead of former guest.init
322
323 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
324 - add Monitor to docs build
325
326 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
327 - plc_config.py and plc-config-tty: generalized to work for more diverse
328 - MyPLC configurations.
329 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
330 - deployments and increase the memory limits in php.ini
331 - plc.d/crond: add --full option to vacuumdb
332
333 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
334 - avoid generating ssl certificates for disabled services among www api boot
335
336 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
337 - cleaned up old entries in db-config
338 - mtail more robust
339
340 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
341 - php include path tweaked for plekit includes
342 - reviewed myplc (fka native) packaging dependencies
343 - renumbered 4.3
344
345 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
346 - rename myplc into myplc-chroot and myplc-native into myplc
347 - new settings (shortname & hrn_root) for local peer
348
349
350 %define module_current_branch 4.3