fix broken target make sync
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 19
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
56 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
57
58 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
59 - new settings for myslice (comon&tophat) and monitor (db)
60 - removed mentions of chroot in description
61 - can redo myplc-docs on broken f12-latex
62 - set short_open_tag in php.ini
63 - fixes in gen-sites-xml (is that still used ?)
64 - partial-repo.sh has moved to 'build' where it more belongs
65 - tweaks in convenience tool 'mtail'
66
67 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
68 - fixed changelog, no change from 5.0-16
69
70 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
71 - requires ed for the plc.d/packages step
72 - sirius initscript to handle stop and restart
73
74 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
75 - ignore steps in db-config.d if they have a '.' or '~' in their name
76
77 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
78 - can redo myplc-docs without the doc for monitor
79
80 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
81 - no semantic change - just fixed specfile for git URL
82
83 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
84 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
85
86 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
87 - add missing files to rpm package
88
89 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
90 - mtail.py -s for SFA
91 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
92
93 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
94 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
95
96 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
97 - plc-config-tty now has a validator on booleans
98 - e.g. entering 'True' now is rejected rather than silently recording 'false'
99
100 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
101 - disable mod_wsgi
102
103 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
104 - module name changes
105 - start wsgi support
106
107 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
108 - new setting PLC_RESERVATION_GRANULARITY
109
110 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
111 - * partial-repo.sh script
112 - * preserve key along with certificates
113
114 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
115 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
116
117 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
118 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
119 - new OMF category in the config
120 - create the drl system slice
121
122 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
123 - first working version of 5.0:
124 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
125 - nodefamily is 3-fold with pldistro-fcdistro-arch
126 - new PLC_FLAVOUR config category
127 - reviewed module layout
128 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
129
130 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
131 - support for fedora 12
132 - new package myplc-config for use by sfa
133 - drupal user registration turned off
134
135 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
136 - - fix to make sure when API, BOOT, MONITOR are on the same
137 - machine as WWW that the SSL key,cert for WWW takes precedence.
138 - - Do proper setup for SSL CA certficate to be used as the server
139 - chain.
140
141 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
142 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
143
144 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
145 - depend on pcucontrol
146
147 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
148 - * validate input according to type in plc_config
149 - * added the _genicw system slice
150 - * add tag types for sites and persons
151 - * add new tags for nodes and slices for exemption from myops
152
153 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
154 - turn off drupal on a box that acts as BOOT server but not as WWW server
155 - cleanup some obsolete code for old chroot-jail packaging in the process
156 - new bootcd-kernel script for keeping bootcd variants up2date
157
158 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
159 - Make the /etc/hosts manipulation optional.
160
161 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
162 - Fix SetRole.
163
164 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
165 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
166 - into the DB.
167 - - Added the root ssh key handling support back into plc.d/ssh and the
168 - default xml file.  This should be identical to the way it was in
169 - rc12.
170 - - Added support in the db-config.d/01-init script to register the root
171 - ssh public key with the default administrator.  In this way the root
172 - ssh key will make it into the root account on the nodes by means of
173 - NodeManager's specialaccounts plugin.
174
175 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
176 - db-config ignores sliver tags
177 - sirius's db-config script renamed (was sirious)
178
179 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
180 - fix for silverauth - missing tag types now created at plc startup time
181
182 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
183 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
184
185 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
186 - companion to NM's specialaccounts plugin
187 - do not generate /etc/planetlab/root_ssh_key* anymore
188 - remove related config. variables and conf_files
189
190 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
191 - clarified description text to refer only to plcrt and not other optional
192 - packages.
193
194 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
195 - fixed a bug setting slice multiple attributes with the same tag name
196
197 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
198 - SSL setup for monitor box, and related new config variables
199 - new conf_file for /etc/planetlab/extensions
200 - various tweaks in db-config internals, about initscripts among others
201 - also more messages defined in the db
202
203 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
204 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
205
206 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
207 - bugfix in db-config, tag 4.3-19 would not fly
208
209 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
210 - Refactored db-config into snippets in db-config.d/.
211
212 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
213 - oops, tag 4.3-17 was broken and would not work
214
215 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
216 - bugfix - escape sequences inserted in xml configs
217
218 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
219 - Handle db-config.d files properly.
220
221 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
222 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
223 - than the log file
224 - - Fix db-config to be a bit more cautious when
225 - /etc/planetlab/db-config.d doesn't exist
226 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
227 - .orig files.
228 - - Refactor generic plc-config-tty code into plc_config.py.
229 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
230 - and the list of validated variables and the corresponding
231 - validator() function. This refactoring lets one reuse plc_config.py
232 - as a generic cmdline configuration tool for highly customer MyPLC
233 - like software.
234
235 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
236 - update PCU Type descriptions.
237 - updates to init scripts
238
239 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
240 - requires monitor-pcucontrol so register-wizard can work
241
242 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
243 - cleaned up plc-config-tty, no more need to configure plc-devel
244
245 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
246 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
247
248 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
249 - tighter right permissions on site_admin's authorized keys for more robustness
250
251 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
252 - fix issue in db-config that prevented correct operation
253
254 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
255 - remove support for chroot-based packaging - no crond nor syslog step anymore
256 - plc init script now named plc.init instead of former guest.init
257
258 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
259 - add Monitor to docs build
260
261 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
262 - plc_config.py and plc-config-tty: generalized to work for more diverse
263 - MyPLC configurations.
264 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
265 - deployments and increase the memory limits in php.ini
266 - plc.d/crond: add --full option to vacuumdb
267
268 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
269 - avoid generating ssl certificates for disabled services among www api boot
270
271 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
272 - cleaned up old entries in db-config
273 - mtail more robust
274
275 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
276 - php include path tweaked for plekit includes
277 - reviewed myplc (fka native) packaging dependencies
278 - renumbered 4.3
279
280 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
281 - rename myplc into myplc-chroot and myplc-native into myplc
282 - new settings (shortname & hrn_root) for local peer
283
284
285 %define module_current_branch 4.3