Setting tag myplc-4.3-39
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 39
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
61 - Allow dnsmasq configuration to be extended.
62
63 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
64 - Add DRL slice.
65 - Generalize bootcd-kernel.
66
67 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
68 - support for fedora 12
69 - new package myplc-config for use by sfa
70 - drupal user registration turned off
71
72 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
73 - - fix to make sure when API, BOOT, MONITOR are on the same
74 - machine as WWW that the SSL key,cert for WWW takes precedence.
75 - - Do proper setup for SSL CA certficate to be used as the server
76 - chain.
77
78 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
79 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
80
81 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
82 - depend on pcucontrol
83
84 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
85 - * validate input according to type in plc_config
86 - * added the _genicw system slice
87 - * add tag types for sites and persons
88 - * add new tags for nodes and slices for exemption from myops
89
90 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
91 - turn off drupal on a box that acts as BOOT server but not as WWW server
92 - cleanup some obsolete code for old chroot-jail packaging in the process
93 - new bootcd-kernel script for keeping bootcd variants up2date
94
95 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
96 - Make the /etc/hosts manipulation optional.
97
98 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
99 - Fix SetRole.
100
101 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
102 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
103 - into the DB.
104 - - Added the root ssh key handling support back into plc.d/ssh and the
105 - default xml file.  This should be identical to the way it was in
106 - rc12.
107 - - Added support in the db-config.d/01-init script to register the root
108 - ssh public key with the default administrator.  In this way the root
109 - ssh key will make it into the root account on the nodes by means of
110 - NodeManager's specialaccounts plugin.
111
112 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
113 - db-config ignores sliver tags
114 - sirius's db-config script renamed (was sirious)
115
116 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
117 - fix for silverauth - missing tag types now created at plc startup time
118
119 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
120 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
121
122 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
123 - companion to NM's specialaccounts plugin
124 - do not generate /etc/planetlab/root_ssh_key* anymore
125 - remove related config. variables and conf_files
126
127 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
128 - clarified description text to refer only to plcrt and not other optional
129 - packages.
130
131 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
132 - fixed a bug setting slice multiple attributes with the same tag name
133
134 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
135 - SSL setup for monitor box, and related new config variables
136 - new conf_file for /etc/planetlab/extensions
137 - various tweaks in db-config internals, about initscripts among others
138 - also more messages defined in the db
139
140 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
141 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
142
143 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
144 - bugfix in db-config, tag 4.3-19 would not fly
145
146 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
147 - Refactored db-config into snippets in db-config.d/.
148
149 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
150 - oops, tag 4.3-17 was broken and would not work
151
152 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
153 - bugfix - escape sequences inserted in xml configs
154
155 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
156 - Handle db-config.d files properly.
157
158 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
159 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
160 - than the log file
161 - - Fix db-config to be a bit more cautious when
162 - /etc/planetlab/db-config.d doesn't exist
163 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
164 - .orig files.
165 - - Refactor generic plc-config-tty code into plc_config.py.
166 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
167 - and the list of validated variables and the corresponding
168 - validator() function. This refactoring lets one reuse plc_config.py
169 - as a generic cmdline configuration tool for highly customer MyPLC
170 - like software.
171
172 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
173 - update PCU Type descriptions.
174 - updates to init scripts
175
176 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
177 - requires monitor-pcucontrol so register-wizard can work
178
179 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
180 - cleaned up plc-config-tty, no more need to configure plc-devel
181
182 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
183 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
184
185 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
186 - tighter right permissions on site_admin's authorized keys for more robustness
187
188 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
189 - fix issue in db-config that prevented correct operation
190
191 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
192 - remove support for chroot-based packaging - no crond nor syslog step anymore
193 - plc init script now named plc.init instead of former guest.init
194
195 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
196 - add Monitor to docs build
197
198 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
199 - plc_config.py and plc-config-tty: generalized to work for more diverse
200 - MyPLC configurations.
201 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
202 - deployments and increase the memory limits in php.ini
203 - plc.d/crond: add --full option to vacuumdb
204
205 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
206 - avoid generating ssl certificates for disabled services among www api boot
207
208 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
209 - cleaned up old entries in db-config
210 - mtail more robust
211
212 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
213 - php include path tweaked for plekit includes
214 - reviewed myplc (fka native) packaging dependencies
215 - renumbered 4.3
216
217 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
218 - rename myplc into myplc-chroot and myplc-native into myplc
219 - new settings (shortname & hrn_root) for local peer
220