Setting tag myplc-4.3-40
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 40
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
61 - Make dnsmasq usable.
62
63 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
64 - Allow dnsmasq configuration to be extended.
65
66 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
67 - Add DRL slice.
68 - Generalize bootcd-kernel.
69
70 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
71 - support for fedora 12
72 - new package myplc-config for use by sfa
73 - drupal user registration turned off
74
75 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
76 - - fix to make sure when API, BOOT, MONITOR are on the same
77 - machine as WWW that the SSL key,cert for WWW takes precedence.
78 - - Do proper setup for SSL CA certficate to be used as the server
79 - chain.
80
81 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
82 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
83
84 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
85 - depend on pcucontrol
86
87 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
88 - * validate input according to type in plc_config
89 - * added the _genicw system slice
90 - * add tag types for sites and persons
91 - * add new tags for nodes and slices for exemption from myops
92
93 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
94 - turn off drupal on a box that acts as BOOT server but not as WWW server
95 - cleanup some obsolete code for old chroot-jail packaging in the process
96 - new bootcd-kernel script for keeping bootcd variants up2date
97
98 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
99 - Make the /etc/hosts manipulation optional.
100
101 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
102 - Fix SetRole.
103
104 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
105 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
106 - into the DB.
107 - - Added the root ssh key handling support back into plc.d/ssh and the
108 - default xml file.  This should be identical to the way it was in
109 - rc12.
110 - - Added support in the db-config.d/01-init script to register the root
111 - ssh public key with the default administrator.  In this way the root
112 - ssh key will make it into the root account on the nodes by means of
113 - NodeManager's specialaccounts plugin.
114
115 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
116 - db-config ignores sliver tags
117 - sirius's db-config script renamed (was sirious)
118
119 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
120 - fix for silverauth - missing tag types now created at plc startup time
121
122 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
123 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
124
125 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
126 - companion to NM's specialaccounts plugin
127 - do not generate /etc/planetlab/root_ssh_key* anymore
128 - remove related config. variables and conf_files
129
130 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
131 - clarified description text to refer only to plcrt and not other optional
132 - packages.
133
134 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
135 - fixed a bug setting slice multiple attributes with the same tag name
136
137 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
138 - SSL setup for monitor box, and related new config variables
139 - new conf_file for /etc/planetlab/extensions
140 - various tweaks in db-config internals, about initscripts among others
141 - also more messages defined in the db
142
143 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
144 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
145
146 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
147 - bugfix in db-config, tag 4.3-19 would not fly
148
149 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
150 - Refactored db-config into snippets in db-config.d/.
151
152 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
153 - oops, tag 4.3-17 was broken and would not work
154
155 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
156 - bugfix - escape sequences inserted in xml configs
157
158 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
159 - Handle db-config.d files properly.
160
161 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
162 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
163 - than the log file
164 - - Fix db-config to be a bit more cautious when
165 - /etc/planetlab/db-config.d doesn't exist
166 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
167 - .orig files.
168 - - Refactor generic plc-config-tty code into plc_config.py.
169 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
170 - and the list of validated variables and the corresponding
171 - validator() function. This refactoring lets one reuse plc_config.py
172 - as a generic cmdline configuration tool for highly customer MyPLC
173 - like software.
174
175 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
176 - update PCU Type descriptions.
177 - updates to init scripts
178
179 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
180 - requires monitor-pcucontrol so register-wizard can work
181
182 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
183 - cleaned up plc-config-tty, no more need to configure plc-devel
184
185 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
186 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
187
188 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
189 - tighter right permissions on site_admin's authorized keys for more robustness
190
191 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
192 - fix issue in db-config that prevented correct operation
193
194 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
195 - remove support for chroot-based packaging - no crond nor syslog step anymore
196 - plc init script now named plc.init instead of former guest.init
197
198 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
199 - add Monitor to docs build
200
201 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
202 - plc_config.py and plc-config-tty: generalized to work for more diverse
203 - MyPLC configurations.
204 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
205 - deployments and increase the memory limits in php.ini
206 - plc.d/crond: add --full option to vacuumdb
207
208 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
209 - avoid generating ssl certificates for disabled services among www api boot
210
211 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
212 - cleaned up old entries in db-config
213 - mtail more robust
214
215 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
216 - php include path tweaked for plekit includes
217 - reviewed myplc (fka native) packaging dependencies
218 - renumbered 4.3
219
220 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
221 - rename myplc into myplc-chroot and myplc-native into myplc
222 - new settings (shortname & hrn_root) for local peer
223