Setting tag myplc-5.2-5
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.2
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
56 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
57 - add an rpm-sign dependency on feedora>=16
58
59 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
60 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
61
62 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
63 - plc.d/gpg now does not rm /dev/random but preserves it
64 - this is because libvirt won't let us run mknod
65
66 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
67 - fix typo in check-hrns - used to print 'host' while dealing with persons
68
69 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
70 - supports httpd config for either mod_python (preferred) or mod_wsgi
71 - requires mod_wsgi on f18 only, otherwise mod_python
72 - supports httpd config for apache 2.4 (f18)
73 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
74
75 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
76 - bugfix in check-vsys-defaults.py
77
78 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
79 - define open_basedir in php.ini to stop confidentiality leak
80 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
81 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
82 - new utilities check-hrns.py and check-vsys-defaults.py
83
84 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
85 - set TimeoutSec to 300 in plc.service
86 - remove ref to deprecated svn $URL$ in db-config usage
87
88 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
89 - expose mtail.py as simply mtail
90
91 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
92 - plc-kml.py now has support for nodegroups
93
94 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
95 - use nodeimage package instead of deprecated bootstrapfs
96 - has systemd-friendly startup script
97 - plc_reload moved to functions/ - no more service plc reload
98 - no svn keywords anymore
99
100 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
101 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
102
103 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
104 - new settings for myslice (comon&tophat) and monitor (db)
105 - removed mentions of chroot in description
106 - can redo myplc-docs on broken f12-latex
107 - set short_open_tag in php.ini
108 - fixes in gen-sites-xml (is that still used ?)
109 - partial-repo.sh has moved to 'build' where it more belongs
110 - tweaks in convenience tool 'mtail'
111
112 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
113 - fixed changelog, no change from 5.0-16
114
115 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
116 - requires ed for the plc.d/packages step
117 - sirius initscript to handle stop and restart
118
119 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
120 - ignore steps in db-config.d if they have a '.' or '~' in their name
121
122 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
123 - can redo myplc-docs without the doc for monitor
124
125 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
126 - no semantic change - just fixed specfile for git URL
127
128 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
129 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
130
131 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
132 - add missing files to rpm package
133
134 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
135 - mtail.py -s for SFA
136 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
137
138 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
139 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
140
141 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
142 - plc-config-tty now has a validator on booleans
143 - e.g. entering 'True' now is rejected rather than silently recording 'false'
144
145 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
146 - disable mod_wsgi
147
148 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
149 - module name changes
150 - start wsgi support
151
152 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
153 - new setting PLC_RESERVATION_GRANULARITY
154
155 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
156 - * partial-repo.sh script
157 - * preserve key along with certificates
158
159 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
160 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
161
162 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
163 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
164 - new OMF category in the config
165 - create the drl system slice
166
167 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
168 - first working version of 5.0:
169 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
170 - nodefamily is 3-fold with pldistro-fcdistro-arch
171 - new PLC_FLAVOUR config category
172 - reviewed module layout
173 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
174
175 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
176 - support for fedora 12
177 - new package myplc-config for use by sfa
178 - drupal user registration turned off
179
180 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
181 - - fix to make sure when API, BOOT, MONITOR are on the same
182 - machine as WWW that the SSL key,cert for WWW takes precedence.
183 - - Do proper setup for SSL CA certficate to be used as the server
184 - chain.
185
186 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
187 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
188
189 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
190 - depend on pcucontrol
191
192 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
193 - * validate input according to type in plc_config
194 - * added the _genicw system slice
195 - * add tag types for sites and persons
196 - * add new tags for nodes and slices for exemption from myops
197
198 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
199 - turn off drupal on a box that acts as BOOT server but not as WWW server
200 - cleanup some obsolete code for old chroot-jail packaging in the process
201 - new bootcd-kernel script for keeping bootcd variants up2date
202
203 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
204 - Make the /etc/hosts manipulation optional.
205
206 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
207 - Fix SetRole.
208
209 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
210 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
211 - into the DB.
212 - - Added the root ssh key handling support back into plc.d/ssh and the
213 - default xml file.  This should be identical to the way it was in
214 - rc12.
215 - - Added support in the db-config.d/01-init script to register the root
216 - ssh public key with the default administrator.  In this way the root
217 - ssh key will make it into the root account on the nodes by means of
218 - NodeManager's specialaccounts plugin.
219
220 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
221 - db-config ignores sliver tags
222 - sirius's db-config script renamed (was sirious)
223
224 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
225 - fix for silverauth - missing tag types now created at plc startup time
226
227 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
228 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
229
230 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
231 - companion to NM's specialaccounts plugin
232 - do not generate /etc/planetlab/root_ssh_key* anymore
233 - remove related config. variables and conf_files
234
235 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
236 - clarified description text to refer only to plcrt and not other optional
237 - packages.
238
239 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
240 - fixed a bug setting slice multiple attributes with the same tag name
241
242 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
243 - SSL setup for monitor box, and related new config variables
244 - new conf_file for /etc/planetlab/extensions
245 - various tweaks in db-config internals, about initscripts among others
246 - also more messages defined in the db
247
248 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
249 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
250
251 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
252 - bugfix in db-config, tag 4.3-19 would not fly
253
254 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
255 - Refactored db-config into snippets in db-config.d/.
256
257 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
258 - oops, tag 4.3-17 was broken and would not work
259
260 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
261 - bugfix - escape sequences inserted in xml configs
262
263 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
264 - Handle db-config.d files properly.
265
266 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
267 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
268 - than the log file
269 - - Fix db-config to be a bit more cautious when
270 - /etc/planetlab/db-config.d doesn't exist
271 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
272 - .orig files.
273 - - Refactor generic plc-config-tty code into plc_config.py.
274 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
275 - and the list of validated variables and the corresponding
276 - validator() function. This refactoring lets one reuse plc_config.py
277 - as a generic cmdline configuration tool for highly customer MyPLC
278 - like software.
279
280 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
281 - update PCU Type descriptions.
282 - updates to init scripts
283
284 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
285 - requires monitor-pcucontrol so register-wizard can work
286
287 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
288 - cleaned up plc-config-tty, no more need to configure plc-devel
289
290 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
291 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
292
293 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
294 - tighter right permissions on site_admin's authorized keys for more robustness
295
296 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
297 - fix issue in db-config that prevented correct operation
298
299 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
300 - remove support for chroot-based packaging - no crond nor syslog step anymore
301 - plc init script now named plc.init instead of former guest.init
302
303 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
304 - add Monitor to docs build
305
306 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
307 - plc_config.py and plc-config-tty: generalized to work for more diverse
308 - MyPLC configurations.
309 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
310 - deployments and increase the memory limits in php.ini
311 - plc.d/crond: add --full option to vacuumdb
312
313 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
314 - avoid generating ssl certificates for disabled services among www api boot
315
316 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
317 - cleaned up old entries in db-config
318 - mtail more robust
319
320 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
321 - php include path tweaked for plekit includes
322 - reviewed myplc (fka native) packaging dependencies
323 - renumbered 4.3
324
325 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
326 - rename myplc into myplc-chroot and myplc-native into myplc
327 - new settings (shortname & hrn_root) for local peer
328
329
330 %define module_current_branch 4.3