catch up with code running at PLE for nicer layout
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
56 - use nodeimage package instead of deprecated bootstrapfs
57 - has systemd-friendly startup script
58 - plc_reload moved to functions/ - no more service plc reload
59 - no svn keywords anymore
60
61 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
62 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
63
64 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
65 - new settings for myslice (comon&tophat) and monitor (db)
66 - removed mentions of chroot in description
67 - can redo myplc-docs on broken f12-latex
68 - set short_open_tag in php.ini
69 - fixes in gen-sites-xml (is that still used ?)
70 - partial-repo.sh has moved to 'build' where it more belongs
71 - tweaks in convenience tool 'mtail'
72
73 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
74 - fixed changelog, no change from 5.0-16
75
76 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
77 - requires ed for the plc.d/packages step
78 - sirius initscript to handle stop and restart
79
80 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
81 - ignore steps in db-config.d if they have a '.' or '~' in their name
82
83 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
84 - can redo myplc-docs without the doc for monitor
85
86 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
87 - no semantic change - just fixed specfile for git URL
88
89 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
90 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
91
92 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
93 - add missing files to rpm package
94
95 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
96 - mtail.py -s for SFA
97 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
98
99 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
100 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
101
102 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
103 - plc-config-tty now has a validator on booleans
104 - e.g. entering 'True' now is rejected rather than silently recording 'false'
105
106 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
107 - disable mod_wsgi
108
109 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
110 - module name changes
111 - start wsgi support
112
113 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
114 - new setting PLC_RESERVATION_GRANULARITY
115
116 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
117 - * partial-repo.sh script
118 - * preserve key along with certificates
119
120 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
121 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
122
123 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
124 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
125 - new OMF category in the config
126 - create the drl system slice
127
128 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
129 - first working version of 5.0:
130 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
131 - nodefamily is 3-fold with pldistro-fcdistro-arch
132 - new PLC_FLAVOUR config category
133 - reviewed module layout
134 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
135
136 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
137 - support for fedora 12
138 - new package myplc-config for use by sfa
139 - drupal user registration turned off
140
141 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
142 - - fix to make sure when API, BOOT, MONITOR are on the same
143 - machine as WWW that the SSL key,cert for WWW takes precedence.
144 - - Do proper setup for SSL CA certficate to be used as the server
145 - chain.
146
147 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
148 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
149
150 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
151 - depend on pcucontrol
152
153 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
154 - * validate input according to type in plc_config
155 - * added the _genicw system slice
156 - * add tag types for sites and persons
157 - * add new tags for nodes and slices for exemption from myops
158
159 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
160 - turn off drupal on a box that acts as BOOT server but not as WWW server
161 - cleanup some obsolete code for old chroot-jail packaging in the process
162 - new bootcd-kernel script for keeping bootcd variants up2date
163
164 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
165 - Make the /etc/hosts manipulation optional.
166
167 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
168 - Fix SetRole.
169
170 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
171 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
172 - into the DB.
173 - - Added the root ssh key handling support back into plc.d/ssh and the
174 - default xml file.  This should be identical to the way it was in
175 - rc12.
176 - - Added support in the db-config.d/01-init script to register the root
177 - ssh public key with the default administrator.  In this way the root
178 - ssh key will make it into the root account on the nodes by means of
179 - NodeManager's specialaccounts plugin.
180
181 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
182 - db-config ignores sliver tags
183 - sirius's db-config script renamed (was sirious)
184
185 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
186 - fix for silverauth - missing tag types now created at plc startup time
187
188 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
189 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
190
191 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
192 - companion to NM's specialaccounts plugin
193 - do not generate /etc/planetlab/root_ssh_key* anymore
194 - remove related config. variables and conf_files
195
196 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
197 - clarified description text to refer only to plcrt and not other optional
198 - packages.
199
200 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
201 - fixed a bug setting slice multiple attributes with the same tag name
202
203 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
204 - SSL setup for monitor box, and related new config variables
205 - new conf_file for /etc/planetlab/extensions
206 - various tweaks in db-config internals, about initscripts among others
207 - also more messages defined in the db
208
209 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
210 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
211
212 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
213 - bugfix in db-config, tag 4.3-19 would not fly
214
215 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
216 - Refactored db-config into snippets in db-config.d/.
217
218 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
219 - oops, tag 4.3-17 was broken and would not work
220
221 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
222 - bugfix - escape sequences inserted in xml configs
223
224 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
225 - Handle db-config.d files properly.
226
227 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
228 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
229 - than the log file
230 - - Fix db-config to be a bit more cautious when
231 - /etc/planetlab/db-config.d doesn't exist
232 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
233 - .orig files.
234 - - Refactor generic plc-config-tty code into plc_config.py.
235 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
236 - and the list of validated variables and the corresponding
237 - validator() function. This refactoring lets one reuse plc_config.py
238 - as a generic cmdline configuration tool for highly customer MyPLC
239 - like software.
240
241 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
242 - update PCU Type descriptions.
243 - updates to init scripts
244
245 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
246 - requires monitor-pcucontrol so register-wizard can work
247
248 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
249 - cleaned up plc-config-tty, no more need to configure plc-devel
250
251 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
252 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
253
254 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
255 - tighter right permissions on site_admin's authorized keys for more robustness
256
257 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
258 - fix issue in db-config that prevented correct operation
259
260 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
261 - remove support for chroot-based packaging - no crond nor syslog step anymore
262 - plc init script now named plc.init instead of former guest.init
263
264 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
265 - add Monitor to docs build
266
267 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
268 - plc_config.py and plc-config-tty: generalized to work for more diverse
269 - MyPLC configurations.
270 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
271 - deployments and increase the memory limits in php.ini
272 - plc.d/crond: add --full option to vacuumdb
273
274 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
275 - avoid generating ssl certificates for disabled services among www api boot
276
277 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
278 - cleaned up old entries in db-config
279 - mtail more robust
280
281 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
282 - php include path tweaked for plekit includes
283 - reviewed myplc (fka native) packaging dependencies
284 - renumbered 4.3
285
286 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
287 - rename myplc into myplc-chroot and myplc-native into myplc
288 - new settings (shortname & hrn_root) for local peer
289
290
291 %define module_current_branch 4.3