Setting tag myplc-4.3-47
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 47
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
61 - attempt to fix small glitches
62
63 * Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
64 - enable short_open_tag for backward compatibility
65
66 * Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
67 - Cherry-pick PHP5 timezone fix form master
68
69 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
70 - pick the greatest version as a kernel
71
72 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
73 - handle directory name changes for myplc-docs package as well
74
75 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
76 - handle directory name changes
77
78 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
79 - Use correct resolv.conf file.
80
81 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
82 - Make dnsmasq usable.
83
84 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
85 - Allow dnsmasq configuration to be extended.
86
87 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
88 - Add DRL slice.
89 - Generalize bootcd-kernel.
90
91 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
92 - support for fedora 12
93 - new package myplc-config for use by sfa
94 - drupal user registration turned off
95
96 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
97 - - fix to make sure when API, BOOT, MONITOR are on the same
98 - machine as WWW that the SSL key,cert for WWW takes precedence.
99 - - Do proper setup for SSL CA certficate to be used as the server
100 - chain.
101
102 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
103 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
104
105 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
106 - depend on pcucontrol
107
108 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
109 - * validate input according to type in plc_config
110 - * added the _genicw system slice
111 - * add tag types for sites and persons
112 - * add new tags for nodes and slices for exemption from myops
113
114 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
115 - turn off drupal on a box that acts as BOOT server but not as WWW server
116 - cleanup some obsolete code for old chroot-jail packaging in the process
117 - new bootcd-kernel script for keeping bootcd variants up2date
118
119 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
120 - Make the /etc/hosts manipulation optional.
121
122 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
123 - Fix SetRole.
124
125 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
126 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
127 - into the DB.
128 - - Added the root ssh key handling support back into plc.d/ssh and the
129 - default xml file.  This should be identical to the way it was in
130 - rc12.
131 - - Added support in the db-config.d/01-init script to register the root
132 - ssh public key with the default administrator.  In this way the root
133 - ssh key will make it into the root account on the nodes by means of
134 - NodeManager's specialaccounts plugin.
135
136 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
137 - db-config ignores sliver tags
138 - sirius's db-config script renamed (was sirious)
139
140 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
141 - fix for silverauth - missing tag types now created at plc startup time
142
143 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
144 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
145
146 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
147 - companion to NM's specialaccounts plugin
148 - do not generate /etc/planetlab/root_ssh_key* anymore
149 - remove related config. variables and conf_files
150
151 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
152 - clarified description text to refer only to plcrt and not other optional
153 - packages.
154
155 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
156 - fixed a bug setting slice multiple attributes with the same tag name
157
158 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
159 - SSL setup for monitor box, and related new config variables
160 - new conf_file for /etc/planetlab/extensions
161 - various tweaks in db-config internals, about initscripts among others
162 - also more messages defined in the db
163
164 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
165 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
166
167 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
168 - bugfix in db-config, tag 4.3-19 would not fly
169
170 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
171 - Refactored db-config into snippets in db-config.d/.
172
173 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
174 - oops, tag 4.3-17 was broken and would not work
175
176 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
177 - bugfix - escape sequences inserted in xml configs
178
179 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
180 - Handle db-config.d files properly.
181
182 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
183 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
184 - than the log file
185 - - Fix db-config to be a bit more cautious when
186 - /etc/planetlab/db-config.d doesn't exist
187 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
188 - .orig files.
189 - - Refactor generic plc-config-tty code into plc_config.py.
190 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
191 - and the list of validated variables and the corresponding
192 - validator() function. This refactoring lets one reuse plc_config.py
193 - as a generic cmdline configuration tool for highly customer MyPLC
194 - like software.
195
196 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
197 - update PCU Type descriptions.
198 - updates to init scripts
199
200 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
201 - requires monitor-pcucontrol so register-wizard can work
202
203 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
204 - cleaned up plc-config-tty, no more need to configure plc-devel
205
206 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
207 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
208
209 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
210 - tighter right permissions on site_admin's authorized keys for more robustness
211
212 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
213 - fix issue in db-config that prevented correct operation
214
215 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
216 - remove support for chroot-based packaging - no crond nor syslog step anymore
217 - plc init script now named plc.init instead of former guest.init
218
219 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
220 - add Monitor to docs build
221
222 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
223 - plc_config.py and plc-config-tty: generalized to work for more diverse
224 - MyPLC configurations.
225 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
226 - deployments and increase the memory limits in php.ini
227 - plc.d/crond: add --full option to vacuumdb
228
229 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
230 - avoid generating ssl certificates for disabled services among www api boot
231
232 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
233 - cleaned up old entries in db-config
234 - mtail more robust
235
236 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
237 - php include path tweaked for plekit includes
238 - reviewed myplc (fka native) packaging dependencies
239 - renumbered 4.3
240
241 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
242 - rename myplc into myplc-chroot and myplc-native into myplc
243 - new settings (shortname & hrn_root) for local peer
244