Setting tag myplc-4.3-44
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 44
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
61 - pick the greatest version as a kernel
62
63 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
64 - handle directory name changes for myplc-docs package as well
65
66 * Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
67 - handle directory name changes
68
69 * Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
70 - Use correct resolv.conf file.
71
72 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
73 - Make dnsmasq usable.
74
75 * Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
76 - Allow dnsmasq configuration to be extended.
77
78 * Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
79 - Add DRL slice.
80 - Generalize bootcd-kernel.
81
82 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
83 - support for fedora 12
84 - new package myplc-config for use by sfa
85 - drupal user registration turned off
86
87 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
88 - - fix to make sure when API, BOOT, MONITOR are on the same
89 - machine as WWW that the SSL key,cert for WWW takes precedence.
90 - - Do proper setup for SSL CA certficate to be used as the server
91 - chain.
92
93 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
94 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
95
96 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
97 - depend on pcucontrol
98
99 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
100 - * validate input according to type in plc_config
101 - * added the _genicw system slice
102 - * add tag types for sites and persons
103 - * add new tags for nodes and slices for exemption from myops
104
105 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
106 - turn off drupal on a box that acts as BOOT server but not as WWW server
107 - cleanup some obsolete code for old chroot-jail packaging in the process
108 - new bootcd-kernel script for keeping bootcd variants up2date
109
110 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
111 - Make the /etc/hosts manipulation optional.
112
113 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
114 - Fix SetRole.
115
116 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
117 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
118 - into the DB.
119 - - Added the root ssh key handling support back into plc.d/ssh and the
120 - default xml file.  This should be identical to the way it was in
121 - rc12.
122 - - Added support in the db-config.d/01-init script to register the root
123 - ssh public key with the default administrator.  In this way the root
124 - ssh key will make it into the root account on the nodes by means of
125 - NodeManager's specialaccounts plugin.
126
127 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
128 - db-config ignores sliver tags
129 - sirius's db-config script renamed (was sirious)
130
131 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
132 - fix for silverauth - missing tag types now created at plc startup time
133
134 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
135 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
136
137 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
138 - companion to NM's specialaccounts plugin
139 - do not generate /etc/planetlab/root_ssh_key* anymore
140 - remove related config. variables and conf_files
141
142 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
143 - clarified description text to refer only to plcrt and not other optional
144 - packages.
145
146 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
147 - fixed a bug setting slice multiple attributes with the same tag name
148
149 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
150 - SSL setup for monitor box, and related new config variables
151 - new conf_file for /etc/planetlab/extensions
152 - various tweaks in db-config internals, about initscripts among others
153 - also more messages defined in the db
154
155 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
156 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
157
158 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
159 - bugfix in db-config, tag 4.3-19 would not fly
160
161 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
162 - Refactored db-config into snippets in db-config.d/.
163
164 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
165 - oops, tag 4.3-17 was broken and would not work
166
167 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
168 - bugfix - escape sequences inserted in xml configs
169
170 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
171 - Handle db-config.d files properly.
172
173 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
174 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
175 - than the log file
176 - - Fix db-config to be a bit more cautious when
177 - /etc/planetlab/db-config.d doesn't exist
178 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
179 - .orig files.
180 - - Refactor generic plc-config-tty code into plc_config.py.
181 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
182 - and the list of validated variables and the corresponding
183 - validator() function. This refactoring lets one reuse plc_config.py
184 - as a generic cmdline configuration tool for highly customer MyPLC
185 - like software.
186
187 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
188 - update PCU Type descriptions.
189 - updates to init scripts
190
191 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
192 - requires monitor-pcucontrol so register-wizard can work
193
194 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
195 - cleaned up plc-config-tty, no more need to configure plc-devel
196
197 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
198 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
199
200 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
201 - tighter right permissions on site_admin's authorized keys for more robustness
202
203 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
204 - fix issue in db-config that prevented correct operation
205
206 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
207 - remove support for chroot-based packaging - no crond nor syslog step anymore
208 - plc init script now named plc.init instead of former guest.init
209
210 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
211 - add Monitor to docs build
212
213 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
214 - plc_config.py and plc-config-tty: generalized to work for more diverse
215 - MyPLC configurations.
216 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
217 - deployments and increase the memory limits in php.ini
218 - plc.d/crond: add --full option to vacuumdb
219
220 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
221 - avoid generating ssl certificates for disabled services among www api boot
222
223 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
224 - cleaned up old entries in db-config
225 - mtail more robust
226
227 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
228 - php include path tweaked for plekit includes
229 - reviewed myplc (fka native) packaging dependencies
230 - renumbered 4.3
231
232 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
233 - rename myplc into myplc-chroot and myplc-native into myplc
234 - new settings (shortname & hrn_root) for local peer
235