Setting tag myplc-5.3-2
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.3
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
56 - tweaks in check-hrns.py
57 - do not require PyXML any more
58
59 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
60 - review check-hrns for plcapi-5.3
61 - add PLC_HRN_ROOT in usual plc-config-tty's settings
62
63 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
64 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
65 - add an rpm-sign dependency on feedora>=16
66
67 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-4
68 - drop PLC_OMF_XMPP_{USER,PASSWORD} from config
69
70 * Tue Apr 23 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-3
71 - plc.d/gpg now does not rm /dev/random but preserves it
72 - this is because libvirt won't let us run mknod
73
74 * Wed Apr 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-2
75 - fix typo in check-hrns - used to print 'host' while dealing with persons
76
77 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-1
78 - supports httpd config for either mod_python (preferred) or mod_wsgi
79 - requires mod_wsgi on f18 only, otherwise mod_python
80 - supports httpd config for apache 2.4 (f18)
81 - new config variable PLC_FLAVOUR_VIRT_MAP to set 'virt' from fcdistro
82
83 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-6
84 - bugfix in check-vsys-defaults.py
85
86 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-5
87 - define open_basedir in php.ini to stop confidentiality leak
88 - new utility slice_ssh_keys.py for showing sliver keys (OMF interop)
89 - new config setting PLC_VSYS_DEFAULTS for vsys tags granted to all
90 - new utilities check-hrns.py and check-vsys-defaults.py
91
92 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-4
93 - set TimeoutSec to 300 in plc.service
94 - remove ref to deprecated svn $URL$ in db-config usage
95
96 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-3
97 - expose mtail.py as simply mtail
98
99 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-2
100 - plc-kml.py now has support for nodegroups
101
102 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.1-1
103 - use nodeimage package instead of deprecated bootstrapfs
104 - has systemd-friendly startup script
105 - plc_reload moved to functions/ - no more service plc reload
106 - no svn keywords anymore
107
108 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
109 - new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
110
111 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
112 - new settings for myslice (comon&tophat) and monitor (db)
113 - removed mentions of chroot in description
114 - can redo myplc-docs on broken f12-latex
115 - set short_open_tag in php.ini
116 - fixes in gen-sites-xml (is that still used ?)
117 - partial-repo.sh has moved to 'build' where it more belongs
118 - tweaks in convenience tool 'mtail'
119
120 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
121 - fixed changelog, no change from 5.0-16
122
123 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
124 - requires ed for the plc.d/packages step
125 - sirius initscript to handle stop and restart
126
127 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
128 - ignore steps in db-config.d if they have a '.' or '~' in their name
129
130 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
131 - can redo myplc-docs without the doc for monitor
132
133 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
134 - no semantic change - just fixed specfile for git URL
135
136 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
137 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
138
139 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
140 - add missing files to rpm package
141
142 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
143 - mtail.py -s for SFA
144 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
145
146 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
147 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
148
149 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
150 - plc-config-tty now has a validator on booleans
151 - e.g. entering 'True' now is rejected rather than silently recording 'false'
152
153 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
154 - disable mod_wsgi
155
156 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
157 - module name changes
158 - start wsgi support
159
160 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
161 - new setting PLC_RESERVATION_GRANULARITY
162
163 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
164 - * partial-repo.sh script
165 - * preserve key along with certificates
166
167 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
168 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
169
170 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
171 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
172 - new OMF category in the config
173 - create the drl system slice
174
175 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
176 - first working version of 5.0:
177 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
178 - nodefamily is 3-fold with pldistro-fcdistro-arch
179 - new PLC_FLAVOUR config category
180 - reviewed module layout
181 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
182
183 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
184 - support for fedora 12
185 - new package myplc-config for use by sfa
186 - drupal user registration turned off
187
188 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
189 - - fix to make sure when API, BOOT, MONITOR are on the same
190 - machine as WWW that the SSL key,cert for WWW takes precedence.
191 - - Do proper setup for SSL CA certficate to be used as the server
192 - chain.
193
194 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
195 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
196
197 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
198 - depend on pcucontrol
199
200 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
201 - * validate input according to type in plc_config
202 - * added the _genicw system slice
203 - * add tag types for sites and persons
204 - * add new tags for nodes and slices for exemption from myops
205
206 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
207 - turn off drupal on a box that acts as BOOT server but not as WWW server
208 - cleanup some obsolete code for old chroot-jail packaging in the process
209 - new bootcd-kernel script for keeping bootcd variants up2date
210
211 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
212 - Make the /etc/hosts manipulation optional.
213
214 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
215 - Fix SetRole.
216
217 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
218 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
219 - into the DB.
220 - - Added the root ssh key handling support back into plc.d/ssh and the
221 - default xml file.  This should be identical to the way it was in
222 - rc12.
223 - - Added support in the db-config.d/01-init script to register the root
224 - ssh public key with the default administrator.  In this way the root
225 - ssh key will make it into the root account on the nodes by means of
226 - NodeManager's specialaccounts plugin.
227
228 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
229 - db-config ignores sliver tags
230 - sirius's db-config script renamed (was sirious)
231
232 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
233 - fix for silverauth - missing tag types now created at plc startup time
234
235 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
236 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
237
238 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
239 - companion to NM's specialaccounts plugin
240 - do not generate /etc/planetlab/root_ssh_key* anymore
241 - remove related config. variables and conf_files
242
243 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
244 - clarified description text to refer only to plcrt and not other optional
245 - packages.
246
247 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
248 - fixed a bug setting slice multiple attributes with the same tag name
249
250 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
251 - SSL setup for monitor box, and related new config variables
252 - new conf_file for /etc/planetlab/extensions
253 - various tweaks in db-config internals, about initscripts among others
254 - also more messages defined in the db
255
256 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
257 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
258
259 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
260 - bugfix in db-config, tag 4.3-19 would not fly
261
262 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
263 - Refactored db-config into snippets in db-config.d/.
264
265 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
266 - oops, tag 4.3-17 was broken and would not work
267
268 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
269 - bugfix - escape sequences inserted in xml configs
270
271 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
272 - Handle db-config.d files properly.
273
274 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
275 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
276 - than the log file
277 - - Fix db-config to be a bit more cautious when
278 - /etc/planetlab/db-config.d doesn't exist
279 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
280 - .orig files.
281 - - Refactor generic plc-config-tty code into plc_config.py.
282 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
283 - and the list of validated variables and the corresponding
284 - validator() function. This refactoring lets one reuse plc_config.py
285 - as a generic cmdline configuration tool for highly customer MyPLC
286 - like software.
287
288 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
289 - update PCU Type descriptions.
290 - updates to init scripts
291
292 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
293 - requires monitor-pcucontrol so register-wizard can work
294
295 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
296 - cleaned up plc-config-tty, no more need to configure plc-devel
297
298 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
299 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
300
301 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
302 - tighter right permissions on site_admin's authorized keys for more robustness
303
304 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
305 - fix issue in db-config that prevented correct operation
306
307 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
308 - remove support for chroot-based packaging - no crond nor syslog step anymore
309 - plc init script now named plc.init instead of former guest.init
310
311 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
312 - add Monitor to docs build
313
314 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
315 - plc_config.py and plc-config-tty: generalized to work for more diverse
316 - MyPLC configurations.
317 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
318 - deployments and increase the memory limits in php.ini
319 - plc.d/crond: add --full option to vacuumdb
320
321 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
322 - avoid generating ssl certificates for disabled services among www api boot
323
324 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
325 - cleaned up old entries in db-config
326 - mtail more robust
327
328 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
329 - php include path tweaked for plekit includes
330 - reviewed myplc (fka native) packaging dependencies
331 - renumbered 4.3
332
333 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
334 - rename myplc into myplc-chroot and myplc-native into myplc
335 - new settings (shortname & hrn_root) for local peer
336
337
338 %define module_current_branch 4.3