Setting tag MyPLC-4.3-25
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 25
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
61 - companion to NM's specialaccounts plugin
62 - do not generate /etc/planetlab/root_ssh_key* anymore
63 - remove related config. variables and conf_files
64
65 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
66 - clarified description text to refer only to plcrt and not other optional
67 - packages.
68
69 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
70 - fixed a bug setting slice multiple attributes with the same tag name
71
72 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
73 - SSL setup for monitor box, and related new config variables
74 - new conf_file for /etc/planetlab/extensions
75 - various tweaks in db-config internals, about initscripts among others
76 - also more messages defined in the db
77
78 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
79 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
80
81 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
82 - bugfix in db-config, tag 4.3-19 would not fly
83
84 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
85 - Refactored db-config into snippets in db-config.d/.
86
87 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
88 - oops, tag 4.3-17 was broken and would not work
89
90 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
91 - bugfix - escape sequences inserted in xml configs
92
93 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
94 - Handle db-config.d files properly.
95
96 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
97 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
98 - than the log file
99 - - Fix db-config to be a bit more cautious when
100 - /etc/planetlab/db-config.d doesn't exist
101 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
102 - .orig files.
103 - - Refactor generic plc-config-tty code into plc_config.py.
104 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
105 - and the list of validated variables and the corresponding
106 - validator() function. This refactoring lets one reuse plc_config.py
107 - as a generic cmdline configuration tool for highly customer MyPLC
108 - like software.
109
110 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
111 - update PCU Type descriptions.
112 - updates to init scripts
113
114 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
115 - requires monitor-pcucontrol so register-wizard can work
116
117 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
118 - cleaned up plc-config-tty, no more need to configure plc-devel
119
120 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
121 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
122
123 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
124 - tighter right permissions on site_admin's authorized keys for more robustness
125
126 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
127 - fix issue in db-config that prevented correct operation
128
129 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
130 - remove support for chroot-based packaging - no crond nor syslog step anymore
131 - plc init script now named plc.init instead of former guest.init
132
133 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
134 - add Monitor to docs build
135
136 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
137 - plc_config.py and plc-config-tty: generalized to work for more diverse
138 - MyPLC configurations.
139 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
140 - deployments and increase the memory limits in php.ini
141 - plc.d/crond: add --full option to vacuumdb
142
143 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
144 - avoid generating ssl certificates for disabled services among www api boot
145
146 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
147 - cleaned up old entries in db-config
148 - mtail more robust
149
150 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
151 - php include path tweaked for plekit includes
152 - reviewed myplc (fka native) packaging dependencies
153 - renumbered 4.3
154
155 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
156 - rename myplc into myplc-chroot and myplc-native into myplc
157 - new settings (shortname & hrn_root) for local peer
158