Setting tag MyPLC-5.0-1
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
61 - first working version of 5.0:
62 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
63 - nodefamily is 3-fold with pldistro-fcdistro-arch
64 - new PLC_FLAVOUR config category
65 - reviewed module layout
66 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
67
68 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
69 - support for fedora 12
70 - new package myplc-config for use by sfa
71 - drupal user registration turned off
72
73 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
74 - - fix to make sure when API, BOOT, MONITOR are on the same
75 - machine as WWW that the SSL key,cert for WWW takes precedence.
76 - - Do proper setup for SSL CA certficate to be used as the server
77 - chain.
78
79 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
80 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
81
82 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
83 - depend on pcucontrol
84
85 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
86 - * validate input according to type in plc_config
87 - * added the _genicw system slice
88 - * add tag types for sites and persons
89 - * add new tags for nodes and slices for exemption from myops
90
91 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
92 - turn off drupal on a box that acts as BOOT server but not as WWW server
93 - cleanup some obsolete code for old chroot-jail packaging in the process
94 - new bootcd-kernel script for keeping bootcd variants up2date
95
96 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
97 - Make the /etc/hosts manipulation optional.
98
99 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
100 - Fix SetRole.
101
102 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
103 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
104 - into the DB.
105 - - Added the root ssh key handling support back into plc.d/ssh and the
106 - default xml file.  This should be identical to the way it was in
107 - rc12.
108 - - Added support in the db-config.d/01-init script to register the root
109 - ssh public key with the default administrator.  In this way the root
110 - ssh key will make it into the root account on the nodes by means of
111 - NodeManager's specialaccounts plugin.
112
113 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
114 - db-config ignores sliver tags
115 - sirius's db-config script renamed (was sirious)
116
117 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
118 - fix for silverauth - missing tag types now created at plc startup time
119
120 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
121 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
122
123 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
124 - companion to NM's specialaccounts plugin
125 - do not generate /etc/planetlab/root_ssh_key* anymore
126 - remove related config. variables and conf_files
127
128 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
129 - clarified description text to refer only to plcrt and not other optional
130 - packages.
131
132 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
133 - fixed a bug setting slice multiple attributes with the same tag name
134
135 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
136 - SSL setup for monitor box, and related new config variables
137 - new conf_file for /etc/planetlab/extensions
138 - various tweaks in db-config internals, about initscripts among others
139 - also more messages defined in the db
140
141 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
142 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
143
144 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
145 - bugfix in db-config, tag 4.3-19 would not fly
146
147 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
148 - Refactored db-config into snippets in db-config.d/.
149
150 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
151 - oops, tag 4.3-17 was broken and would not work
152
153 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
154 - bugfix - escape sequences inserted in xml configs
155
156 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
157 - Handle db-config.d files properly.
158
159 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
160 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
161 - than the log file
162 - - Fix db-config to be a bit more cautious when
163 - /etc/planetlab/db-config.d doesn't exist
164 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
165 - .orig files.
166 - - Refactor generic plc-config-tty code into plc_config.py.
167 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
168 - and the list of validated variables and the corresponding
169 - validator() function. This refactoring lets one reuse plc_config.py
170 - as a generic cmdline configuration tool for highly customer MyPLC
171 - like software.
172
173 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
174 - update PCU Type descriptions.
175 - updates to init scripts
176
177 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
178 - requires monitor-pcucontrol so register-wizard can work
179
180 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
181 - cleaned up plc-config-tty, no more need to configure plc-devel
182
183 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
184 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
185
186 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
187 - tighter right permissions on site_admin's authorized keys for more robustness
188
189 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
190 - fix issue in db-config that prevented correct operation
191
192 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
193 - remove support for chroot-based packaging - no crond nor syslog step anymore
194 - plc init script now named plc.init instead of former guest.init
195
196 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
197 - add Monitor to docs build
198
199 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
200 - plc_config.py and plc-config-tty: generalized to work for more diverse
201 - MyPLC configurations.
202 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
203 - deployments and increase the memory limits in php.ini
204 - plc.d/crond: add --full option to vacuumdb
205
206 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
207 - avoid generating ssl certificates for disabled services among www api boot
208
209 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
210 - cleaned up old entries in db-config
211 - mtail more robust
212
213 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
214 - php include path tweaked for plekit includes
215 - reviewed myplc (fka native) packaging dependencies
216 - renumbered 4.3
217
218 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
219 - rename myplc into myplc-chroot and myplc-native into myplc
220 - new settings (shortname & hrn_root) for local peer
221
222
223 %define module_current_branch 4.3