Setting tag MyPLC-4.3-35
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 35
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
61 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
62
63 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
64 - depend on pcucontrol
65
66 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
67 - * validate input according to type in plc_config
68 - * added the _genicw system slice
69 - * add tag types for sites and persons
70 - * add new tags for nodes and slices for exemption from myops
71
72 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
73 - turn off drupal on a box that acts as BOOT server but not as WWW server
74 - cleanup some obsolete code for old chroot-jail packaging in the process
75 - new bootcd-kernel script for keeping bootcd variants up2date
76
77 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
78 - Make the /etc/hosts manipulation optional.
79
80 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
81 - Fix SetRole.
82
83 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
84 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
85 - into the DB.
86 - - Added the root ssh key handling support back into plc.d/ssh and the
87 - default xml file.  This should be identical to the way it was in
88 - rc12.
89 - - Added support in the db-config.d/01-init script to register the root
90 - ssh public key with the default administrator.  In this way the root
91 - ssh key will make it into the root account on the nodes by means of
92 - NodeManager's specialaccounts plugin.
93
94 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
95 - db-config ignores sliver tags
96 - sirius's db-config script renamed (was sirious)
97
98 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
99 - fix for silverauth - missing tag types now created at plc startup time
100
101 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
102 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
103
104 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
105 - companion to NM's specialaccounts plugin
106 - do not generate /etc/planetlab/root_ssh_key* anymore
107 - remove related config. variables and conf_files
108
109 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
110 - clarified description text to refer only to plcrt and not other optional
111 - packages.
112
113 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
114 - fixed a bug setting slice multiple attributes with the same tag name
115
116 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
117 - SSL setup for monitor box, and related new config variables
118 - new conf_file for /etc/planetlab/extensions
119 - various tweaks in db-config internals, about initscripts among others
120 - also more messages defined in the db
121
122 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
123 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
124
125 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
126 - bugfix in db-config, tag 4.3-19 would not fly
127
128 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
129 - Refactored db-config into snippets in db-config.d/.
130
131 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
132 - oops, tag 4.3-17 was broken and would not work
133
134 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
135 - bugfix - escape sequences inserted in xml configs
136
137 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
138 - Handle db-config.d files properly.
139
140 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
141 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
142 - than the log file
143 - - Fix db-config to be a bit more cautious when
144 - /etc/planetlab/db-config.d doesn't exist
145 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
146 - .orig files.
147 - - Refactor generic plc-config-tty code into plc_config.py.
148 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
149 - and the list of validated variables and the corresponding
150 - validator() function. This refactoring lets one reuse plc_config.py
151 - as a generic cmdline configuration tool for highly customer MyPLC
152 - like software.
153
154 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
155 - update PCU Type descriptions.
156 - updates to init scripts
157
158 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
159 - requires monitor-pcucontrol so register-wizard can work
160
161 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
162 - cleaned up plc-config-tty, no more need to configure plc-devel
163
164 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
165 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
166
167 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
168 - tighter right permissions on site_admin's authorized keys for more robustness
169
170 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
171 - fix issue in db-config that prevented correct operation
172
173 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
174 - remove support for chroot-based packaging - no crond nor syslog step anymore
175 - plc init script now named plc.init instead of former guest.init
176
177 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
178 - add Monitor to docs build
179
180 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
181 - plc_config.py and plc-config-tty: generalized to work for more diverse
182 - MyPLC configurations.
183 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
184 - deployments and increase the memory limits in php.ini
185 - plc.d/crond: add --full option to vacuumdb
186
187 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
188 - avoid generating ssl certificates for disabled services among www api boot
189
190 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
191 - cleaned up old entries in db-config
192 - mtail more robust
193
194 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
195 - php include path tweaked for plekit includes
196 - reviewed myplc (fka native) packaging dependencies
197 - renumbered 4.3
198
199 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
200 - rename myplc into myplc-chroot and myplc-native into myplc
201 - new settings (shortname & hrn_root) for local peer
202