Setting tag MyPLC-4.3-30
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 30
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
61 - Fix SetRole.
62
63 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
64 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
65 - into the DB.
66 - - Added the root ssh key handling support back into plc.d/ssh and the
67 - default xml file.  This should be identical to the way it was in
68 - rc12.
69 - - Added support in the db-config.d/01-init script to register the root
70 - ssh public key with the default administrator.  In this way the root
71 - ssh key will make it into the root account on the nodes by means of
72 - NodeManager's specialaccounts plugin.
73
74 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
75 - db-config ignores sliver tags
76 - sirius's db-config script renamed (was sirious)
77
78 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
79 - fix for silverauth - missing tag types now created at plc startup time
80
81 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
82 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
83
84 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
85 - companion to NM's specialaccounts plugin
86 - do not generate /etc/planetlab/root_ssh_key* anymore
87 - remove related config. variables and conf_files
88
89 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
90 - clarified description text to refer only to plcrt and not other optional
91 - packages.
92
93 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
94 - fixed a bug setting slice multiple attributes with the same tag name
95
96 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
97 - SSL setup for monitor box, and related new config variables
98 - new conf_file for /etc/planetlab/extensions
99 - various tweaks in db-config internals, about initscripts among others
100 - also more messages defined in the db
101
102 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
103 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
104
105 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
106 - bugfix in db-config, tag 4.3-19 would not fly
107
108 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
109 - Refactored db-config into snippets in db-config.d/.
110
111 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
112 - oops, tag 4.3-17 was broken and would not work
113
114 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
115 - bugfix - escape sequences inserted in xml configs
116
117 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
118 - Handle db-config.d files properly.
119
120 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
121 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
122 - than the log file
123 - - Fix db-config to be a bit more cautious when
124 - /etc/planetlab/db-config.d doesn't exist
125 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
126 - .orig files.
127 - - Refactor generic plc-config-tty code into plc_config.py.
128 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
129 - and the list of validated variables and the corresponding
130 - validator() function. This refactoring lets one reuse plc_config.py
131 - as a generic cmdline configuration tool for highly customer MyPLC
132 - like software.
133
134 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
135 - update PCU Type descriptions.
136 - updates to init scripts
137
138 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
139 - requires monitor-pcucontrol so register-wizard can work
140
141 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
142 - cleaned up plc-config-tty, no more need to configure plc-devel
143
144 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
145 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
146
147 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
148 - tighter right permissions on site_admin's authorized keys for more robustness
149
150 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
151 - fix issue in db-config that prevented correct operation
152
153 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
154 - remove support for chroot-based packaging - no crond nor syslog step anymore
155 - plc init script now named plc.init instead of former guest.init
156
157 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
158 - add Monitor to docs build
159
160 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
161 - plc_config.py and plc-config-tty: generalized to work for more diverse
162 - MyPLC configurations.
163 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
164 - deployments and increase the memory limits in php.ini
165 - plc.d/crond: add --full option to vacuumdb
166
167 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
168 - avoid generating ssl certificates for disabled services among www api boot
169
170 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
171 - cleaned up old entries in db-config
172 - mtail more robust
173
174 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
175 - php include path tweaked for plekit includes
176 - reviewed myplc (fka native) packaging dependencies
177 - renumbered 4.3
178
179 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
180 - rename myplc into myplc-chroot and myplc-native into myplc
181 - new settings (shortname & hrn_root) for local peer
182