Setting tag MyPLC-4.3-33
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 33
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
61 - * validate input according to type in plc_config
62 - * added the _genicw system slice
63 - * add tag types for sites and persons
64 - * add new tags for nodes and slices for exemption from myops
65
66 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
67 - turn off drupal on a box that acts as BOOT server but not as WWW server
68 - cleanup some obsolete code for old chroot-jail packaging in the process
69 - new bootcd-kernel script for keeping bootcd variants up2date
70
71 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
72 - Make the /etc/hosts manipulation optional.
73
74 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
75 - Fix SetRole.
76
77 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
78 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
79 - into the DB.
80 - - Added the root ssh key handling support back into plc.d/ssh and the
81 - default xml file.  This should be identical to the way it was in
82 - rc12.
83 - - Added support in the db-config.d/01-init script to register the root
84 - ssh public key with the default administrator.  In this way the root
85 - ssh key will make it into the root account on the nodes by means of
86 - NodeManager's specialaccounts plugin.
87
88 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
89 - db-config ignores sliver tags
90 - sirius's db-config script renamed (was sirious)
91
92 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
93 - fix for silverauth - missing tag types now created at plc startup time
94
95 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
96 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
97
98 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
99 - companion to NM's specialaccounts plugin
100 - do not generate /etc/planetlab/root_ssh_key* anymore
101 - remove related config. variables and conf_files
102
103 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
104 - clarified description text to refer only to plcrt and not other optional
105 - packages.
106
107 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
108 - fixed a bug setting slice multiple attributes with the same tag name
109
110 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
111 - SSL setup for monitor box, and related new config variables
112 - new conf_file for /etc/planetlab/extensions
113 - various tweaks in db-config internals, about initscripts among others
114 - also more messages defined in the db
115
116 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
117 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
118
119 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
120 - bugfix in db-config, tag 4.3-19 would not fly
121
122 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
123 - Refactored db-config into snippets in db-config.d/.
124
125 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
126 - oops, tag 4.3-17 was broken and would not work
127
128 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
129 - bugfix - escape sequences inserted in xml configs
130
131 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
132 - Handle db-config.d files properly.
133
134 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
135 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
136 - than the log file
137 - - Fix db-config to be a bit more cautious when
138 - /etc/planetlab/db-config.d doesn't exist
139 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
140 - .orig files.
141 - - Refactor generic plc-config-tty code into plc_config.py.
142 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
143 - and the list of validated variables and the corresponding
144 - validator() function. This refactoring lets one reuse plc_config.py
145 - as a generic cmdline configuration tool for highly customer MyPLC
146 - like software.
147
148 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
149 - update PCU Type descriptions.
150 - updates to init scripts
151
152 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
153 - requires monitor-pcucontrol so register-wizard can work
154
155 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
156 - cleaned up plc-config-tty, no more need to configure plc-devel
157
158 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
159 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
160
161 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
162 - tighter right permissions on site_admin's authorized keys for more robustness
163
164 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
165 - fix issue in db-config that prevented correct operation
166
167 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
168 - remove support for chroot-based packaging - no crond nor syslog step anymore
169 - plc init script now named plc.init instead of former guest.init
170
171 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
172 - add Monitor to docs build
173
174 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
175 - plc_config.py and plc-config-tty: generalized to work for more diverse
176 - MyPLC configurations.
177 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
178 - deployments and increase the memory limits in php.ini
179 - plc.d/crond: add --full option to vacuumdb
180
181 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
182 - avoid generating ssl certificates for disabled services among www api boot
183
184 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
185 - cleaned up old entries in db-config
186 - mtail more robust
187
188 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
189 - php include path tweaked for plekit includes
190 - reviewed myplc (fka native) packaging dependencies
191 - renumbered 4.3
192
193 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
194 - rename myplc into myplc-chroot and myplc-native into myplc
195 - new settings (shortname & hrn_root) for local peer
196