Setting tag MyPLC-4.3-29
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 29
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
61 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
62 - into the DB.
63 - - Added the root ssh key handling support back into plc.d/ssh and the
64 - default xml file.  This should be identical to the way it was in
65 - rc12.
66 - - Added support in the db-config.d/01-init script to register the root
67 - ssh public key with the default administrator.  In this way the root
68 - ssh key will make it into the root account on the nodes by means of
69 - NodeManager's specialaccounts plugin.
70
71 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
72 - db-config ignores sliver tags
73 - sirius's db-config script renamed (was sirious)
74
75 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
76 - fix for silverauth - missing tag types now created at plc startup time
77
78 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
79 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
80
81 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
82 - companion to NM's specialaccounts plugin
83 - do not generate /etc/planetlab/root_ssh_key* anymore
84 - remove related config. variables and conf_files
85
86 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
87 - clarified description text to refer only to plcrt and not other optional
88 - packages.
89
90 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
91 - fixed a bug setting slice multiple attributes with the same tag name
92
93 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
94 - SSL setup for monitor box, and related new config variables
95 - new conf_file for /etc/planetlab/extensions
96 - various tweaks in db-config internals, about initscripts among others
97 - also more messages defined in the db
98
99 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
100 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
101
102 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
103 - bugfix in db-config, tag 4.3-19 would not fly
104
105 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
106 - Refactored db-config into snippets in db-config.d/.
107
108 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
109 - oops, tag 4.3-17 was broken and would not work
110
111 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
112 - bugfix - escape sequences inserted in xml configs
113
114 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
115 - Handle db-config.d files properly.
116
117 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
118 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
119 - than the log file
120 - - Fix db-config to be a bit more cautious when
121 - /etc/planetlab/db-config.d doesn't exist
122 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
123 - .orig files.
124 - - Refactor generic plc-config-tty code into plc_config.py.
125 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
126 - and the list of validated variables and the corresponding
127 - validator() function. This refactoring lets one reuse plc_config.py
128 - as a generic cmdline configuration tool for highly customer MyPLC
129 - like software.
130
131 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
132 - update PCU Type descriptions.
133 - updates to init scripts
134
135 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
136 - requires monitor-pcucontrol so register-wizard can work
137
138 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
139 - cleaned up plc-config-tty, no more need to configure plc-devel
140
141 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
142 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
143
144 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
145 - tighter right permissions on site_admin's authorized keys for more robustness
146
147 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
148 - fix issue in db-config that prevented correct operation
149
150 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
151 - remove support for chroot-based packaging - no crond nor syslog step anymore
152 - plc init script now named plc.init instead of former guest.init
153
154 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
155 - add Monitor to docs build
156
157 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
158 - plc_config.py and plc-config-tty: generalized to work for more diverse
159 - MyPLC configurations.
160 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
161 - deployments and increase the memory limits in php.ini
162 - plc.d/crond: add --full option to vacuumdb
163
164 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
165 - avoid generating ssl certificates for disabled services among www api boot
166
167 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
168 - cleaned up old entries in db-config
169 - mtail more robust
170
171 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
172 - php include path tweaked for plekit includes
173 - reviewed myplc (fka native) packaging dependencies
174 - renumbered 4.3
175
176 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
177 - rename myplc into myplc-chroot and myplc-native into myplc
178 - new settings (shortname & hrn_root) for local peer
179