Setting tag MyPLC-4.3-37
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 37
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
61 - support for fedora 12
62 - new package myplc-config for use by sfa
63 - drupal user registration turned off
64
65 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
66 - - fix to make sure when API, BOOT, MONITOR are on the same
67 - machine as WWW that the SSL key,cert for WWW takes precedence.
68 - - Do proper setup for SSL CA certficate to be used as the server
69 - chain.
70
71 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
72 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
73
74 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
75 - depend on pcucontrol
76
77 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
78 - * validate input according to type in plc_config
79 - * added the _genicw system slice
80 - * add tag types for sites and persons
81 - * add new tags for nodes and slices for exemption from myops
82
83 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
84 - turn off drupal on a box that acts as BOOT server but not as WWW server
85 - cleanup some obsolete code for old chroot-jail packaging in the process
86 - new bootcd-kernel script for keeping bootcd variants up2date
87
88 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
89 - Make the /etc/hosts manipulation optional.
90
91 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
92 - Fix SetRole.
93
94 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
95 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
96 - into the DB.
97 - - Added the root ssh key handling support back into plc.d/ssh and the
98 - default xml file.  This should be identical to the way it was in
99 - rc12.
100 - - Added support in the db-config.d/01-init script to register the root
101 - ssh public key with the default administrator.  In this way the root
102 - ssh key will make it into the root account on the nodes by means of
103 - NodeManager's specialaccounts plugin.
104
105 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
106 - db-config ignores sliver tags
107 - sirius's db-config script renamed (was sirious)
108
109 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
110 - fix for silverauth - missing tag types now created at plc startup time
111
112 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
113 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
114
115 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
116 - companion to NM's specialaccounts plugin
117 - do not generate /etc/planetlab/root_ssh_key* anymore
118 - remove related config. variables and conf_files
119
120 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
121 - clarified description text to refer only to plcrt and not other optional
122 - packages.
123
124 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
125 - fixed a bug setting slice multiple attributes with the same tag name
126
127 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
128 - SSL setup for monitor box, and related new config variables
129 - new conf_file for /etc/planetlab/extensions
130 - various tweaks in db-config internals, about initscripts among others
131 - also more messages defined in the db
132
133 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
134 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
135
136 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
137 - bugfix in db-config, tag 4.3-19 would not fly
138
139 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
140 - Refactored db-config into snippets in db-config.d/.
141
142 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
143 - oops, tag 4.3-17 was broken and would not work
144
145 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
146 - bugfix - escape sequences inserted in xml configs
147
148 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
149 - Handle db-config.d files properly.
150
151 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
152 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
153 - than the log file
154 - - Fix db-config to be a bit more cautious when
155 - /etc/planetlab/db-config.d doesn't exist
156 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
157 - .orig files.
158 - - Refactor generic plc-config-tty code into plc_config.py.
159 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
160 - and the list of validated variables and the corresponding
161 - validator() function. This refactoring lets one reuse plc_config.py
162 - as a generic cmdline configuration tool for highly customer MyPLC
163 - like software.
164
165 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
166 - update PCU Type descriptions.
167 - updates to init scripts
168
169 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
170 - requires monitor-pcucontrol so register-wizard can work
171
172 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
173 - cleaned up plc-config-tty, no more need to configure plc-devel
174
175 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
176 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
177
178 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
179 - tighter right permissions on site_admin's authorized keys for more robustness
180
181 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
182 - fix issue in db-config that prevented correct operation
183
184 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
185 - remove support for chroot-based packaging - no crond nor syslog step anymore
186 - plc init script now named plc.init instead of former guest.init
187
188 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
189 - add Monitor to docs build
190
191 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
192 - plc_config.py and plc-config-tty: generalized to work for more diverse
193 - MyPLC configurations.
194 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
195 - deployments and increase the memory limits in php.ini
196 - plc.d/crond: add --full option to vacuumdb
197
198 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
199 - avoid generating ssl certificates for disabled services among www api boot
200
201 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
202 - cleaned up old entries in db-config
203 - mtail more robust
204
205 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
206 - php include path tweaked for plekit includes
207 - reviewed myplc (fka native) packaging dependencies
208 - renumbered 4.3
209
210 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
211 - rename myplc into myplc-chroot and myplc-native into myplc
212 - new settings (shortname & hrn_root) for local peer
213