Setting tag myplc-5.0-18
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 18
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
56 - new settings for myslice (comon&tophat) and monitor (db)
57 - removed mentions of chroot in description
58 - can redo myplc-docs on broken f12-latex
59 - set short_open_tag in php.ini
60 - fixes in gen-sites-xml (is that still used ?)
61 - partial-repo.sh has moved to 'build' where it more belongs
62 - tweaks in convenience tool 'mtail'
63
64 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
65 - fixed changelog, no change from 5.0-16
66
67 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
68 - requires ed for the plc.d/packages step
69 - sirius initscript to handle stop and restart
70
71 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
72 - ignore steps in db-config.d if they have a '.' or '~' in their name
73
74 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
75 - can redo myplc-docs without the doc for monitor
76
77 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
78 - no semantic change - just fixed specfile for git URL
79
80 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
81 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
82
83 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
84 - add missing files to rpm package
85
86 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
87 - mtail.py -s for SFA
88 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
89
90 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
91 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
92
93 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
94 - plc-config-tty now has a validator on booleans
95 - e.g. entering 'True' now is rejected rather than silently recording 'false'
96
97 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
98 - disable mod_wsgi
99
100 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
101 - module name changes
102 - start wsgi support
103
104 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
105 - new setting PLC_RESERVATION_GRANULARITY
106
107 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
108 - * partial-repo.sh script
109 - * preserve key along with certificates
110
111 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
112 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
113
114 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
115 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
116 - new OMF category in the config
117 - create the drl system slice
118
119 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
120 - first working version of 5.0:
121 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
122 - nodefamily is 3-fold with pldistro-fcdistro-arch
123 - new PLC_FLAVOUR config category
124 - reviewed module layout
125 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
126
127 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
128 - support for fedora 12
129 - new package myplc-config for use by sfa
130 - drupal user registration turned off
131
132 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
133 - - fix to make sure when API, BOOT, MONITOR are on the same
134 - machine as WWW that the SSL key,cert for WWW takes precedence.
135 - - Do proper setup for SSL CA certficate to be used as the server
136 - chain.
137
138 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
139 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
140
141 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
142 - depend on pcucontrol
143
144 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
145 - * validate input according to type in plc_config
146 - * added the _genicw system slice
147 - * add tag types for sites and persons
148 - * add new tags for nodes and slices for exemption from myops
149
150 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
151 - turn off drupal on a box that acts as BOOT server but not as WWW server
152 - cleanup some obsolete code for old chroot-jail packaging in the process
153 - new bootcd-kernel script for keeping bootcd variants up2date
154
155 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
156 - Make the /etc/hosts manipulation optional.
157
158 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
159 - Fix SetRole.
160
161 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
162 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
163 - into the DB.
164 - - Added the root ssh key handling support back into plc.d/ssh and the
165 - default xml file.  This should be identical to the way it was in
166 - rc12.
167 - - Added support in the db-config.d/01-init script to register the root
168 - ssh public key with the default administrator.  In this way the root
169 - ssh key will make it into the root account on the nodes by means of
170 - NodeManager's specialaccounts plugin.
171
172 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
173 - db-config ignores sliver tags
174 - sirius's db-config script renamed (was sirious)
175
176 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
177 - fix for silverauth - missing tag types now created at plc startup time
178
179 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
180 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
181
182 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
183 - companion to NM's specialaccounts plugin
184 - do not generate /etc/planetlab/root_ssh_key* anymore
185 - remove related config. variables and conf_files
186
187 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
188 - clarified description text to refer only to plcrt and not other optional
189 - packages.
190
191 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
192 - fixed a bug setting slice multiple attributes with the same tag name
193
194 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
195 - SSL setup for monitor box, and related new config variables
196 - new conf_file for /etc/planetlab/extensions
197 - various tweaks in db-config internals, about initscripts among others
198 - also more messages defined in the db
199
200 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
201 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
202
203 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
204 - bugfix in db-config, tag 4.3-19 would not fly
205
206 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
207 - Refactored db-config into snippets in db-config.d/.
208
209 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
210 - oops, tag 4.3-17 was broken and would not work
211
212 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
213 - bugfix - escape sequences inserted in xml configs
214
215 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
216 - Handle db-config.d files properly.
217
218 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
219 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
220 - than the log file
221 - - Fix db-config to be a bit more cautious when
222 - /etc/planetlab/db-config.d doesn't exist
223 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
224 - .orig files.
225 - - Refactor generic plc-config-tty code into plc_config.py.
226 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
227 - and the list of validated variables and the corresponding
228 - validator() function. This refactoring lets one reuse plc_config.py
229 - as a generic cmdline configuration tool for highly customer MyPLC
230 - like software.
231
232 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
233 - update PCU Type descriptions.
234 - updates to init scripts
235
236 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
237 - requires monitor-pcucontrol so register-wizard can work
238
239 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
240 - cleaned up plc-config-tty, no more need to configure plc-devel
241
242 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
243 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
244
245 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
246 - tighter right permissions on site_admin's authorized keys for more robustness
247
248 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
249 - fix issue in db-config that prevented correct operation
250
251 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
252 - remove support for chroot-based packaging - no crond nor syslog step anymore
253 - plc init script now named plc.init instead of former guest.init
254
255 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
256 - add Monitor to docs build
257
258 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
259 - plc_config.py and plc-config-tty: generalized to work for more diverse
260 - MyPLC configurations.
261 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
262 - deployments and increase the memory limits in php.ini
263 - plc.d/crond: add --full option to vacuumdb
264
265 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
266 - avoid generating ssl certificates for disabled services among www api boot
267
268 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
269 - cleaned up old entries in db-config
270 - mtail more robust
271
272 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
273 - php include path tweaked for plekit includes
274 - reviewed myplc (fka native) packaging dependencies
275 - renumbered 4.3
276
277 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
278 - rename myplc into myplc-chroot and myplc-native into myplc
279 - new settings (shortname & hrn_root) for local peer
280
281
282 %define module_current_branch 4.3