Setting tag MyPLC-4.3-31
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 31
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
61 - Make the /etc/hosts manipulation optional.
62
63 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
64 - Fix SetRole.
65
66 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
67 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
68 - into the DB.
69 - - Added the root ssh key handling support back into plc.d/ssh and the
70 - default xml file.  This should be identical to the way it was in
71 - rc12.
72 - - Added support in the db-config.d/01-init script to register the root
73 - ssh public key with the default administrator.  In this way the root
74 - ssh key will make it into the root account on the nodes by means of
75 - NodeManager's specialaccounts plugin.
76
77 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
78 - db-config ignores sliver tags
79 - sirius's db-config script renamed (was sirious)
80
81 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
82 - fix for silverauth - missing tag types now created at plc startup time
83
84 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
85 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
86
87 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
88 - companion to NM's specialaccounts plugin
89 - do not generate /etc/planetlab/root_ssh_key* anymore
90 - remove related config. variables and conf_files
91
92 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
93 - clarified description text to refer only to plcrt and not other optional
94 - packages.
95
96 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
97 - fixed a bug setting slice multiple attributes with the same tag name
98
99 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
100 - SSL setup for monitor box, and related new config variables
101 - new conf_file for /etc/planetlab/extensions
102 - various tweaks in db-config internals, about initscripts among others
103 - also more messages defined in the db
104
105 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
106 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
107
108 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
109 - bugfix in db-config, tag 4.3-19 would not fly
110
111 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
112 - Refactored db-config into snippets in db-config.d/.
113
114 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
115 - oops, tag 4.3-17 was broken and would not work
116
117 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
118 - bugfix - escape sequences inserted in xml configs
119
120 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
121 - Handle db-config.d files properly.
122
123 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
124 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
125 - than the log file
126 - - Fix db-config to be a bit more cautious when
127 - /etc/planetlab/db-config.d doesn't exist
128 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
129 - .orig files.
130 - - Refactor generic plc-config-tty code into plc_config.py.
131 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
132 - and the list of validated variables and the corresponding
133 - validator() function. This refactoring lets one reuse plc_config.py
134 - as a generic cmdline configuration tool for highly customer MyPLC
135 - like software.
136
137 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
138 - update PCU Type descriptions.
139 - updates to init scripts
140
141 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
142 - requires monitor-pcucontrol so register-wizard can work
143
144 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
145 - cleaned up plc-config-tty, no more need to configure plc-devel
146
147 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
148 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
149
150 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
151 - tighter right permissions on site_admin's authorized keys for more robustness
152
153 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
154 - fix issue in db-config that prevented correct operation
155
156 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
157 - remove support for chroot-based packaging - no crond nor syslog step anymore
158 - plc init script now named plc.init instead of former guest.init
159
160 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
161 - add Monitor to docs build
162
163 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
164 - plc_config.py and plc-config-tty: generalized to work for more diverse
165 - MyPLC configurations.
166 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
167 - deployments and increase the memory limits in php.ini
168 - plc.d/crond: add --full option to vacuumdb
169
170 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
171 - avoid generating ssl certificates for disabled services among www api boot
172
173 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
174 - cleaned up old entries in db-config
175 - mtail more robust
176
177 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
178 - php include path tweaked for plekit includes
179 - reviewed myplc (fka native) packaging dependencies
180 - renumbered 4.3
181
182 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
183 - rename myplc into myplc-chroot and myplc-native into myplc
184 - new settings (shortname & hrn_root) for local peer
185