Setting tag MyPLC-4.3-23
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 23
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
61 - fixed a bug setting slice multiple attributes with the same tag name
62
63 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
64 - SSL setup for monitor box, and related new config variables
65 - new conf_file for /etc/planetlab/extensions
66 - various tweaks in db-config internals, about initscripts among others
67 - also more messages defined in the db
68
69 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
70 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
71
72 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
73 - bugfix in db-config, tag 4.3-19 would not fly
74
75 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
76 - Refactored db-config into snippets in db-config.d/.
77
78 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
79 - oops, tag 4.3-17 was broken and would not work
80
81 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
82 - bugfix - escape sequences inserted in xml configs
83
84 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
85 - Handle db-config.d files properly.
86
87 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
88 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
89 - than the log file
90 - - Fix db-config to be a bit more cautious when
91 - /etc/planetlab/db-config.d doesn't exist
92 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
93 - .orig files.
94 - - Refactor generic plc-config-tty code into plc_config.py.
95 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
96 - and the list of validated variables and the corresponding
97 - validator() function. This refactoring lets one reuse plc_config.py
98 - as a generic cmdline configuration tool for highly customer MyPLC
99 - like software.
100
101 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
102 - update PCU Type descriptions.
103 - updates to init scripts
104
105 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
106 - requires monitor-pcucontrol so register-wizard can work
107
108 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
109 - cleaned up plc-config-tty, no more need to configure plc-devel
110
111 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
112 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
113
114 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
115 - tighter right permissions on site_admin's authorized keys for more robustness
116
117 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
118 - fix issue in db-config that prevented correct operation
119
120 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
121 - remove support for chroot-based packaging - no crond nor syslog step anymore
122 - plc init script now named plc.init instead of former guest.init
123
124 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
125 - add Monitor to docs build
126
127 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
128 - plc_config.py and plc-config-tty: generalized to work for more diverse
129 - MyPLC configurations.
130 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
131 - deployments and increase the memory limits in php.ini
132 - plc.d/crond: add --full option to vacuumdb
133
134 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
135 - avoid generating ssl certificates for disabled services among www api boot
136
137 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
138 - cleaned up old entries in db-config
139 - mtail more robust
140
141 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
142 - php include path tweaked for plekit includes
143 - reviewed myplc (fka native) packaging dependencies
144 - renumbered 4.3
145
146 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
147 - rename myplc into myplc-chroot and myplc-native into myplc
148 - new settings (shortname & hrn_root) for local peer
149