Tagging module MyPLC - MyPLC-4.3-8
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 8
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
61 - remove support for chroot-based packaging - no crond nor syslog step anymore
62 - plc init script now named plc.init instead of former guest.init
63
64 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
65 - add Monitor to docs build
66
67 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
68 - plc_config.py and plc-config-tty: generalized to work for more diverse
69 - MyPLC configurations.
70 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
71 - deployments and increase the memory limits in php.ini
72 - plc.d/crond: add --full option to vacuumdb
73
74 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
75 - avoid generating ssl certificates for disabled services among www api boot
76
77 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
78 - cleaned up old entries in db-config
79 - mtail more robust
80
81 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
82 - php include path tweaked for plekit includes
83 - reviewed myplc (fka native) packaging dependencies
84 - renumbered 4.3
85
86 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
87 - rename myplc into myplc-chroot and myplc-native into myplc
88 - new settings (shortname & hrn_root) for local peer
89