Setting tag MyPLC-4.3-27
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 27
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
61 - fix for silverauth - missing tag types now created at plc startup time
62
63 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
64 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
65
66 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
67 - companion to NM's specialaccounts plugin
68 - do not generate /etc/planetlab/root_ssh_key* anymore
69 - remove related config. variables and conf_files
70
71 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
72 - clarified description text to refer only to plcrt and not other optional
73 - packages.
74
75 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
76 - fixed a bug setting slice multiple attributes with the same tag name
77
78 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
79 - SSL setup for monitor box, and related new config variables
80 - new conf_file for /etc/planetlab/extensions
81 - various tweaks in db-config internals, about initscripts among others
82 - also more messages defined in the db
83
84 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
85 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
86
87 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
88 - bugfix in db-config, tag 4.3-19 would not fly
89
90 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
91 - Refactored db-config into snippets in db-config.d/.
92
93 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
94 - oops, tag 4.3-17 was broken and would not work
95
96 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
97 - bugfix - escape sequences inserted in xml configs
98
99 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
100 - Handle db-config.d files properly.
101
102 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
103 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
104 - than the log file
105 - - Fix db-config to be a bit more cautious when
106 - /etc/planetlab/db-config.d doesn't exist
107 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
108 - .orig files.
109 - - Refactor generic plc-config-tty code into plc_config.py.
110 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
111 - and the list of validated variables and the corresponding
112 - validator() function. This refactoring lets one reuse plc_config.py
113 - as a generic cmdline configuration tool for highly customer MyPLC
114 - like software.
115
116 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
117 - update PCU Type descriptions.
118 - updates to init scripts
119
120 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
121 - requires monitor-pcucontrol so register-wizard can work
122
123 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
124 - cleaned up plc-config-tty, no more need to configure plc-devel
125
126 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
127 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
128
129 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
130 - tighter right permissions on site_admin's authorized keys for more robustness
131
132 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
133 - fix issue in db-config that prevented correct operation
134
135 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
136 - remove support for chroot-based packaging - no crond nor syslog step anymore
137 - plc init script now named plc.init instead of former guest.init
138
139 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
140 - add Monitor to docs build
141
142 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
143 - plc_config.py and plc-config-tty: generalized to work for more diverse
144 - MyPLC configurations.
145 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
146 - deployments and increase the memory limits in php.ini
147 - plc.d/crond: add --full option to vacuumdb
148
149 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
150 - avoid generating ssl certificates for disabled services among www api boot
151
152 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
153 - cleaned up old entries in db-config
154 - mtail more robust
155
156 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
157 - php include path tweaked for plekit includes
158 - reviewed myplc (fka native) packaging dependencies
159 - renumbered 4.3
160
161 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
162 - rename myplc into myplc-chroot and myplc-native into myplc
163 - new settings (shortname & hrn_root) for local peer
164