Setting tag myplc-5.0-10
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 10
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
61 - mtail.py -s for SFA
62 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
63
64 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
65 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
66
67 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
68 - plc-config-tty now has a validator on booleans
69 - e.g. entering 'True' now is rejected rather than silently recording 'false'
70
71 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
72 - disable mod_wsgi
73
74 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
75 - module name changes
76 - start wsgi support
77
78 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
79 - new setting PLC_RESERVATION_GRANULARITY
80
81 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
82 - * partial-repo.sh script
83 - * preserve key along with certificates
84
85 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
86 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
87
88 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
89 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
90 - new OMF category in the config
91 - create the drl system slice
92
93 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
94 - first working version of 5.0:
95 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
96 - nodefamily is 3-fold with pldistro-fcdistro-arch
97 - new PLC_FLAVOUR config category
98 - reviewed module layout
99 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
100
101 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
102 - support for fedora 12
103 - new package myplc-config for use by sfa
104 - drupal user registration turned off
105
106 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
107 - - fix to make sure when API, BOOT, MONITOR are on the same
108 - machine as WWW that the SSL key,cert for WWW takes precedence.
109 - - Do proper setup for SSL CA certficate to be used as the server
110 - chain.
111
112 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
113 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
114
115 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
116 - depend on pcucontrol
117
118 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
119 - * validate input according to type in plc_config
120 - * added the _genicw system slice
121 - * add tag types for sites and persons
122 - * add new tags for nodes and slices for exemption from myops
123
124 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
125 - turn off drupal on a box that acts as BOOT server but not as WWW server
126 - cleanup some obsolete code for old chroot-jail packaging in the process
127 - new bootcd-kernel script for keeping bootcd variants up2date
128
129 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
130 - Make the /etc/hosts manipulation optional.
131
132 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
133 - Fix SetRole.
134
135 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
136 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
137 - into the DB.
138 - - Added the root ssh key handling support back into plc.d/ssh and the
139 - default xml file.  This should be identical to the way it was in
140 - rc12.
141 - - Added support in the db-config.d/01-init script to register the root
142 - ssh public key with the default administrator.  In this way the root
143 - ssh key will make it into the root account on the nodes by means of
144 - NodeManager's specialaccounts plugin.
145
146 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
147 - db-config ignores sliver tags
148 - sirius's db-config script renamed (was sirious)
149
150 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
151 - fix for silverauth - missing tag types now created at plc startup time
152
153 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
154 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
155
156 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
157 - companion to NM's specialaccounts plugin
158 - do not generate /etc/planetlab/root_ssh_key* anymore
159 - remove related config. variables and conf_files
160
161 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
162 - clarified description text to refer only to plcrt and not other optional
163 - packages.
164
165 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
166 - fixed a bug setting slice multiple attributes with the same tag name
167
168 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
169 - SSL setup for monitor box, and related new config variables
170 - new conf_file for /etc/planetlab/extensions
171 - various tweaks in db-config internals, about initscripts among others
172 - also more messages defined in the db
173
174 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
175 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
176
177 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
178 - bugfix in db-config, tag 4.3-19 would not fly
179
180 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
181 - Refactored db-config into snippets in db-config.d/.
182
183 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
184 - oops, tag 4.3-17 was broken and would not work
185
186 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
187 - bugfix - escape sequences inserted in xml configs
188
189 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
190 - Handle db-config.d files properly.
191
192 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
193 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
194 - than the log file
195 - - Fix db-config to be a bit more cautious when
196 - /etc/planetlab/db-config.d doesn't exist
197 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
198 - .orig files.
199 - - Refactor generic plc-config-tty code into plc_config.py.
200 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
201 - and the list of validated variables and the corresponding
202 - validator() function. This refactoring lets one reuse plc_config.py
203 - as a generic cmdline configuration tool for highly customer MyPLC
204 - like software.
205
206 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
207 - update PCU Type descriptions.
208 - updates to init scripts
209
210 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
211 - requires monitor-pcucontrol so register-wizard can work
212
213 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
214 - cleaned up plc-config-tty, no more need to configure plc-devel
215
216 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
217 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
218
219 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
220 - tighter right permissions on site_admin's authorized keys for more robustness
221
222 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
223 - fix issue in db-config that prevented correct operation
224
225 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
226 - remove support for chroot-based packaging - no crond nor syslog step anymore
227 - plc init script now named plc.init instead of former guest.init
228
229 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
230 - add Monitor to docs build
231
232 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
233 - plc_config.py and plc-config-tty: generalized to work for more diverse
234 - MyPLC configurations.
235 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
236 - deployments and increase the memory limits in php.ini
237 - plc.d/crond: add --full option to vacuumdb
238
239 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
240 - avoid generating ssl certificates for disabled services among www api boot
241
242 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
243 - cleaned up old entries in db-config
244 - mtail more robust
245
246 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
247 - php include path tweaked for plekit includes
248 - reviewed myplc (fka native) packaging dependencies
249 - renumbered 4.3
250
251 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
252 - rename myplc into myplc-chroot and myplc-native into myplc
253 - new settings (shortname & hrn_root) for local peer
254
255
256 %define module_current_branch 4.3