Setting tag MyPLC-4.3-36
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 36
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
61 - - fix to make sure when API, BOOT, MONITOR are on the same
62 - machine as WWW that the SSL key,cert for WWW takes precedence.
63 - - Do proper setup for SSL CA certficate to be used as the server
64 - chain.
65
66 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
67 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
68
69 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
70 - depend on pcucontrol
71
72 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
73 - * validate input according to type in plc_config
74 - * added the _genicw system slice
75 - * add tag types for sites and persons
76 - * add new tags for nodes and slices for exemption from myops
77
78 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
79 - turn off drupal on a box that acts as BOOT server but not as WWW server
80 - cleanup some obsolete code for old chroot-jail packaging in the process
81 - new bootcd-kernel script for keeping bootcd variants up2date
82
83 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
84 - Make the /etc/hosts manipulation optional.
85
86 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
87 - Fix SetRole.
88
89 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
90 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
91 - into the DB.
92 - - Added the root ssh key handling support back into plc.d/ssh and the
93 - default xml file.  This should be identical to the way it was in
94 - rc12.
95 - - Added support in the db-config.d/01-init script to register the root
96 - ssh public key with the default administrator.  In this way the root
97 - ssh key will make it into the root account on the nodes by means of
98 - NodeManager's specialaccounts plugin.
99
100 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
101 - db-config ignores sliver tags
102 - sirius's db-config script renamed (was sirious)
103
104 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
105 - fix for silverauth - missing tag types now created at plc startup time
106
107 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
108 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
109
110 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
111 - companion to NM's specialaccounts plugin
112 - do not generate /etc/planetlab/root_ssh_key* anymore
113 - remove related config. variables and conf_files
114
115 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
116 - clarified description text to refer only to plcrt and not other optional
117 - packages.
118
119 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
120 - fixed a bug setting slice multiple attributes with the same tag name
121
122 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
123 - SSL setup for monitor box, and related new config variables
124 - new conf_file for /etc/planetlab/extensions
125 - various tweaks in db-config internals, about initscripts among others
126 - also more messages defined in the db
127
128 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
129 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
130
131 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
132 - bugfix in db-config, tag 4.3-19 would not fly
133
134 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
135 - Refactored db-config into snippets in db-config.d/.
136
137 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
138 - oops, tag 4.3-17 was broken and would not work
139
140 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
141 - bugfix - escape sequences inserted in xml configs
142
143 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
144 - Handle db-config.d files properly.
145
146 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
147 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
148 - than the log file
149 - - Fix db-config to be a bit more cautious when
150 - /etc/planetlab/db-config.d doesn't exist
151 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
152 - .orig files.
153 - - Refactor generic plc-config-tty code into plc_config.py.
154 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
155 - and the list of validated variables and the corresponding
156 - validator() function. This refactoring lets one reuse plc_config.py
157 - as a generic cmdline configuration tool for highly customer MyPLC
158 - like software.
159
160 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
161 - update PCU Type descriptions.
162 - updates to init scripts
163
164 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
165 - requires monitor-pcucontrol so register-wizard can work
166
167 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
168 - cleaned up plc-config-tty, no more need to configure plc-devel
169
170 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
171 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
172
173 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
174 - tighter right permissions on site_admin's authorized keys for more robustness
175
176 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
177 - fix issue in db-config that prevented correct operation
178
179 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
180 - remove support for chroot-based packaging - no crond nor syslog step anymore
181 - plc init script now named plc.init instead of former guest.init
182
183 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
184 - add Monitor to docs build
185
186 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
187 - plc_config.py and plc-config-tty: generalized to work for more diverse
188 - MyPLC configurations.
189 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
190 - deployments and increase the memory limits in php.ini
191 - plc.d/crond: add --full option to vacuumdb
192
193 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
194 - avoid generating ssl certificates for disabled services among www api boot
195
196 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
197 - cleaned up old entries in db-config
198 - mtail more robust
199
200 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
201 - php include path tweaked for plekit includes
202 - reviewed myplc (fka native) packaging dependencies
203 - renumbered 4.3
204
205 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
206 - rename myplc into myplc-chroot and myplc-native into myplc
207 - new settings (shortname & hrn_root) for local peer
208