Setting tag MyPLC-5.0-6
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 6
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
61 - module name changes
62 - start wsgi support
63
64 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
65 - new setting PLC_RESERVATION_GRANULARITY
66
67 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
68 - * partial-repo.sh script
69 - * preserve key along with certificates
70
71 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
72 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
73
74 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
75 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
76 - new OMF category in the config
77 - create the drl system slice
78
79 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
80 - first working version of 5.0:
81 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
82 - nodefamily is 3-fold with pldistro-fcdistro-arch
83 - new PLC_FLAVOUR config category
84 - reviewed module layout
85 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
86
87 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
88 - support for fedora 12
89 - new package myplc-config for use by sfa
90 - drupal user registration turned off
91
92 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
93 - - fix to make sure when API, BOOT, MONITOR are on the same
94 - machine as WWW that the SSL key,cert for WWW takes precedence.
95 - - Do proper setup for SSL CA certficate to be used as the server
96 - chain.
97
98 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
99 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
100
101 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
102 - depend on pcucontrol
103
104 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
105 - * validate input according to type in plc_config
106 - * added the _genicw system slice
107 - * add tag types for sites and persons
108 - * add new tags for nodes and slices for exemption from myops
109
110 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
111 - turn off drupal on a box that acts as BOOT server but not as WWW server
112 - cleanup some obsolete code for old chroot-jail packaging in the process
113 - new bootcd-kernel script for keeping bootcd variants up2date
114
115 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
116 - Make the /etc/hosts manipulation optional.
117
118 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
119 - Fix SetRole.
120
121 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
122 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
123 - into the DB.
124 - - Added the root ssh key handling support back into plc.d/ssh and the
125 - default xml file.  This should be identical to the way it was in
126 - rc12.
127 - - Added support in the db-config.d/01-init script to register the root
128 - ssh public key with the default administrator.  In this way the root
129 - ssh key will make it into the root account on the nodes by means of
130 - NodeManager's specialaccounts plugin.
131
132 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
133 - db-config ignores sliver tags
134 - sirius's db-config script renamed (was sirious)
135
136 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
137 - fix for silverauth - missing tag types now created at plc startup time
138
139 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
140 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
141
142 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
143 - companion to NM's specialaccounts plugin
144 - do not generate /etc/planetlab/root_ssh_key* anymore
145 - remove related config. variables and conf_files
146
147 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
148 - clarified description text to refer only to plcrt and not other optional
149 - packages.
150
151 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
152 - fixed a bug setting slice multiple attributes with the same tag name
153
154 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
155 - SSL setup for monitor box, and related new config variables
156 - new conf_file for /etc/planetlab/extensions
157 - various tweaks in db-config internals, about initscripts among others
158 - also more messages defined in the db
159
160 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
161 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
162
163 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
164 - bugfix in db-config, tag 4.3-19 would not fly
165
166 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
167 - Refactored db-config into snippets in db-config.d/.
168
169 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
170 - oops, tag 4.3-17 was broken and would not work
171
172 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
173 - bugfix - escape sequences inserted in xml configs
174
175 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
176 - Handle db-config.d files properly.
177
178 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
179 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
180 - than the log file
181 - - Fix db-config to be a bit more cautious when
182 - /etc/planetlab/db-config.d doesn't exist
183 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
184 - .orig files.
185 - - Refactor generic plc-config-tty code into plc_config.py.
186 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
187 - and the list of validated variables and the corresponding
188 - validator() function. This refactoring lets one reuse plc_config.py
189 - as a generic cmdline configuration tool for highly customer MyPLC
190 - like software.
191
192 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
193 - update PCU Type descriptions.
194 - updates to init scripts
195
196 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
197 - requires monitor-pcucontrol so register-wizard can work
198
199 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
200 - cleaned up plc-config-tty, no more need to configure plc-devel
201
202 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
203 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
204
205 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
206 - tighter right permissions on site_admin's authorized keys for more robustness
207
208 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
209 - fix issue in db-config that prevented correct operation
210
211 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
212 - remove support for chroot-based packaging - no crond nor syslog step anymore
213 - plc init script now named plc.init instead of former guest.init
214
215 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
216 - add Monitor to docs build
217
218 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
219 - plc_config.py and plc-config-tty: generalized to work for more diverse
220 - MyPLC configurations.
221 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
222 - deployments and increase the memory limits in php.ini
223 - plc.d/crond: add --full option to vacuumdb
224
225 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
226 - avoid generating ssl certificates for disabled services among www api boot
227
228 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
229 - cleaned up old entries in db-config
230 - mtail more robust
231
232 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
233 - php include path tweaked for plekit includes
234 - reviewed myplc (fka native) packaging dependencies
235 - renumbered 4.3
236
237 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
238 - rename myplc into myplc-chroot and myplc-native into myplc
239 - new settings (shortname & hrn_root) for local peer
240
241
242 %define module_current_branch 4.3