Setting tag myplc-5.0-8
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 8
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
61 - plc-config-tty now has a validator on booleans
62 - e.g. entering 'True' now is rejected rather than silently recording 'false'
63
64 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
65 - disable mod_wsgi
66
67 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
68 - module name changes
69 - start wsgi support
70
71 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
72 - new setting PLC_RESERVATION_GRANULARITY
73
74 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
75 - * partial-repo.sh script
76 - * preserve key along with certificates
77
78 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
79 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
80
81 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
82 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
83 - new OMF category in the config
84 - create the drl system slice
85
86 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
87 - first working version of 5.0:
88 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
89 - nodefamily is 3-fold with pldistro-fcdistro-arch
90 - new PLC_FLAVOUR config category
91 - reviewed module layout
92 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
93
94 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
95 - support for fedora 12
96 - new package myplc-config for use by sfa
97 - drupal user registration turned off
98
99 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
100 - - fix to make sure when API, BOOT, MONITOR are on the same
101 - machine as WWW that the SSL key,cert for WWW takes precedence.
102 - - Do proper setup for SSL CA certficate to be used as the server
103 - chain.
104
105 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
106 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
107
108 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
109 - depend on pcucontrol
110
111 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
112 - * validate input according to type in plc_config
113 - * added the _genicw system slice
114 - * add tag types for sites and persons
115 - * add new tags for nodes and slices for exemption from myops
116
117 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
118 - turn off drupal on a box that acts as BOOT server but not as WWW server
119 - cleanup some obsolete code for old chroot-jail packaging in the process
120 - new bootcd-kernel script for keeping bootcd variants up2date
121
122 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
123 - Make the /etc/hosts manipulation optional.
124
125 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
126 - Fix SetRole.
127
128 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
129 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
130 - into the DB.
131 - - Added the root ssh key handling support back into plc.d/ssh and the
132 - default xml file.  This should be identical to the way it was in
133 - rc12.
134 - - Added support in the db-config.d/01-init script to register the root
135 - ssh public key with the default administrator.  In this way the root
136 - ssh key will make it into the root account on the nodes by means of
137 - NodeManager's specialaccounts plugin.
138
139 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
140 - db-config ignores sliver tags
141 - sirius's db-config script renamed (was sirious)
142
143 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
144 - fix for silverauth - missing tag types now created at plc startup time
145
146 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
147 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
148
149 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
150 - companion to NM's specialaccounts plugin
151 - do not generate /etc/planetlab/root_ssh_key* anymore
152 - remove related config. variables and conf_files
153
154 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
155 - clarified description text to refer only to plcrt and not other optional
156 - packages.
157
158 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
159 - fixed a bug setting slice multiple attributes with the same tag name
160
161 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
162 - SSL setup for monitor box, and related new config variables
163 - new conf_file for /etc/planetlab/extensions
164 - various tweaks in db-config internals, about initscripts among others
165 - also more messages defined in the db
166
167 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
168 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
169
170 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
171 - bugfix in db-config, tag 4.3-19 would not fly
172
173 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
174 - Refactored db-config into snippets in db-config.d/.
175
176 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
177 - oops, tag 4.3-17 was broken and would not work
178
179 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
180 - bugfix - escape sequences inserted in xml configs
181
182 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
183 - Handle db-config.d files properly.
184
185 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
186 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
187 - than the log file
188 - - Fix db-config to be a bit more cautious when
189 - /etc/planetlab/db-config.d doesn't exist
190 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
191 - .orig files.
192 - - Refactor generic plc-config-tty code into plc_config.py.
193 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
194 - and the list of validated variables and the corresponding
195 - validator() function. This refactoring lets one reuse plc_config.py
196 - as a generic cmdline configuration tool for highly customer MyPLC
197 - like software.
198
199 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
200 - update PCU Type descriptions.
201 - updates to init scripts
202
203 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
204 - requires monitor-pcucontrol so register-wizard can work
205
206 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
207 - cleaned up plc-config-tty, no more need to configure plc-devel
208
209 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
210 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
211
212 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
213 - tighter right permissions on site_admin's authorized keys for more robustness
214
215 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
216 - fix issue in db-config that prevented correct operation
217
218 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
219 - remove support for chroot-based packaging - no crond nor syslog step anymore
220 - plc init script now named plc.init instead of former guest.init
221
222 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
223 - add Monitor to docs build
224
225 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
226 - plc_config.py and plc-config-tty: generalized to work for more diverse
227 - MyPLC configurations.
228 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
229 - deployments and increase the memory limits in php.ini
230 - plc.d/crond: add --full option to vacuumdb
231
232 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
233 - avoid generating ssl certificates for disabled services among www api boot
234
235 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
236 - cleaned up old entries in db-config
237 - mtail more robust
238
239 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
240 - php include path tweaked for plekit includes
241 - reviewed myplc (fka native) packaging dependencies
242 - renumbered 4.3
243
244 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
245 - rename myplc into myplc-chroot and myplc-native into myplc
246 - new settings (shortname & hrn_root) for local peer
247
248
249 %define module_current_branch 4.3