Merge commit 'origin/master'
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 16
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
56 - requires ed for the plc.d/packages step
57 - new initscript_body slice tag
58 - sirius initscript to handle stop and restart
59
60 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
61 - ignore steps in db-config.d if they have a '.' or '~' in their name
62
63 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
64 - can redo myplc-docs without the doc for monitor
65
66 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
67 - no semantic change - just fixed specfile for git URL
68
69 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
70 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
71
72 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
73 - add missing files to rpm package
74
75 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
76 - mtail.py -s for SFA
77 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
78
79 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
80 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
81
82 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
83 - plc-config-tty now has a validator on booleans
84 - e.g. entering 'True' now is rejected rather than silently recording 'false'
85
86 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
87 - disable mod_wsgi
88
89 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
90 - module name changes
91 - start wsgi support
92
93 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
94 - new setting PLC_RESERVATION_GRANULARITY
95
96 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
97 - * partial-repo.sh script
98 - * preserve key along with certificates
99
100 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
101 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
102
103 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
104 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
105 - new OMF category in the config
106 - create the drl system slice
107
108 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
109 - first working version of 5.0:
110 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
111 - nodefamily is 3-fold with pldistro-fcdistro-arch
112 - new PLC_FLAVOUR config category
113 - reviewed module layout
114 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
115
116 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
117 - support for fedora 12
118 - new package myplc-config for use by sfa
119 - drupal user registration turned off
120
121 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
122 - - fix to make sure when API, BOOT, MONITOR are on the same
123 - machine as WWW that the SSL key,cert for WWW takes precedence.
124 - - Do proper setup for SSL CA certficate to be used as the server
125 - chain.
126
127 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
128 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
129
130 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
131 - depend on pcucontrol
132
133 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
134 - * validate input according to type in plc_config
135 - * added the _genicw system slice
136 - * add tag types for sites and persons
137 - * add new tags for nodes and slices for exemption from myops
138
139 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
140 - turn off drupal on a box that acts as BOOT server but not as WWW server
141 - cleanup some obsolete code for old chroot-jail packaging in the process
142 - new bootcd-kernel script for keeping bootcd variants up2date
143
144 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
145 - Make the /etc/hosts manipulation optional.
146
147 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
148 - Fix SetRole.
149
150 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
151 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
152 - into the DB.
153 - - Added the root ssh key handling support back into plc.d/ssh and the
154 - default xml file.  This should be identical to the way it was in
155 - rc12.
156 - - Added support in the db-config.d/01-init script to register the root
157 - ssh public key with the default administrator.  In this way the root
158 - ssh key will make it into the root account on the nodes by means of
159 - NodeManager's specialaccounts plugin.
160
161 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
162 - db-config ignores sliver tags
163 - sirius's db-config script renamed (was sirious)
164
165 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
166 - fix for silverauth - missing tag types now created at plc startup time
167
168 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
169 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
170
171 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
172 - companion to NM's specialaccounts plugin
173 - do not generate /etc/planetlab/root_ssh_key* anymore
174 - remove related config. variables and conf_files
175
176 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
177 - clarified description text to refer only to plcrt and not other optional
178 - packages.
179
180 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
181 - fixed a bug setting slice multiple attributes with the same tag name
182
183 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
184 - SSL setup for monitor box, and related new config variables
185 - new conf_file for /etc/planetlab/extensions
186 - various tweaks in db-config internals, about initscripts among others
187 - also more messages defined in the db
188
189 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
190 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
191
192 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
193 - bugfix in db-config, tag 4.3-19 would not fly
194
195 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
196 - Refactored db-config into snippets in db-config.d/.
197
198 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
199 - oops, tag 4.3-17 was broken and would not work
200
201 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
202 - bugfix - escape sequences inserted in xml configs
203
204 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
205 - Handle db-config.d files properly.
206
207 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
208 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
209 - than the log file
210 - - Fix db-config to be a bit more cautious when
211 - /etc/planetlab/db-config.d doesn't exist
212 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
213 - .orig files.
214 - - Refactor generic plc-config-tty code into plc_config.py.
215 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
216 - and the list of validated variables and the corresponding
217 - validator() function. This refactoring lets one reuse plc_config.py
218 - as a generic cmdline configuration tool for highly customer MyPLC
219 - like software.
220
221 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
222 - update PCU Type descriptions.
223 - updates to init scripts
224
225 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
226 - requires monitor-pcucontrol so register-wizard can work
227
228 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
229 - cleaned up plc-config-tty, no more need to configure plc-devel
230
231 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
232 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
233
234 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
235 - tighter right permissions on site_admin's authorized keys for more robustness
236
237 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
238 - fix issue in db-config that prevented correct operation
239
240 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
241 - remove support for chroot-based packaging - no crond nor syslog step anymore
242 - plc init script now named plc.init instead of former guest.init
243
244 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
245 - add Monitor to docs build
246
247 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
248 - plc_config.py and plc-config-tty: generalized to work for more diverse
249 - MyPLC configurations.
250 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
251 - deployments and increase the memory limits in php.ini
252 - plc.d/crond: add --full option to vacuumdb
253
254 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
255 - avoid generating ssl certificates for disabled services among www api boot
256
257 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
258 - cleaned up old entries in db-config
259 - mtail more robust
260
261 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
262 - php include path tweaked for plekit includes
263 - reviewed myplc (fka native) packaging dependencies
264 - renumbered 4.3
265
266 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
267 - rename myplc into myplc-chroot and myplc-native into myplc
268 - new settings (shortname & hrn_root) for local peer
269
270
271 %define module_current_branch 4.3