Setting tag myplc-5.0-15
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 15
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
56 - ignore steps in db-config.d if they have a '.' or '~' in their name
57
58 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
59 - can redo myplc-docs without the doc for monitor
60
61 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
62 - no semantic change - just fixed specfile for git URL
63
64 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
65 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
66
67 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
68 - add missing files to rpm package
69
70 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
71 - mtail.py -s for SFA
72 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
73
74 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
75 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
76
77 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
78 - plc-config-tty now has a validator on booleans
79 - e.g. entering 'True' now is rejected rather than silently recording 'false'
80
81 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
82 - disable mod_wsgi
83
84 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
85 - module name changes
86 - start wsgi support
87
88 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
89 - new setting PLC_RESERVATION_GRANULARITY
90
91 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
92 - * partial-repo.sh script
93 - * preserve key along with certificates
94
95 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
96 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
97
98 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
99 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
100 - new OMF category in the config
101 - create the drl system slice
102
103 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
104 - first working version of 5.0:
105 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
106 - nodefamily is 3-fold with pldistro-fcdistro-arch
107 - new PLC_FLAVOUR config category
108 - reviewed module layout
109 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
110
111 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
112 - support for fedora 12
113 - new package myplc-config for use by sfa
114 - drupal user registration turned off
115
116 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
117 - - fix to make sure when API, BOOT, MONITOR are on the same
118 - machine as WWW that the SSL key,cert for WWW takes precedence.
119 - - Do proper setup for SSL CA certficate to be used as the server
120 - chain.
121
122 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
123 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
124
125 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
126 - depend on pcucontrol
127
128 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
129 - * validate input according to type in plc_config
130 - * added the _genicw system slice
131 - * add tag types for sites and persons
132 - * add new tags for nodes and slices for exemption from myops
133
134 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
135 - turn off drupal on a box that acts as BOOT server but not as WWW server
136 - cleanup some obsolete code for old chroot-jail packaging in the process
137 - new bootcd-kernel script for keeping bootcd variants up2date
138
139 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
140 - Make the /etc/hosts manipulation optional.
141
142 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
143 - Fix SetRole.
144
145 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
146 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
147 - into the DB.
148 - - Added the root ssh key handling support back into plc.d/ssh and the
149 - default xml file.  This should be identical to the way it was in
150 - rc12.
151 - - Added support in the db-config.d/01-init script to register the root
152 - ssh public key with the default administrator.  In this way the root
153 - ssh key will make it into the root account on the nodes by means of
154 - NodeManager's specialaccounts plugin.
155
156 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
157 - db-config ignores sliver tags
158 - sirius's db-config script renamed (was sirious)
159
160 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
161 - fix for silverauth - missing tag types now created at plc startup time
162
163 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
164 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
165
166 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
167 - companion to NM's specialaccounts plugin
168 - do not generate /etc/planetlab/root_ssh_key* anymore
169 - remove related config. variables and conf_files
170
171 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
172 - clarified description text to refer only to plcrt and not other optional
173 - packages.
174
175 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
176 - fixed a bug setting slice multiple attributes with the same tag name
177
178 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
179 - SSL setup for monitor box, and related new config variables
180 - new conf_file for /etc/planetlab/extensions
181 - various tweaks in db-config internals, about initscripts among others
182 - also more messages defined in the db
183
184 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
185 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
186
187 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
188 - bugfix in db-config, tag 4.3-19 would not fly
189
190 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
191 - Refactored db-config into snippets in db-config.d/.
192
193 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
194 - oops, tag 4.3-17 was broken and would not work
195
196 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
197 - bugfix - escape sequences inserted in xml configs
198
199 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
200 - Handle db-config.d files properly.
201
202 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
203 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
204 - than the log file
205 - - Fix db-config to be a bit more cautious when
206 - /etc/planetlab/db-config.d doesn't exist
207 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
208 - .orig files.
209 - - Refactor generic plc-config-tty code into plc_config.py.
210 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
211 - and the list of validated variables and the corresponding
212 - validator() function. This refactoring lets one reuse plc_config.py
213 - as a generic cmdline configuration tool for highly customer MyPLC
214 - like software.
215
216 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
217 - update PCU Type descriptions.
218 - updates to init scripts
219
220 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
221 - requires monitor-pcucontrol so register-wizard can work
222
223 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
224 - cleaned up plc-config-tty, no more need to configure plc-devel
225
226 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
227 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
228
229 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
230 - tighter right permissions on site_admin's authorized keys for more robustness
231
232 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
233 - fix issue in db-config that prevented correct operation
234
235 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
236 - remove support for chroot-based packaging - no crond nor syslog step anymore
237 - plc init script now named plc.init instead of former guest.init
238
239 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
240 - add Monitor to docs build
241
242 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
243 - plc_config.py and plc-config-tty: generalized to work for more diverse
244 - MyPLC configurations.
245 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
246 - deployments and increase the memory limits in php.ini
247 - plc.d/crond: add --full option to vacuumdb
248
249 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
250 - avoid generating ssl certificates for disabled services among www api boot
251
252 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
253 - cleaned up old entries in db-config
254 - mtail more robust
255
256 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
257 - php include path tweaked for plekit includes
258 - reviewed myplc (fka native) packaging dependencies
259 - renumbered 4.3
260
261 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
262 - rename myplc into myplc-chroot and myplc-native into myplc
263 - new settings (shortname & hrn_root) for local peer
264
265
266 %define module_current_branch 4.3