Setting tag MyPLC-5.0-3
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
61 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
62
63 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
64 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
65 - new OMF category in the config
66 - create the drl system slice
67
68 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
69 - first working version of 5.0:
70 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
71 - nodefamily is 3-fold with pldistro-fcdistro-arch
72 - new PLC_FLAVOUR config category
73 - reviewed module layout
74 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
75
76 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
77 - support for fedora 12
78 - new package myplc-config for use by sfa
79 - drupal user registration turned off
80
81 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
82 - - fix to make sure when API, BOOT, MONITOR are on the same
83 - machine as WWW that the SSL key,cert for WWW takes precedence.
84 - - Do proper setup for SSL CA certficate to be used as the server
85 - chain.
86
87 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
88 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
89
90 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
91 - depend on pcucontrol
92
93 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
94 - * validate input according to type in plc_config
95 - * added the _genicw system slice
96 - * add tag types for sites and persons
97 - * add new tags for nodes and slices for exemption from myops
98
99 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
100 - turn off drupal on a box that acts as BOOT server but not as WWW server
101 - cleanup some obsolete code for old chroot-jail packaging in the process
102 - new bootcd-kernel script for keeping bootcd variants up2date
103
104 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
105 - Make the /etc/hosts manipulation optional.
106
107 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
108 - Fix SetRole.
109
110 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
111 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
112 - into the DB.
113 - - Added the root ssh key handling support back into plc.d/ssh and the
114 - default xml file.  This should be identical to the way it was in
115 - rc12.
116 - - Added support in the db-config.d/01-init script to register the root
117 - ssh public key with the default administrator.  In this way the root
118 - ssh key will make it into the root account on the nodes by means of
119 - NodeManager's specialaccounts plugin.
120
121 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
122 - db-config ignores sliver tags
123 - sirius's db-config script renamed (was sirious)
124
125 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
126 - fix for silverauth - missing tag types now created at plc startup time
127
128 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
129 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
130
131 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
132 - companion to NM's specialaccounts plugin
133 - do not generate /etc/planetlab/root_ssh_key* anymore
134 - remove related config. variables and conf_files
135
136 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
137 - clarified description text to refer only to plcrt and not other optional
138 - packages.
139
140 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
141 - fixed a bug setting slice multiple attributes with the same tag name
142
143 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
144 - SSL setup for monitor box, and related new config variables
145 - new conf_file for /etc/planetlab/extensions
146 - various tweaks in db-config internals, about initscripts among others
147 - also more messages defined in the db
148
149 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
150 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
151
152 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
153 - bugfix in db-config, tag 4.3-19 would not fly
154
155 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
156 - Refactored db-config into snippets in db-config.d/.
157
158 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
159 - oops, tag 4.3-17 was broken and would not work
160
161 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
162 - bugfix - escape sequences inserted in xml configs
163
164 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
165 - Handle db-config.d files properly.
166
167 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
168 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
169 - than the log file
170 - - Fix db-config to be a bit more cautious when
171 - /etc/planetlab/db-config.d doesn't exist
172 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
173 - .orig files.
174 - - Refactor generic plc-config-tty code into plc_config.py.
175 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
176 - and the list of validated variables and the corresponding
177 - validator() function. This refactoring lets one reuse plc_config.py
178 - as a generic cmdline configuration tool for highly customer MyPLC
179 - like software.
180
181 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
182 - update PCU Type descriptions.
183 - updates to init scripts
184
185 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
186 - requires monitor-pcucontrol so register-wizard can work
187
188 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
189 - cleaned up plc-config-tty, no more need to configure plc-devel
190
191 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
192 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
193
194 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
195 - tighter right permissions on site_admin's authorized keys for more robustness
196
197 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
198 - fix issue in db-config that prevented correct operation
199
200 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
201 - remove support for chroot-based packaging - no crond nor syslog step anymore
202 - plc init script now named plc.init instead of former guest.init
203
204 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
205 - add Monitor to docs build
206
207 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
208 - plc_config.py and plc-config-tty: generalized to work for more diverse
209 - MyPLC configurations.
210 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
211 - deployments and increase the memory limits in php.ini
212 - plc.d/crond: add --full option to vacuumdb
213
214 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
215 - avoid generating ssl certificates for disabled services among www api boot
216
217 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
218 - cleaned up old entries in db-config
219 - mtail more robust
220
221 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
222 - php include path tweaked for plekit includes
223 - reviewed myplc (fka native) packaging dependencies
224 - renumbered 4.3
225
226 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
227 - rename myplc into myplc-chroot and myplc-native into myplc
228 - new settings (shortname & hrn_root) for local peer
229
230
231 %define module_current_branch 4.3