Tagging module MyPLC - MyPLC-4.3-20
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 20
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
61 - bugfix in db-config, tag 4.3-19 would not fly
62
63 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
64 - Refactored db-config into snippets in db-config.d/.
65
66 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
67 - oops, tag 4.3-17 was broken and would not work
68
69 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
70 - bugfix - escape sequences inserted in xml configs
71
72 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
73 - Handle db-config.d files properly.
74
75 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
76 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
77 - than the log file
78 - - Fix db-config to be a bit more cautious when
79 - /etc/planetlab/db-config.d doesn't exist
80 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
81 - .orig files.
82 - - Refactor generic plc-config-tty code into plc_config.py.
83 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
84 - and the list of validated variables and the corresponding
85 - validator() function. This refactoring lets one reuse plc_config.py
86 - as a generic cmdline configuration tool for highly customer MyPLC
87 - like software.
88
89 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
90 - update PCU Type descriptions.
91 - updates to init scripts
92
93 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
94 - requires monitor-pcucontrol so register-wizard can work
95
96 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
97 - cleaned up plc-config-tty, no more need to configure plc-devel
98
99 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
100 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
101
102 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
103 - tighter right permissions on site_admin's authorized keys for more robustness
104
105 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
106 - fix issue in db-config that prevented correct operation
107
108 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
109 - remove support for chroot-based packaging - no crond nor syslog step anymore
110 - plc init script now named plc.init instead of former guest.init
111
112 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
113 - add Monitor to docs build
114
115 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
116 - plc_config.py and plc-config-tty: generalized to work for more diverse
117 - MyPLC configurations.
118 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
119 - deployments and increase the memory limits in php.ini
120 - plc.d/crond: add --full option to vacuumdb
121
122 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
123 - avoid generating ssl certificates for disabled services among www api boot
124
125 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
126 - cleaned up old entries in db-config
127 - mtail more robust
128
129 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
130 - php include path tweaked for plekit includes
131 - reviewed myplc (fka native) packaging dependencies
132 - renumbered 4.3
133
134 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
135 - rename myplc into myplc-chroot and myplc-native into myplc
136 - new settings (shortname & hrn_root) for local peer
137