Setting tag MyPLC-4.3-32
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 32
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
61 - turn off drupal on a box that acts as BOOT server but not as WWW server
62 - cleanup some obsolete code for old chroot-jail packaging in the process
63 - new bootcd-kernel script for keeping bootcd variants up2date
64
65 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
66 - Make the /etc/hosts manipulation optional.
67
68 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
69 - Fix SetRole.
70
71 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
72 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
73 - into the DB.
74 - - Added the root ssh key handling support back into plc.d/ssh and the
75 - default xml file.  This should be identical to the way it was in
76 - rc12.
77 - - Added support in the db-config.d/01-init script to register the root
78 - ssh public key with the default administrator.  In this way the root
79 - ssh key will make it into the root account on the nodes by means of
80 - NodeManager's specialaccounts plugin.
81
82 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
83 - db-config ignores sliver tags
84 - sirius's db-config script renamed (was sirious)
85
86 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
87 - fix for silverauth - missing tag types now created at plc startup time
88
89 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
90 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
91
92 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
93 - companion to NM's specialaccounts plugin
94 - do not generate /etc/planetlab/root_ssh_key* anymore
95 - remove related config. variables and conf_files
96
97 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
98 - clarified description text to refer only to plcrt and not other optional
99 - packages.
100
101 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
102 - fixed a bug setting slice multiple attributes with the same tag name
103
104 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
105 - SSL setup for monitor box, and related new config variables
106 - new conf_file for /etc/planetlab/extensions
107 - various tweaks in db-config internals, about initscripts among others
108 - also more messages defined in the db
109
110 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
111 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
112
113 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
114 - bugfix in db-config, tag 4.3-19 would not fly
115
116 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
117 - Refactored db-config into snippets in db-config.d/.
118
119 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
120 - oops, tag 4.3-17 was broken and would not work
121
122 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
123 - bugfix - escape sequences inserted in xml configs
124
125 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
126 - Handle db-config.d files properly.
127
128 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
129 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
130 - than the log file
131 - - Fix db-config to be a bit more cautious when
132 - /etc/planetlab/db-config.d doesn't exist
133 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
134 - .orig files.
135 - - Refactor generic plc-config-tty code into plc_config.py.
136 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
137 - and the list of validated variables and the corresponding
138 - validator() function. This refactoring lets one reuse plc_config.py
139 - as a generic cmdline configuration tool for highly customer MyPLC
140 - like software.
141
142 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
143 - update PCU Type descriptions.
144 - updates to init scripts
145
146 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
147 - requires monitor-pcucontrol so register-wizard can work
148
149 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
150 - cleaned up plc-config-tty, no more need to configure plc-devel
151
152 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
153 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
154
155 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
156 - tighter right permissions on site_admin's authorized keys for more robustness
157
158 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
159 - fix issue in db-config that prevented correct operation
160
161 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
162 - remove support for chroot-based packaging - no crond nor syslog step anymore
163 - plc init script now named plc.init instead of former guest.init
164
165 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
166 - add Monitor to docs build
167
168 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
169 - plc_config.py and plc-config-tty: generalized to work for more diverse
170 - MyPLC configurations.
171 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
172 - deployments and increase the memory limits in php.ini
173 - plc.d/crond: add --full option to vacuumdb
174
175 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
176 - avoid generating ssl certificates for disabled services among www api boot
177
178 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
179 - cleaned up old entries in db-config
180 - mtail more robust
181
182 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
183 - php include path tweaked for plekit includes
184 - reviewed myplc (fka native) packaging dependencies
185 - renumbered 4.3
186
187 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
188 - rename myplc into myplc-chroot and myplc-native into myplc
189 - new settings (shortname & hrn_root) for local peer
190