Setting tag myplc-5.0-13
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 13
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
56 - no semantic change - just fixed specfile for git URL
57
58 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
59 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
60
61 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
62 - add missing files to rpm package
63
64 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
65 - mtail.py -s for SFA
66 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
67
68 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
69 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
70
71 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
72 - plc-config-tty now has a validator on booleans
73 - e.g. entering 'True' now is rejected rather than silently recording 'false'
74
75 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
76 - disable mod_wsgi
77
78 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
79 - module name changes
80 - start wsgi support
81
82 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
83 - new setting PLC_RESERVATION_GRANULARITY
84
85 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
86 - * partial-repo.sh script
87 - * preserve key along with certificates
88
89 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
90 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
91
92 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
93 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
94 - new OMF category in the config
95 - create the drl system slice
96
97 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
98 - first working version of 5.0:
99 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
100 - nodefamily is 3-fold with pldistro-fcdistro-arch
101 - new PLC_FLAVOUR config category
102 - reviewed module layout
103 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
104
105 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
106 - support for fedora 12
107 - new package myplc-config for use by sfa
108 - drupal user registration turned off
109
110 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
111 - - fix to make sure when API, BOOT, MONITOR are on the same
112 - machine as WWW that the SSL key,cert for WWW takes precedence.
113 - - Do proper setup for SSL CA certficate to be used as the server
114 - chain.
115
116 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
117 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
118
119 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
120 - depend on pcucontrol
121
122 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
123 - * validate input according to type in plc_config
124 - * added the _genicw system slice
125 - * add tag types for sites and persons
126 - * add new tags for nodes and slices for exemption from myops
127
128 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
129 - turn off drupal on a box that acts as BOOT server but not as WWW server
130 - cleanup some obsolete code for old chroot-jail packaging in the process
131 - new bootcd-kernel script for keeping bootcd variants up2date
132
133 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
134 - Make the /etc/hosts manipulation optional.
135
136 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
137 - Fix SetRole.
138
139 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
140 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
141 - into the DB.
142 - - Added the root ssh key handling support back into plc.d/ssh and the
143 - default xml file.  This should be identical to the way it was in
144 - rc12.
145 - - Added support in the db-config.d/01-init script to register the root
146 - ssh public key with the default administrator.  In this way the root
147 - ssh key will make it into the root account on the nodes by means of
148 - NodeManager's specialaccounts plugin.
149
150 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
151 - db-config ignores sliver tags
152 - sirius's db-config script renamed (was sirious)
153
154 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
155 - fix for silverauth - missing tag types now created at plc startup time
156
157 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
158 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
159
160 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
161 - companion to NM's specialaccounts plugin
162 - do not generate /etc/planetlab/root_ssh_key* anymore
163 - remove related config. variables and conf_files
164
165 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
166 - clarified description text to refer only to plcrt and not other optional
167 - packages.
168
169 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
170 - fixed a bug setting slice multiple attributes with the same tag name
171
172 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
173 - SSL setup for monitor box, and related new config variables
174 - new conf_file for /etc/planetlab/extensions
175 - various tweaks in db-config internals, about initscripts among others
176 - also more messages defined in the db
177
178 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
179 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
180
181 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
182 - bugfix in db-config, tag 4.3-19 would not fly
183
184 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
185 - Refactored db-config into snippets in db-config.d/.
186
187 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
188 - oops, tag 4.3-17 was broken and would not work
189
190 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
191 - bugfix - escape sequences inserted in xml configs
192
193 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
194 - Handle db-config.d files properly.
195
196 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
197 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
198 - than the log file
199 - - Fix db-config to be a bit more cautious when
200 - /etc/planetlab/db-config.d doesn't exist
201 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
202 - .orig files.
203 - - Refactor generic plc-config-tty code into plc_config.py.
204 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
205 - and the list of validated variables and the corresponding
206 - validator() function. This refactoring lets one reuse plc_config.py
207 - as a generic cmdline configuration tool for highly customer MyPLC
208 - like software.
209
210 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
211 - update PCU Type descriptions.
212 - updates to init scripts
213
214 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
215 - requires monitor-pcucontrol so register-wizard can work
216
217 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
218 - cleaned up plc-config-tty, no more need to configure plc-devel
219
220 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
221 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
222
223 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
224 - tighter right permissions on site_admin's authorized keys for more robustness
225
226 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
227 - fix issue in db-config that prevented correct operation
228
229 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
230 - remove support for chroot-based packaging - no crond nor syslog step anymore
231 - plc init script now named plc.init instead of former guest.init
232
233 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
234 - add Monitor to docs build
235
236 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
237 - plc_config.py and plc-config-tty: generalized to work for more diverse
238 - MyPLC configurations.
239 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
240 - deployments and increase the memory limits in php.ini
241 - plc.d/crond: add --full option to vacuumdb
242
243 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
244 - avoid generating ssl certificates for disabled services among www api boot
245
246 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
247 - cleaned up old entries in db-config
248 - mtail more robust
249
250 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
251 - php include path tweaked for plekit includes
252 - reviewed myplc (fka native) packaging dependencies
253 - renumbered 4.3
254
255 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
256 - rename myplc into myplc-chroot and myplc-native into myplc
257 - new settings (shortname & hrn_root) for local peer
258
259
260 %define module_current_branch 4.3