fix URL in specfile - rm svn-keywords
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 12
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
56 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
57
58 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
59 - add missing files to rpm package
60
61 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
62 - mtail.py -s for SFA
63 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
64
65 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
66 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
67
68 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
69 - plc-config-tty now has a validator on booleans
70 - e.g. entering 'True' now is rejected rather than silently recording 'false'
71
72 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
73 - disable mod_wsgi
74
75 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
76 - module name changes
77 - start wsgi support
78
79 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
80 - new setting PLC_RESERVATION_GRANULARITY
81
82 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
83 - * partial-repo.sh script
84 - * preserve key along with certificates
85
86 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
87 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
88
89 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
90 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
91 - new OMF category in the config
92 - create the drl system slice
93
94 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
95 - first working version of 5.0:
96 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
97 - nodefamily is 3-fold with pldistro-fcdistro-arch
98 - new PLC_FLAVOUR config category
99 - reviewed module layout
100 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
101
102 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
103 - support for fedora 12
104 - new package myplc-config for use by sfa
105 - drupal user registration turned off
106
107 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
108 - - fix to make sure when API, BOOT, MONITOR are on the same
109 - machine as WWW that the SSL key,cert for WWW takes precedence.
110 - - Do proper setup for SSL CA certficate to be used as the server
111 - chain.
112
113 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
114 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
115
116 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
117 - depend on pcucontrol
118
119 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
120 - * validate input according to type in plc_config
121 - * added the _genicw system slice
122 - * add tag types for sites and persons
123 - * add new tags for nodes and slices for exemption from myops
124
125 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
126 - turn off drupal on a box that acts as BOOT server but not as WWW server
127 - cleanup some obsolete code for old chroot-jail packaging in the process
128 - new bootcd-kernel script for keeping bootcd variants up2date
129
130 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
131 - Make the /etc/hosts manipulation optional.
132
133 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
134 - Fix SetRole.
135
136 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
137 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
138 - into the DB.
139 - - Added the root ssh key handling support back into plc.d/ssh and the
140 - default xml file.  This should be identical to the way it was in
141 - rc12.
142 - - Added support in the db-config.d/01-init script to register the root
143 - ssh public key with the default administrator.  In this way the root
144 - ssh key will make it into the root account on the nodes by means of
145 - NodeManager's specialaccounts plugin.
146
147 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
148 - db-config ignores sliver tags
149 - sirius's db-config script renamed (was sirious)
150
151 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
152 - fix for silverauth - missing tag types now created at plc startup time
153
154 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
155 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
156
157 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
158 - companion to NM's specialaccounts plugin
159 - do not generate /etc/planetlab/root_ssh_key* anymore
160 - remove related config. variables and conf_files
161
162 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
163 - clarified description text to refer only to plcrt and not other optional
164 - packages.
165
166 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
167 - fixed a bug setting slice multiple attributes with the same tag name
168
169 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
170 - SSL setup for monitor box, and related new config variables
171 - new conf_file for /etc/planetlab/extensions
172 - various tweaks in db-config internals, about initscripts among others
173 - also more messages defined in the db
174
175 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
176 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
177
178 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
179 - bugfix in db-config, tag 4.3-19 would not fly
180
181 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
182 - Refactored db-config into snippets in db-config.d/.
183
184 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
185 - oops, tag 4.3-17 was broken and would not work
186
187 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
188 - bugfix - escape sequences inserted in xml configs
189
190 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
191 - Handle db-config.d files properly.
192
193 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
194 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
195 - than the log file
196 - - Fix db-config to be a bit more cautious when
197 - /etc/planetlab/db-config.d doesn't exist
198 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
199 - .orig files.
200 - - Refactor generic plc-config-tty code into plc_config.py.
201 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
202 - and the list of validated variables and the corresponding
203 - validator() function. This refactoring lets one reuse plc_config.py
204 - as a generic cmdline configuration tool for highly customer MyPLC
205 - like software.
206
207 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
208 - update PCU Type descriptions.
209 - updates to init scripts
210
211 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
212 - requires monitor-pcucontrol so register-wizard can work
213
214 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
215 - cleaned up plc-config-tty, no more need to configure plc-devel
216
217 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
218 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
219
220 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
221 - tighter right permissions on site_admin's authorized keys for more robustness
222
223 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
224 - fix issue in db-config that prevented correct operation
225
226 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
227 - remove support for chroot-based packaging - no crond nor syslog step anymore
228 - plc init script now named plc.init instead of former guest.init
229
230 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
231 - add Monitor to docs build
232
233 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
234 - plc_config.py and plc-config-tty: generalized to work for more diverse
235 - MyPLC configurations.
236 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
237 - deployments and increase the memory limits in php.ini
238 - plc.d/crond: add --full option to vacuumdb
239
240 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
241 - avoid generating ssl certificates for disabled services among www api boot
242
243 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
244 - cleaned up old entries in db-config
245 - mtail more robust
246
247 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
248 - php include path tweaked for plekit includes
249 - reviewed myplc (fka native) packaging dependencies
250 - renumbered 4.3
251
252 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
253 - rename myplc into myplc-chroot and myplc-native into myplc
254 - new settings (shortname & hrn_root) for local peer
255
256
257 %define module_current_branch 4.3