Setting tag myplc-5.0-12
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 12
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
61 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
62
63 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
64 - add missing files to rpm package
65
66 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
67 - mtail.py -s for SFA
68 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
69
70 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
71 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
72
73 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
74 - plc-config-tty now has a validator on booleans
75 - e.g. entering 'True' now is rejected rather than silently recording 'false'
76
77 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
78 - disable mod_wsgi
79
80 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
81 - module name changes
82 - start wsgi support
83
84 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
85 - new setting PLC_RESERVATION_GRANULARITY
86
87 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
88 - * partial-repo.sh script
89 - * preserve key along with certificates
90
91 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
92 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
93
94 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
95 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
96 - new OMF category in the config
97 - create the drl system slice
98
99 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
100 - first working version of 5.0:
101 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
102 - nodefamily is 3-fold with pldistro-fcdistro-arch
103 - new PLC_FLAVOUR config category
104 - reviewed module layout
105 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
106
107 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
108 - support for fedora 12
109 - new package myplc-config for use by sfa
110 - drupal user registration turned off
111
112 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
113 - - fix to make sure when API, BOOT, MONITOR are on the same
114 - machine as WWW that the SSL key,cert for WWW takes precedence.
115 - - Do proper setup for SSL CA certficate to be used as the server
116 - chain.
117
118 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
119 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
120
121 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
122 - depend on pcucontrol
123
124 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
125 - * validate input according to type in plc_config
126 - * added the _genicw system slice
127 - * add tag types for sites and persons
128 - * add new tags for nodes and slices for exemption from myops
129
130 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
131 - turn off drupal on a box that acts as BOOT server but not as WWW server
132 - cleanup some obsolete code for old chroot-jail packaging in the process
133 - new bootcd-kernel script for keeping bootcd variants up2date
134
135 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
136 - Make the /etc/hosts manipulation optional.
137
138 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
139 - Fix SetRole.
140
141 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
142 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
143 - into the DB.
144 - - Added the root ssh key handling support back into plc.d/ssh and the
145 - default xml file.  This should be identical to the way it was in
146 - rc12.
147 - - Added support in the db-config.d/01-init script to register the root
148 - ssh public key with the default administrator.  In this way the root
149 - ssh key will make it into the root account on the nodes by means of
150 - NodeManager's specialaccounts plugin.
151
152 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
153 - db-config ignores sliver tags
154 - sirius's db-config script renamed (was sirious)
155
156 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
157 - fix for silverauth - missing tag types now created at plc startup time
158
159 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
160 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
161
162 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
163 - companion to NM's specialaccounts plugin
164 - do not generate /etc/planetlab/root_ssh_key* anymore
165 - remove related config. variables and conf_files
166
167 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
168 - clarified description text to refer only to plcrt and not other optional
169 - packages.
170
171 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
172 - fixed a bug setting slice multiple attributes with the same tag name
173
174 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
175 - SSL setup for monitor box, and related new config variables
176 - new conf_file for /etc/planetlab/extensions
177 - various tweaks in db-config internals, about initscripts among others
178 - also more messages defined in the db
179
180 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
181 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
182
183 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
184 - bugfix in db-config, tag 4.3-19 would not fly
185
186 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
187 - Refactored db-config into snippets in db-config.d/.
188
189 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
190 - oops, tag 4.3-17 was broken and would not work
191
192 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
193 - bugfix - escape sequences inserted in xml configs
194
195 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
196 - Handle db-config.d files properly.
197
198 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
199 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
200 - than the log file
201 - - Fix db-config to be a bit more cautious when
202 - /etc/planetlab/db-config.d doesn't exist
203 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
204 - .orig files.
205 - - Refactor generic plc-config-tty code into plc_config.py.
206 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
207 - and the list of validated variables and the corresponding
208 - validator() function. This refactoring lets one reuse plc_config.py
209 - as a generic cmdline configuration tool for highly customer MyPLC
210 - like software.
211
212 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
213 - update PCU Type descriptions.
214 - updates to init scripts
215
216 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
217 - requires monitor-pcucontrol so register-wizard can work
218
219 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
220 - cleaned up plc-config-tty, no more need to configure plc-devel
221
222 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
223 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
224
225 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
226 - tighter right permissions on site_admin's authorized keys for more robustness
227
228 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
229 - fix issue in db-config that prevented correct operation
230
231 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
232 - remove support for chroot-based packaging - no crond nor syslog step anymore
233 - plc init script now named plc.init instead of former guest.init
234
235 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
236 - add Monitor to docs build
237
238 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
239 - plc_config.py and plc-config-tty: generalized to work for more diverse
240 - MyPLC configurations.
241 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
242 - deployments and increase the memory limits in php.ini
243 - plc.d/crond: add --full option to vacuumdb
244
245 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
246 - avoid generating ssl certificates for disabled services among www api boot
247
248 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
249 - cleaned up old entries in db-config
250 - mtail more robust
251
252 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
253 - php include path tweaked for plekit includes
254 - reviewed myplc (fka native) packaging dependencies
255 - renumbered 4.3
256
257 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
258 - rename myplc into myplc-chroot and myplc-native into myplc
259 - new settings (shortname & hrn_root) for local peer
260
261
262 %define module_current_branch 4.3