Merge branch 'master' of ssh://git.onelab.eu/git/myplc
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 11
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
61 - add missing files to rpm package
62
63 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
64 - mtail.py -s for SFA
65 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
66
67 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
68 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
69
70 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
71 - plc-config-tty now has a validator on booleans
72 - e.g. entering 'True' now is rejected rather than silently recording 'false'
73
74 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
75 - disable mod_wsgi
76
77 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
78 - module name changes
79 - start wsgi support
80
81 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
82 - new setting PLC_RESERVATION_GRANULARITY
83
84 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
85 - * partial-repo.sh script
86 - * preserve key along with certificates
87
88 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
89 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
90
91 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
92 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
93 - new OMF category in the config
94 - create the drl system slice
95
96 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
97 - first working version of 5.0:
98 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
99 - nodefamily is 3-fold with pldistro-fcdistro-arch
100 - new PLC_FLAVOUR config category
101 - reviewed module layout
102 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
103
104 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
105 - support for fedora 12
106 - new package myplc-config for use by sfa
107 - drupal user registration turned off
108
109 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
110 - - fix to make sure when API, BOOT, MONITOR are on the same
111 - machine as WWW that the SSL key,cert for WWW takes precedence.
112 - - Do proper setup for SSL CA certficate to be used as the server
113 - chain.
114
115 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
116 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
117
118 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
119 - depend on pcucontrol
120
121 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
122 - * validate input according to type in plc_config
123 - * added the _genicw system slice
124 - * add tag types for sites and persons
125 - * add new tags for nodes and slices for exemption from myops
126
127 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
128 - turn off drupal on a box that acts as BOOT server but not as WWW server
129 - cleanup some obsolete code for old chroot-jail packaging in the process
130 - new bootcd-kernel script for keeping bootcd variants up2date
131
132 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
133 - Make the /etc/hosts manipulation optional.
134
135 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
136 - Fix SetRole.
137
138 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
139 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
140 - into the DB.
141 - - Added the root ssh key handling support back into plc.d/ssh and the
142 - default xml file.  This should be identical to the way it was in
143 - rc12.
144 - - Added support in the db-config.d/01-init script to register the root
145 - ssh public key with the default administrator.  In this way the root
146 - ssh key will make it into the root account on the nodes by means of
147 - NodeManager's specialaccounts plugin.
148
149 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
150 - db-config ignores sliver tags
151 - sirius's db-config script renamed (was sirious)
152
153 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
154 - fix for silverauth - missing tag types now created at plc startup time
155
156 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
157 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
158
159 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
160 - companion to NM's specialaccounts plugin
161 - do not generate /etc/planetlab/root_ssh_key* anymore
162 - remove related config. variables and conf_files
163
164 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
165 - clarified description text to refer only to plcrt and not other optional
166 - packages.
167
168 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
169 - fixed a bug setting slice multiple attributes with the same tag name
170
171 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
172 - SSL setup for monitor box, and related new config variables
173 - new conf_file for /etc/planetlab/extensions
174 - various tweaks in db-config internals, about initscripts among others
175 - also more messages defined in the db
176
177 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
178 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
179
180 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
181 - bugfix in db-config, tag 4.3-19 would not fly
182
183 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
184 - Refactored db-config into snippets in db-config.d/.
185
186 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
187 - oops, tag 4.3-17 was broken and would not work
188
189 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
190 - bugfix - escape sequences inserted in xml configs
191
192 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
193 - Handle db-config.d files properly.
194
195 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
196 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
197 - than the log file
198 - - Fix db-config to be a bit more cautious when
199 - /etc/planetlab/db-config.d doesn't exist
200 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
201 - .orig files.
202 - - Refactor generic plc-config-tty code into plc_config.py.
203 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
204 - and the list of validated variables and the corresponding
205 - validator() function. This refactoring lets one reuse plc_config.py
206 - as a generic cmdline configuration tool for highly customer MyPLC
207 - like software.
208
209 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
210 - update PCU Type descriptions.
211 - updates to init scripts
212
213 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
214 - requires monitor-pcucontrol so register-wizard can work
215
216 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
217 - cleaned up plc-config-tty, no more need to configure plc-devel
218
219 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
220 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
221
222 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
223 - tighter right permissions on site_admin's authorized keys for more robustness
224
225 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
226 - fix issue in db-config that prevented correct operation
227
228 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
229 - remove support for chroot-based packaging - no crond nor syslog step anymore
230 - plc init script now named plc.init instead of former guest.init
231
232 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
233 - add Monitor to docs build
234
235 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
236 - plc_config.py and plc-config-tty: generalized to work for more diverse
237 - MyPLC configurations.
238 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
239 - deployments and increase the memory limits in php.ini
240 - plc.d/crond: add --full option to vacuumdb
241
242 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
243 - avoid generating ssl certificates for disabled services among www api boot
244
245 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
246 - cleaned up old entries in db-config
247 - mtail more robust
248
249 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
250 - php include path tweaked for plekit includes
251 - reviewed myplc (fka native) packaging dependencies
252 - renumbered 4.3
253
254 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
255 - rename myplc into myplc-chroot and myplc-native into myplc
256 - new settings (shortname & hrn_root) for local peer
257
258
259 %define module_current_branch 4.3