Setting tag myplc-5.0-17
[myplc.git] / myplc-release.spec
1 %define name myplc-release
2 %define version 5.0
3 %define taglevel 17
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central (PLC) release file
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: Applications/Systems
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15 BuildArch: noarch
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 %define debug_package %{nil}
23
24 %description 
25 This package contains in /etc/myplc-release the details of the
26 contents of that release. This is used by the GetPlcRelease API call.
27
28 %prep
29 %setup -q
30
31 %build
32
33 # fetch the release stamp from the build if any
34 if [ -f ../../myplc-release ] ; then
35   cp ../../myplc-release myplc-release
36 else
37   echo "Cannot find release information." > myplc-release
38   date >> myplc-release
39   echo "$HeadURL$" >> myplc-release
40 fi
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 # install it in /etc/myplc-release 
45 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root,-)
52 /etc/myplc-release
53
54 %changelog
55 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
56 - fixed changelog, no change from 5.0-16
57
58 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
59 - requires ed for the plc.d/packages step
60 - sirius initscript to handle stop and restart
61
62 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
63 - ignore steps in db-config.d if they have a '.' or '~' in their name
64
65 * Wed Jan 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-14
66 - can redo myplc-docs without the doc for monitor
67
68 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-13
69 - no semantic change - just fixed specfile for git URL
70
71 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-12
72 - needed for plcapi-5.0-19, i.e. tag permissions based on roles
73
74 * Mon Oct 04 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - myplc-5.0-11
75 - add missing files to rpm package
76
77 * Mon Oct 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-10
78 - mtail.py -s for SFA
79 - spot-aliesm.py is a utility script for sanity checks of the PLC db when running refreshpeer+sfa
80
81 * Thu Jul 15 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-9
82 - avoid duplication of the plc-config binary in both myplc and myplc-config rpms
83
84 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-8
85 - plc-config-tty now has a validator on booleans
86 - e.g. entering 'True' now is rejected rather than silently recording 'false'
87
88 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-7
89 - disable mod_wsgi
90
91 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-6
92 - module name changes
93 - start wsgi support
94
95 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-5
96 - new setting PLC_RESERVATION_GRANULARITY
97
98 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
99 - * partial-repo.sh script
100 - * preserve key along with certificates
101
102 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
103 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
104
105 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
106 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
107 - new OMF category in the config
108 - create the drl system slice
109
110 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
111 - first working version of 5.0:
112 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
113 - nodefamily is 3-fold with pldistro-fcdistro-arch
114 - new PLC_FLAVOUR config category
115 - reviewed module layout
116 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
117
118 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
119 - support for fedora 12
120 - new package myplc-config for use by sfa
121 - drupal user registration turned off
122
123 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
124 - - fix to make sure when API, BOOT, MONITOR are on the same
125 - machine as WWW that the SSL key,cert for WWW takes precedence.
126 - - Do proper setup for SSL CA certficate to be used as the server
127 - chain.
128
129 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
130 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
131
132 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
133 - depend on pcucontrol
134
135 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
136 - * validate input according to type in plc_config
137 - * added the _genicw system slice
138 - * add tag types for sites and persons
139 - * add new tags for nodes and slices for exemption from myops
140
141 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
142 - turn off drupal on a box that acts as BOOT server but not as WWW server
143 - cleanup some obsolete code for old chroot-jail packaging in the process
144 - new bootcd-kernel script for keeping bootcd variants up2date
145
146 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
147 - Make the /etc/hosts manipulation optional.
148
149 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
150 - Fix SetRole.
151
152 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
153 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
154 - into the DB.
155 - - Added the root ssh key handling support back into plc.d/ssh and the
156 - default xml file.  This should be identical to the way it was in
157 - rc12.
158 - - Added support in the db-config.d/01-init script to register the root
159 - ssh public key with the default administrator.  In this way the root
160 - ssh key will make it into the root account on the nodes by means of
161 - NodeManager's specialaccounts plugin.
162
163 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
164 - db-config ignores sliver tags
165 - sirius's db-config script renamed (was sirious)
166
167 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
168 - fix for silverauth - missing tag types now created at plc startup time
169
170 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
171 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
172
173 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
174 - companion to NM's specialaccounts plugin
175 - do not generate /etc/planetlab/root_ssh_key* anymore
176 - remove related config. variables and conf_files
177
178 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
179 - clarified description text to refer only to plcrt and not other optional
180 - packages.
181
182 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
183 - fixed a bug setting slice multiple attributes with the same tag name
184
185 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
186 - SSL setup for monitor box, and related new config variables
187 - new conf_file for /etc/planetlab/extensions
188 - various tweaks in db-config internals, about initscripts among others
189 - also more messages defined in the db
190
191 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
192 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
193
194 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
195 - bugfix in db-config, tag 4.3-19 would not fly
196
197 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
198 - Refactored db-config into snippets in db-config.d/.
199
200 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
201 - oops, tag 4.3-17 was broken and would not work
202
203 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
204 - bugfix - escape sequences inserted in xml configs
205
206 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
207 - Handle db-config.d files properly.
208
209 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
210 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
211 - than the log file
212 - - Fix db-config to be a bit more cautious when
213 - /etc/planetlab/db-config.d doesn't exist
214 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
215 - .orig files.
216 - - Refactor generic plc-config-tty code into plc_config.py.
217 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
218 - and the list of validated variables and the corresponding
219 - validator() function. This refactoring lets one reuse plc_config.py
220 - as a generic cmdline configuration tool for highly customer MyPLC
221 - like software.
222
223 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
224 - update PCU Type descriptions.
225 - updates to init scripts
226
227 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
228 - requires monitor-pcucontrol so register-wizard can work
229
230 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
231 - cleaned up plc-config-tty, no more need to configure plc-devel
232
233 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
234 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
235
236 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
237 - tighter right permissions on site_admin's authorized keys for more robustness
238
239 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
240 - fix issue in db-config that prevented correct operation
241
242 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
243 - remove support for chroot-based packaging - no crond nor syslog step anymore
244 - plc init script now named plc.init instead of former guest.init
245
246 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
247 - add Monitor to docs build
248
249 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
250 - plc_config.py and plc-config-tty: generalized to work for more diverse
251 - MyPLC configurations.
252 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
253 - deployments and increase the memory limits in php.ini
254 - plc.d/crond: add --full option to vacuumdb
255
256 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
257 - avoid generating ssl certificates for disabled services among www api boot
258
259 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
260 - cleaned up old entries in db-config
261 - mtail more robust
262
263 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
264 - php include path tweaked for plekit includes
265 - reviewed myplc (fka native) packaging dependencies
266 - renumbered 4.3
267
268 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
269 - rename myplc into myplc-chroot and myplc-native into myplc
270 - new settings (shortname & hrn_root) for local peer
271
272
273 %define module_current_branch 4.3