Setting tag MyPLC-4.3-34
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 4.3
8 %define taglevel 34
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
61 - depend on pcucontrol
62
63 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
64 - * validate input according to type in plc_config
65 - * added the _genicw system slice
66 - * add tag types for sites and persons
67 - * add new tags for nodes and slices for exemption from myops
68
69 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
70 - turn off drupal on a box that acts as BOOT server but not as WWW server
71 - cleanup some obsolete code for old chroot-jail packaging in the process
72 - new bootcd-kernel script for keeping bootcd variants up2date
73
74 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
75 - Make the /etc/hosts manipulation optional.
76
77 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
78 - Fix SetRole.
79
80 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
81 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
82 - into the DB.
83 - - Added the root ssh key handling support back into plc.d/ssh and the
84 - default xml file.  This should be identical to the way it was in
85 - rc12.
86 - - Added support in the db-config.d/01-init script to register the root
87 - ssh public key with the default administrator.  In this way the root
88 - ssh key will make it into the root account on the nodes by means of
89 - NodeManager's specialaccounts plugin.
90
91 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
92 - db-config ignores sliver tags
93 - sirius's db-config script renamed (was sirious)
94
95 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
96 - fix for silverauth - missing tag types now created at plc startup time
97
98 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
99 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
100
101 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
102 - companion to NM's specialaccounts plugin
103 - do not generate /etc/planetlab/root_ssh_key* anymore
104 - remove related config. variables and conf_files
105
106 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
107 - clarified description text to refer only to plcrt and not other optional
108 - packages.
109
110 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
111 - fixed a bug setting slice multiple attributes with the same tag name
112
113 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
114 - SSL setup for monitor box, and related new config variables
115 - new conf_file for /etc/planetlab/extensions
116 - various tweaks in db-config internals, about initscripts among others
117 - also more messages defined in the db
118
119 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
120 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
121
122 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
123 - bugfix in db-config, tag 4.3-19 would not fly
124
125 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
126 - Refactored db-config into snippets in db-config.d/.
127
128 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
129 - oops, tag 4.3-17 was broken and would not work
130
131 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
132 - bugfix - escape sequences inserted in xml configs
133
134 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
135 - Handle db-config.d files properly.
136
137 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
138 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
139 - than the log file
140 - - Fix db-config to be a bit more cautious when
141 - /etc/planetlab/db-config.d doesn't exist
142 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
143 - .orig files.
144 - - Refactor generic plc-config-tty code into plc_config.py.
145 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
146 - and the list of validated variables and the corresponding
147 - validator() function. This refactoring lets one reuse plc_config.py
148 - as a generic cmdline configuration tool for highly customer MyPLC
149 - like software.
150
151 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
152 - update PCU Type descriptions.
153 - updates to init scripts
154
155 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
156 - requires monitor-pcucontrol so register-wizard can work
157
158 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
159 - cleaned up plc-config-tty, no more need to configure plc-devel
160
161 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
162 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
163
164 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
165 - tighter right permissions on site_admin's authorized keys for more robustness
166
167 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
168 - fix issue in db-config that prevented correct operation
169
170 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
171 - remove support for chroot-based packaging - no crond nor syslog step anymore
172 - plc init script now named plc.init instead of former guest.init
173
174 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
175 - add Monitor to docs build
176
177 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
178 - plc_config.py and plc-config-tty: generalized to work for more diverse
179 - MyPLC configurations.
180 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
181 - deployments and increase the memory limits in php.ini
182 - plc.d/crond: add --full option to vacuumdb
183
184 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
185 - avoid generating ssl certificates for disabled services among www api boot
186
187 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
188 - cleaned up old entries in db-config
189 - mtail more robust
190
191 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
192 - php include path tweaked for plekit includes
193 - reviewed myplc (fka native) packaging dependencies
194 - renumbered 4.3
195
196 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
197 - rename myplc into myplc-chroot and myplc-native into myplc
198 - new settings (shortname & hrn_root) for local peer
199