Setting tag MyPLC-5.0-4
[myplc.git] / myplc-release.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name myplc-release
7 %define version 5.0
8 %define taglevel 4
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Central (PLC) release file
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: Applications/Systems
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20 BuildArch: noarch
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 %define debug_package %{nil}
28
29 %description 
30 This package contains in /etc/myplc-release the details of the
31 contents of that release. This is used by the GetPlcRelease API call.
32
33 %prep
34 %setup -q
35
36 %build
37
38 # fetch the release stamp from the build if any
39 if [ -f ../../myplc-release ] ; then
40   cp ../../myplc-release myplc-release
41 else
42   echo "Cannot find release information." > myplc-release
43   date >> myplc-release
44   echo "$HeadURL$" >> myplc-release
45 fi
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 # install it in /etc/myplc-release 
50 install -D -m 444 myplc-release ${RPM_BUILD_ROOT}/etc/myplc-release
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root,-)
57 /etc/myplc-release
58
59 %changelog
60 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-5.0-4
61 - * partial-repo.sh script
62 - * preserve key along with certificates
63
64 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-3
65 - set date.timezone to GMT if not set in php.ini for php-5.3 / fedora12
66
67 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-2
68 - legacy scripts gen-sites-xml & gen-static-content back in (sigh)
69 - new OMF category in the config
70 - create the drl system slice
71
72 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
73 - first working version of 5.0:
74 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
75 - nodefamily is 3-fold with pldistro-fcdistro-arch
76 - new PLC_FLAVOUR config category
77 - reviewed module layout
78 - cleaned up old chroot-related build stuff (does not need the build module when building anymore)
79
80 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
81 - support for fedora 12
82 - new package myplc-config for use by sfa
83 - drupal user registration turned off
84
85 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
86 - - fix to make sure when API, BOOT, MONITOR are on the same
87 - machine as WWW that the SSL key,cert for WWW takes precedence.
88 - - Do proper setup for SSL CA certficate to be used as the server
89 - chain.
90
91 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
92 - - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
93
94 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
95 - depend on pcucontrol
96
97 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
98 - * validate input according to type in plc_config
99 - * added the _genicw system slice
100 - * add tag types for sites and persons
101 - * add new tags for nodes and slices for exemption from myops
102
103 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
104 - turn off drupal on a box that acts as BOOT server but not as WWW server
105 - cleanup some obsolete code for old chroot-jail packaging in the process
106 - new bootcd-kernel script for keeping bootcd variants up2date
107
108 * Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
109 - Make the /etc/hosts manipulation optional.
110
111 * Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
112 - Fix SetRole.
113
114 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
115 - - Added "SetRole()" so that db-config.d/ scriplets can insert roles
116 - into the DB.
117 - - Added the root ssh key handling support back into plc.d/ssh and the
118 - default xml file.  This should be identical to the way it was in
119 - rc12.
120 - - Added support in the db-config.d/01-init script to register the root
121 - ssh public key with the default administrator.  In this way the root
122 - ssh key will make it into the root account on the nodes by means of
123 - NodeManager's specialaccounts plugin.
124
125 * Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
126 - db-config ignores sliver tags
127 - sirius's db-config script renamed (was sirious)
128
129 * Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
130 - fix for silverauth - missing tag types now created at plc startup time
131
132 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
133 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
134
135 * Wed Oct 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-25
136 - companion to NM's specialaccounts plugin
137 - do not generate /etc/planetlab/root_ssh_key* anymore
138 - remove related config. variables and conf_files
139
140 * Sun Sep 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-24
141 - clarified description text to refer only to plcrt and not other optional
142 - packages.
143
144 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-23
145 - fixed a bug setting slice multiple attributes with the same tag name
146
147 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-22
148 - SSL setup for monitor box, and related new config variables
149 - new conf_file for /etc/planetlab/extensions
150 - various tweaks in db-config internals, about initscripts among others
151 - also more messages defined in the db
152
153 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-21
154 - create node tags, like e.g. 'arch', that were not handled with 4.3-20
155
156 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-20
157 - bugfix in db-config, tag 4.3-19 would not fly
158
159 * Mon Jul 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-19
160 - Refactored db-config into snippets in db-config.d/.
161
162 * Thu Jul 02 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-18
163 - oops, tag 4.3-17 was broken and would not work
164
165 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-17
166 - bugfix - escape sequences inserted in xml configs
167
168 * Fri Jun 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-16
169 - Handle db-config.d files properly.
170
171 * Tue Jun 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-15
172 - - Fix /etc/init.d/plc to have command usage show up on the tty rather
173 - than the log file
174 - - Fix db-config to be a bit more cautious when
175 - /etc/planetlab/db-config.d doesn't exist
176 - - Clean up db-config approach to ignore .bak, *~, .rpm{save,new}, and
177 - .orig files.
178 - - Refactor generic plc-config-tty code into plc_config.py.
179 - plc-config-tty now contains MyPLC specific paths, "usual" variables,
180 - and the list of validated variables and the corresponding
181 - validator() function. This refactoring lets one reuse plc_config.py
182 - as a generic cmdline configuration tool for highly customer MyPLC
183 - like software.
184
185 * Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-14
186 - update PCU Type descriptions.
187 - updates to init scripts
188
189 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-13
190 - requires monitor-pcucontrol so register-wizard can work
191
192 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-12
193 - cleaned up plc-config-tty, no more need to configure plc-devel
194
195 * Tue May 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-11
196 - first draft of plc-orpha-accounts.py, and rename check-ssl-peering into plc-<>
197
198 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-10
199 - tighter right permissions on site_admin's authorized keys for more robustness
200
201 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-9
202 - fix issue in db-config that prevented correct operation
203
204 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-8
205 - remove support for chroot-based packaging - no crond nor syslog step anymore
206 - plc init script now named plc.init instead of former guest.init
207
208 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.3-7
209 - add Monitor to docs build
210
211 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
212 - plc_config.py and plc-config-tty: generalized to work for more diverse
213 - MyPLC configurations.
214 - plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
215 - deployments and increase the memory limits in php.ini
216 - plc.d/crond: add --full option to vacuumdb
217
218 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-5
219 - avoid generating ssl certificates for disabled services among www api boot
220
221 * Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-4
222 - cleaned up old entries in db-config
223 - mtail more robust
224
225 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-3
226 - php include path tweaked for plekit includes
227 - reviewed myplc (fka native) packaging dependencies
228 - renumbered 4.3
229
230 * Thu Jan 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-2
231 - rename myplc into myplc-chroot and myplc-native into myplc
232 - new settings (shortname & hrn_root) for local peer
233
234
235 %define module_current_branch 4.3